nginx php动态编译加载模块.-阿里云开发者社区

开发者社区> 技术小牛人> 正文

nginx php动态编译加载模块.

简介:
+关注继续查看

#Nginx动态编译加载模块步骤

#查看目前Nginx版本及编译模块

#[root@centos7 ~]# /opt/app/lnmp/nginx-1.12.0/sbin/nginx -V

#nginx version: nginx/1.12.0

#built by gcc 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) 

#built with OpenSSL 1.0.2k  26 Jan 2017

#TLS SNI support enabled

#configure arguments: --prefix=/opt/app/lnmp/nginx-1.12.0 --with-pcre=/opt/app/lnmp/pcre-8.40

#

#下载nginx-1.12.0源码包,并且解压.比如加载--with-http_ssl_module模块

#cd nginx-1.12.0

#./configure --prefix=/opt/app/lnmp/nginx-1.12.0 --with-pcre=/opt/app/lnmp/pcre-8.40 --with-http_ssl_module

#make  

###########################切记不能make install#####################

#此时源码包里的objs多了一个nginx启动文件.进入cd /opt/download/nginx-1.12.0/objs

#备份原来二进制nginx启动文件.

#\mv /opt/app/lnmp/nginx-1.12.0/sbin/nginx /opt/app/lnmp/nginx-1.12.0/sbin/nginx.bak

#\cp nginx  /opt/app/lnmp/nginx-1.12.0/sbin/nginx

#平滑启动: /opt/app/lnmp/nginx-1.12.0/sbin/nginx -s reload

----若是平滑升级则在平滑重启前,源码目录下make upgrade .源码包要比现有包新稳定版.


动态编译php

@进入源码包.

/opt/download/php-7.1.5/ext && ls

@进入需要加载的模块.如何GD

cd gd

@然后用原来编译安装好的php启动目录下的phpize生成configure

[root@centos7 gd] /opt/app/lnmp/php-7.1.5/bin/phpize  回车.

@把编译配置加入安装好的php-config

[root@centos7 gd] ./configure --with-php-config=/opt/app/lnmp/php-7.1.5/bin/php-config

[root@centos7 gd] make && make install

@编译完成后生成的文件存放在,完成没有报错会提示如下.

/opt/app/lnmp/php-7.1.5/lib/php/extensions/no-debug-non-zts-20160303/

@ 修改php.ini文件extension支持gd.so


本文转自  一招拜师  51CTO博客,原文链接:http://blog.51cto.com/sadoc/1946875

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
阿里云服务器怎么设置密码?怎么停机?怎么重启服务器?
如果在创建实例时没有设置密码,或者密码丢失,您可以在控制台上重新设置实例的登录密码。本文仅描述如何在 ECS 管理控制台上修改实例登录密码。
4065 0
阿里云服务器端口号设置
阿里云服务器初级使用者可能面临的问题之一. 使用tomcat或者其他服务器软件设置端口号后,比如 一些不是默认的, mysql的 3306, mssql的1433,有时候打不开网页, 原因是没有在ecs安全组去设置这个端口号. 解决: 点击ecs下网络和安全下的安全组 在弹出的安全组中,如果没有就新建安全组,然后点击配置规则 最后如上图点击添加...或快速创建.   have fun!  将编程看作是一门艺术,而不单单是个技术。
4477 0
NGINX 加载动态模块(NGINX 1.9.11开始增加加载动态模块支持)
NGINX 1.9.11开始增加加载动态模块支持,从此不再需要替换nginx文件即可增加第三方扩展。目前官方只有几个模块支持动态加载,第三方模块需要升级支持才可编译成模块。 tinywan@tinywan:~/nginx-1.
1496 0
3320
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
文娱运维技术
立即下载
《SaaS模式云原生数据仓库应用场景实践》
立即下载
《看见新力量:二》电子书
立即下载