CentOS7下安装Docker-Compose-阿里云开发者社区

开发者社区> 云原生> 正文
登录阅读全文

CentOS7下安装Docker-Compose

简介:




在使用Docker的时候,有一个工具叫做  docker-compose,安装它的前提是要安装pip工具.

1、首先检查Linux有没有安装Python-pip包,直接执行 yum install python-pip


2、没有python-pip包就执行命令 yum -y install epel-release


(3)、执行成功之后,再次执行yum install python-pip



(4)、对安装好的pip进行升级 pip install --upgrade pip



至此,pip工具就安装好了。


安装好pip之后,就可以安装Docker-Compose了.

在linunx终端执行:pip install docker-compose.

执行完之后,输入docker-compse,报如下错误:


[python] view plain copy

  1. [root@localhost ~]# docker-compose  

  2. Traceback (most recent call last):  

  3.   File "/usr/bin/docker-compose", line 5in <module>  

  4.     from pkg_resources import load_entry_point  

  5.   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3011in <module>  

  6.     parse_requirements(__requires__), Environment()  

  7.   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626in resolve  

  8.     raise DistributionNotFound(req)  

  9. pkg_resources.DistributionNotFound: backports.ssl-match-hostname>=3.5  


解决方法:在终端输入命令
pip install --upgrade backports.ssl_match_hostname


执行成功之后:docker-compose  --version 查看版本信息.


[python] view plain copy

  1. [root@localhost ~]# docker-compose -version  


  2. docker-compose version 1.8.1, build 878cff1  



本文转自gaofeng36599 51CTO博客,原文链接:http://blog.51cto.com/786678398/1933869

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
云原生
使用钉钉扫一扫加入圈子
+ 订阅

云原生时代,是开发者最好的时代

其他文章
最新文章
相关文章