zabbix在configure时候遇到的问题(Ubuntu\debian)-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

zabbix在configure时候遇到的问题(Ubuntu\debian)

简介:

在Ubuntu系统中,安装zabbix进行configure时会遇到以下4个主要问题

./configure --enable-server --enable-agent --with-mysql --enable-ipv6 --with-net-snmp --with-libcurl --with-libxml2


apt-get install -y gcc

1 configure:error:MySQL library not found

the problem is not installed mysql-devel

1.#apt-get install libghc6-hsql-mysql-dev (ubuntu )

2 configure:error:Jabber library not found


2 the problem is not installed jabber lib

1.#apt-get install libphp-jabber

2.#apt-get install libnet-jabber-loudmouth-perl

3. #apt-get install jabber-dev

4.#apt-get install libiksemel-dev (* this packet important)


3 configure:error:Not found curl Library

the problem is not installed libcurl4-openssl-dev

1.#apt-get install libcurl4-openssl-dev


4 configure:error :Not found NET-SNMP library

1.#apt-get install libsnmp-dev

2.#apt-get install snmp











本文转自 bobo5900pro  51CTO博客,原文链接:http://blog.51cto.com/bobo5900pro/1840283,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: