开发者社区> ap0581w9c> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

刷完OpenWrt在浏览器无法访问的解决办法

简介: 其实问题很明显、 是因为刷了trunk版固件、 并没有集成luci、 那接下来就是装luci、但是装luci需要联网(不过其实不联网其实也是可以安装的、) 我说的联网是让路有联网、而不是网线接路由,路由接电脑、然后电脑拨号上网、这种联网、 如何让路由联网呢? 1、最简单的方法、如果你有两个路由、或者...
+关注继续查看

其实问题很明显、 
是因为刷了trunk版固件、 
并没有集成luci、 

那接下来就是装luci、但是装luci需要联网(不过其实不联网其实也是可以安装的、) 
我说的联网是让路有联网、而不是网线接路由,路由接电脑、然后电脑拨号上网、这种联网、 
如何让路由联网呢? 
1、最简单的方法、如果你有两个路由、或者你的猫带有路由功能、 
设置你另外一个路由自动拨号、并把LAN口设置DHCP自动分配IP地址、然后用网线连接该路由LAN口到你需要配置的路由的WAN口、再把你需要配置的路由LAN口用网线与电脑相连、 
2、配置路由文件、让其自动拨号、 
如果你没有另外一个路由那你就要稍微动一下手指了、 
如果是刚刷了OpenWrt的路由、是没有密码的、我们没有密码不能使用ssh登录或者winSCP、 
所以我们先设置密码、 
用网线连接路由LAN口与电脑、 
电脑打开cmd、 

输入telnet 192.168.1.1回车


如果提示telnet不是可执行的命令、需要在 
控制面板-程序-程序和功能-打开或关闭Windows功能、 
把telnet服务端和telnet客户端勾选、确定、 
执行上述命令后将登录到路由、我们设密码、 
输入 

passwd root


提示 
Changing password for root 
New password: 
输入密码、这里注意、你输入时屏幕不会有反应、输入完密码回车就是了、 
提示 
Retype password: 
再次输入密码、输入完回车、 
虽然在telnet里也可以配置联网、但是我建议使用winSCP来配置、比较清晰、操作也比较方便、 
下载winSCP、运行、 



主机名填写 192.168.1.1 
端口默认22 
用户名   root 
密码输入你刚刚设置的密码、 
协议设置为SCP 
点登录、 
可能会提示group错误、确定就是了、不会有影响、 
打开后是如下界面: 

点   .. 
这个图标回到上级文件夹、 
进入到/etc/config/  文件夹、 
修改network文件、双击打开、提示错误直接确定、 

我的配置文件如下、大家在wan的配置下、修改proto为pppoe并加上用户名密码、具体参照我的配置: 

config interface ‘loopback’ 
option ifname ‘lo’ 
option proto ‘static’ 
option ipaddr ’127.0.0.1′ 
option netmask ’255.0.0.0′ 
config interface ‘lan’ 
option ifname ‘eth0′ 
option type ‘bridge’ 
option proto ‘static’ 
option ipaddr ’192.168.36.1′ 
option netmask ’255.255.255.0′ 
config interface ‘wan’ 
option ifname ‘eth1′ 
option _orig_ifname ‘eth1′ 
option _orig_bridge ‘false’ 
option proto ‘pppoe’ 
option username ‘ABCDEFG’                    ‘ABCDEFG’改为你的宽带帐号、 
option password ’123456′                          ‘123456’改为你的宽带密码、 
config switch 
option name ‘eth0′ 
option reset ’1′ 
option enable_vlan ’1′ 
config switch_vlan 
option device ‘eth0′ 
option vlan ’1′ 
option ports ’0 1 2 3 4′


点击保存、保存时会有错误、确定就是了、 
成功保存后(可关闭再次打开该文件看看是否已经成功保存、)、 
重启路由即可、(重启就是拔了电源再插上) 
3、使用无线连接、 
因为此方法不太实用、在此我就不详述了、 
路由器联网后、 
我们使用putty这个软件使用ssh登录、(因为我们已经设置了密码、所以不能用telnet登录了、) 
没有putty软件的同学点此下载、(也可使用SecureCRT.rar) 
打开putty 

主机名输入 192.168.1.1 
端口选择 22 
连接类型选择ssh 
打开、 
用户名root 
密码为你自己设置的、 
登录后 
逐步输入以下命令、 

opkg update 
opkg install luci luci-i18n-chinses


等待下载并安装好luci以及luci中文包后、再输入以下命令启用页面、 

/etc/init.d/uhttpd enable 
/etc/init.d/uhttpd start


现在打开你的浏览器、输入 http://192.68.1.1 
看看、配置页面是不是出现了?

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
Retrofit+OkHttp实现Cookie持久化,RxJava方式
Retrofit+OkHttp实现Cookie持久化,RxJava方式
45 0
阿里云Redis公网连接的解决办法
https://help.aliyun.com/document_detail/43850.html   前提条件 如果您需要从本地 PC 端访问 Redis 实例进行数据操作,可以通过在 ECS 上配置端口映射或者端口转发实现。
7635 0
CSDN博客使用MarkDown编辑器bug解决办法
前段时间使用CSDN开始梳理自己的知识结构,主要是使用JupyterNotebook编辑,然后使用md模式导出,再用csdn自带的md编辑器上传导入。
845 0
在Windows中实现Java调用DLL(转载)
本文提供调用本地 C 代码的 Java 代码示例,包括传递和返回某些常用的数据类型。本地方法包含在特定于平台的可执行文件中。就本文中的示例而言,本地方法包含在 Windows 32 位动态链接库 (DLL) 中。
1814 0
flexpaper实例在浏览器无法显示的解决办法
想用flexpaper显示swf,但是为什么在ie和谷歌浏览器下连自带的例子都显示不了呢,在火狐下可以的? flexpaper实例从官网上面下载之后,发现直接打开运行,在ie里面可以显示,但是在谷歌浏览器里面却不显示,网上说可以添加信任进去,我也添加了信任(http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html)进去,但是不可能产品发布之后让每一个客户都去动态设置信任吧,那样的话还不如不开发。
1138 0
DEDE在后台设置启用多站点绝对网址RSS出错解决办法
DEDE在后台设置启用多站点绝对网址RSS出错解决办法 - 发表于:DEDE技术吧 - Dede教程 今天偶然发现,栏目下的rss.xml路径全部重复,原来以前开启了启用多站点绝对网址就出现这种情况了,下面我们讲述解决方法: 我们打开 include/arc.
710 0
+关注
578
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载