ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3
栈和队列:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
using namespace std;
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
char str1[10];
int m;
scanf("%d%s",&m,str1);
if(!strcmp(str1,"FIFO"))
{
queue <int >sq;
while(m--)
{
char str2[10];
scanf("%s",str2);
if(!strcmp(str2,"IN"))
{
int b;
scanf("%d\n",&b);
sq.push(b);
}
else
{
if(sq.empty())
printf("None\n");
else
{
printf("%d\n",sq.front());
sq.pop();
}
}
}
}
else
{
stack <int >st;
while(m--)
{
char str2[10];
scanf("%s",str2);
if(!strcmp(str2,"IN"))
{
int b;
scanf("%d\n",&b);
st.push(b);
}
else
{
if(st.empty())
printf("None\n");
else
{
printf("%d\n",st.top());
st.pop();
}
}
}
}
}
return 0;
}
【 注释: 】int strcmp( string str1 , string str2 )
注意该比较区分大小写。
参数
str1第一个字符串。
str2第二个字符串。
返回值
如果 str1小于 str2,返回负数;如果 str1大于 str2,返回正数;二者相等则返回 0。(相等时返回0)