oracle rac 11g 日志占满系统盘导致数据库down掉

简介:

oracle日志占满系统盘满了导致数据库挂掉 并且archivelog日志也满了倒是数据库无法open,无法登陆,幸好还可以到mount状态。解决办法:

1.根据报错查看 表象: crs 服务down掉 
CRS-0184: Cannot communicate with the CRS daemon
删除/var/tmp/.oracle 目录
删除oracle alter日志:
cd /u01/app/oracle/rdbms/bol/BOL1/alter
rm -rf *

到此重启机器 可以启动oracle的所以服务,但是不能启动oracle的db服务

启动db服务的时候报错如下:
PRCR-1079 : 无法启动资源 ora.orcl.db ORA-03113: end-of-file on communication channel

解决办法:
su - oracle 
sqlplus / as sysdba

startup mount##rac上面2台都要做

查看是否为归档模式:
archive log list

查看闪回分区大小:
show parameter db_recovery_file_dest_size

查看archlog log使用率:
select * from v$flash_recovery_area_usage; --查看空间占用率,如果 ARCHIVED LOG 超过90%,Oracle随时有宕机的危险

增大闪回分区大小:
alter system set db_recovery_file_dest_size=xxG;##rac 操作一台即可

启动数据库:

alter database open ##rac 上面2台机器都要做

到此之后,可以连接数据库了,但是现在需要做的是清楚数据库的归档日志,因为现在只是增大了db_recovery的空间而已,我们需要清理掉不需要的归档日志,获得空间。
清除归档日志脚本:
#!/bin/bash
source /home/oracle/.bash_profile 
#LOGFILE=/data/rman/rman_delete.log 
#RMAN=$ORACLE_HOME/bin/rman 
$ORACLE_HOME/bin/rman log=/home/oracle/del_arch$(date +%Y-%m-%d).log <<EOF 
connect target sys/xxxx@xxx 
crosscheck archivelog all; 
delete noprompt expired archivelog all; 
delete noprompt archivelog until time 'sysdate-3'; 
exit; 
EOF

直接在root目录下运行即可。到此问题解决完成,记录一下,日后可以使用。

本文转自  674591788  51CTO博客,原文链接:http://blog.51cto.com/mrdeng/2066568

相关实践学习
【涂鸦即艺术】基于云应用开发平台CAP部署AI实时生图绘板
【涂鸦即艺术】基于云应用开发平台CAP部署AI实时生图绘板
相关文章
|
Oracle 关系型数据库 Linux
【赵渝强老师】Oracle数据库配置助手:DBCA
Oracle数据库配置助手(DBCA)是用于创建和配置Oracle数据库的工具,支持图形界面和静默执行模式。本文介绍了使用DBCA在Linux环境下创建数据库的完整步骤,包括选择数据库操作类型、配置存储与网络选项、设置管理密码等,并提供了界面截图与视频讲解,帮助用户快速掌握数据库创建流程。
995 93
|
12月前
|
Oracle 关系型数据库 Linux
【赵渝强老师】使用NetManager创建Oracle数据库的监听器
Oracle NetManager是数据库网络配置工具,用于创建监听器、配置服务命名与网络连接,支持多数据库共享监听,确保客户端与服务器通信顺畅。
529 0
|
SQL Oracle 关系型数据库
Oracle数据库创建表空间和索引的SQL语法示例
以上SQL语法提供了一种标准方式去组织Oracle数据库内部结构,并且通过合理使用可以显著改善查询速度及整体性能。需要注意,在实际应用过程当中应该根据具体业务需求、系统资源状况以及预期目标去合理规划并调整参数设置以达到最佳效果。
753 8
|
Oracle 关系型数据库 数据库
数据库数据恢复—服务器异常断电导致Oracle数据库报错的数据恢复案例
Oracle数据库故障: 某公司一台服务器上部署Oracle数据库。服务器意外断电导致数据库报错,报错内容为“system01.dbf需要更多的恢复来保持一致性”。该Oracle数据库没有备份,仅有一些断断续续的归档日志。 Oracle数据库恢复流程: 1、检测数据库故障情况; 2、尝试挂起并修复数据库; 3、解析数据库文件; 4、导出并验证恢复的数据库文件。
|
缓存 关系型数据库 BI
使用MYSQL Report分析数据库性能(下)
使用MYSQL Report分析数据库性能
688 158
|
关系型数据库 MySQL 数据库
自建数据库如何迁移至RDS MySQL实例
数据库迁移是一项复杂且耗时的工程,需考虑数据安全、完整性及业务中断影响。使用阿里云数据传输服务DTS,可快速、平滑完成迁移任务,将应用停机时间降至分钟级。您还可通过全量备份自建数据库并恢复至RDS MySQL实例,实现间接迁移上云。
|
关系型数据库 MySQL 数据库
阿里云数据库RDS费用价格:MySQL、SQL Server、PostgreSQL和MariaDB引擎收费标准
阿里云RDS数据库支持MySQL、SQL Server、PostgreSQL、MariaDB,多种引擎优惠上线!MySQL倚天版88元/年,SQL Server 2核4G仅299元/年,PostgreSQL 227元/年起。高可用、可弹性伸缩,安全稳定。详情见官网活动页。
1820 152
|
关系型数据库 MySQL 数据库
阿里云数据库RDS支持MySQL、SQL Server、PostgreSQL和MariaDB引擎
阿里云数据库RDS支持MySQL、SQL Server、PostgreSQL和MariaDB引擎,提供高性价比、稳定安全的云数据库服务,适用于多种行业与业务场景。
1245 156
|
缓存 监控 关系型数据库
使用MYSQL Report分析数据库性能(中)
使用MYSQL Report分析数据库性能
819 156
|
缓存 监控 关系型数据库
使用MYSQL Report分析数据库性能(上)
最终建议:当前系统是完美的读密集型负载模型,优化重点应放在减少行读取量和提高数据定位效率。通过索引优化、分区策略和内存缓存,预期可降低30%的CPU负载,同时保持100%的缓冲池命中率。建议每百万次查询后刷新统计信息以持续优化
853 161

推荐镜像

更多