[ACMcoder] Max Sum

简介: Problem Description Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

解题思路

动态规划

实现代码

#include <iostream>
using namespace std;

int main()
{
    int caseCount, numCount;
    int caseIndex, numIndex;
    cin>>caseCount;
    for (caseIndex = 1; caseIndex <= caseCount; caseIndex++)
    {
        cin>>numCount;
        int num;
        int local_max = 0;
        int global_max = 0x80000000;
        int start, end;
        int temp = 1;
        for (numIndex = 1; numIndex <= numCount; numIndex++)
        {
            cin>>num;
            local_max += num;
            if (local_max > global_max)
            {
                global_max = local_max;
                start = temp;
                end = numIndex;
            }

            if (local_max < 0)
            {
                local_max = 0;
                temp = numIndex + 1;
            }
        }

        cout<<"Case "<<caseIndex<<":"<<endl;
        cout<<global_max<<" "<<start<<" "<<end<<endl;
        if (caseIndex != caseCount)
            cout<<endl;
    }
}
目录
相关文章
|
4月前
|
SQL 数据库
MAX() 函数
MAX() 函数
44 6
|
5月前
|
人工智能 BI
|
12月前
|
移动开发 安全 JavaScript
MAX4/11/03/016/08/1/1/00 MAX-4/11/01/008/08/1/1/00
MAX4/11/03/016/08/1/1/00 MAX-4/11/01/008/08/1/1/00
50 0
|
5月前
|
编译器 C++
C++ max函数与min函数
C++ max函数与min函数
157 0
|
12月前
|
机器学习/深度学习
计算sum=1+2...+n,要求number和sum的类型都是int,且sum在32位以内~
计算sum=1+2...+n,要求number和sum的类型都是int,且sum在32位以内~
|
12月前
|
UED
C400/A8/1/1/1/00 MAX-4/11/03/128/99/1/0/00
C400/A8/1/1/1/00 MAX-4/11/03/128/99/1/0/00
33 0
|
人工智能 算法
1305:Maximum sum
1305:Maximum sum
|
文件存储
Sum of Round Numbers
Sum of Round Numbers
113 0
Sum of Round Numbers