八、用路由器模拟帧中继交换机配制
8.1、拓扑图
(注:这个模拟完全可以用模拟器作,而且IE的机试一定要考的)
图上所示是一个部分网状的帧中继的拓扑,其中R7中模拟帧中继交换机,R1为中心路由器,R2和R3为分支路由器
8.2
、基本配制
R1 ==========================================
host R1
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
int s1/2
encap frame
ip add 192.168.192.1 255.255.255.0
no sh
frame map ip 192.168.192.2 102 broadcast
frame map ip 192.168.192.4 103 broadcast
!
int loop 0
ip add 192.168.10.10 255.255.255.0
R2 ==========================================
host R2
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
int s1/2
encap frame
ip add 192.168.192.2 255.255.255.0
no sh
frame map ip 192.168.192.1 201 broadcast
frame map ip 192.168.192.4 201 broadcast
no frame inverse-arp
int loop 0
ip add 192.168.20.20 255.255.255.0
!
R3 ==========================================
host R3
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
int s1/2
encap frame
ip add 192.168.192.4 255.255.255.0
no sh
frame map ip 192.168.192.1 301 broadcast
frame map ip 192.168.192.2 301 broadcast
no frame inverse-arp
int loop 0
ip add 192.168.30.30 255.255.255.0
!
R7 ==========================================
路由器模拟frame-relay交换机配制
host Frame-Swith
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
frame switching
!
interface Serial1/0
no ip directed-broadcast
clock rate 56000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
no sh
!
interface Serial1/1
no ip directed-broadcast
clock rate 56000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
no sh
!
interface Serial1/2
no ip directed-broadcast
clock rate 56000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
no sh
!
R1 ==========================================
host R1
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
int s1/2
encap frame
ip add 192.168.192.1 255.255.255.0
no sh
frame map ip 192.168.192.2 102 broadcast
frame map ip 192.168.192.4 103 broadcast
!
int loop 0
ip add 192.168.10.10 255.255.255.0
R2 ==========================================
host R2
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
int s1/2
encap frame
ip add 192.168.192.2 255.255.255.0
no sh
frame map ip 192.168.192.1 201 broadcast
frame map ip 192.168.192.4 201 broadcast
no frame inverse-arp
int loop 0
ip add 192.168.20.20 255.255.255.0
!
R3 ==========================================
host R3
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
int s1/2
encap frame
ip add 192.168.192.4 255.255.255.0
no sh
frame map ip 192.168.192.1 301 broadcast
frame map ip 192.168.192.2 301 broadcast
no frame inverse-arp
int loop 0
ip add 192.168.30.30 255.255.255.0
!
R7 ==========================================
路由器模拟frame-relay交换机配制
host Frame-Swith
no ip domain-look
line con 0
logg sy
exec-time 0 0
!
frame switching
!
interface Serial1/0
no ip directed-broadcast
clock rate 56000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
no sh
!
interface Serial1/1
no ip directed-broadcast
clock rate 56000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
no sh
!
interface Serial1/2
no ip directed-broadcast
clock rate 56000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
no sh
!
当所有基本都配制好后,我们就可以在R1、R2、R3之间互相ping串口的IP,如果能通就说明帧中继正常工作。但是我们是不能ping 对方的loopback0的地址。
当然也可以用一些查看帧中继的命来查看
Show fram map
Show fram pvc
Show ip route
来验证
8.3、配制OSPF
注意事项:配制时须要指明网络类型
R1:
int s1/2
ip ospf network point-to-multipoint
router ospf 1
net 192.168.192.0 0.0.0.255 area 0
net 192.168.10.0 0.0.0.255 area 0
R2:
int s1/2
ip ospf network point-to-multipoint
router ospf 1
net 192.168.192.0 0.0.0.255 area 0
net 192.168.20
.0 0.0.0.255 area 0
R3:
int s1/2
ip ospf network point-to-multipoint
router ospf 1
net 192.168.192.0 0.0.0.255 area 0
net 192.168.30
.0 0.0.0.255 area 0
此时配制完成
我们可以在一个路由器上
ping另一个路由器的loopback0地址,如果通就说明配制成功
也可以用
show ip route来查看是不是有对方的loopback0路由
本文转自zcm8483 51CTO博客,原文链接:http://blog.51cto.com/haolun/993022