eigrp chalenge labl-阿里云开发者社区

开发者社区> 安全> 正文
登录阅读全文

eigrp chalenge labl

简介:

wKiom1NY09PDMbCoAADafzWHFyw784.jpg

1按照拓扑分配IP地址。带宽64k,2eigp AS=1,3关闭自动汇总4在r4的lookback口上手工汇总 5设置r1 -r2 hello时间 6设置 r2--r3 send 7md5加密 key=cisco 8用tclsh测试路由之间连通性 

R1#show run 
Building configuration... 

Current configuration : 1300 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname R1 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 




!          













!  




interface Loopback0 
ip address 172.16.1.1 255.255.255.0 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 

interface Serial1/0 
bandwidth 64 
ip address 172.16.12.1 255.255.255.0 
ip hello-interval eigrp 1 2 
serial restart-delay 0 

interface Serial1/1 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/2 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/3 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/4 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/5 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/6 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/7 
no ip address 
shutdown 
serial restart-delay 0 

router eigrp 1 
network 172.16.12.0 0.0.0.255 
no auto-summary 


no ip http server 
no ip http secure-server 






control-plane 






gatekeeper 
shutdown 


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 


end 
hostname r2 
R2#show run 
Building configuration... 

Current configuration : 1411 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname R2 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 




!          













!  




interface Loopback0 
ip address 172.16.2.1 255.255.255.0 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 

interface Serial1/0 
bandwidth 64 
ip address 172.16.12.2 255.255.255.0 
ip hello-interval eigrp 1 2 
serial restart-delay 0 

interface Serial1/1 
bandwidth 64 
ip address 172.16.23.2 255.255.255.0 
ip hello-interval eigrp 1 2 
ip hold-time eigrp 1 3 
serial restart-delay 0 

interface Serial1/2 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/3 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/4 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/5 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/6 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/7 
no ip address 
shutdown 
serial restart-delay 0 
!          
router eigrp 1 
network 172.16.12.0 0.0.0.255 
network 172.16.23.0 0.0.0.255 
no auto-summary 


no ip http server 
no ip http secure-server 






control-plane 






gatekeeper 
shutdown  


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 


end 

hostname r3 
R3#show run 
*Mar 19 21:22:58.827: %SYS-5-CONFIG_I: Configured from console by console 
R3#show run 
Building configuration... 

Current configuration : 1708 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname R3 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 




!          
key chain cisco 
key 1 
 key-string haha 














!  




interface Loopback0 
ip address 172.16.3.1 255.255.255.248 

interface Loopback1 
ip address 172.16.3.33 255.255.255.248 

interface Loopback2 
ip address 172.16.3.65 255.255.255.248 

interface Loopback4 
ip address 172.16.3.97 255.255.255.248 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 

interface Serial1/0 
bandwidth 64 
ip address 172.16.23.3 255.255.255.0 
ip hello-interval eigrp 1 2 
ip hold-time eigrp 1 3 
serial restart-delay 0 
!          
interface Serial1/1 
ip address 172.16.34.3 255.255.255.0 
ip authentication mode eigrp 1 md5 
ip authentication key-chain eigrp 1 cisco 
serial restart-delay 0 

interface Serial1/2 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/3 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/4 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/5 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/6 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/7 
no ip address 
shutdown 
serial restart-delay 0 

router eigrp 1 
network 172.16.0.0 0.0.7.255 
network 172.16.16.0 0.0.7.255 
network 172.16.32.0 0.0.7.255 
no auto-summary 


no ip http server 
no ip http secure-server 
!          





control-plane 






gatekeeper 
shutdown 


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 


end 

hostname r4 
R4#show run 
Building configuration... 

Current configuration : 1664 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname R4 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 




!          
key chain cisco 
key 1 
 key-string haha 














!  




interface Loopback0 
ip address 172.16.4.1 255.255.255.248 
ip summary-address eigrp 1 172.16.0.0 255.255.0.0 5 

interface Loopback1 
ip address 172.16.4.33 255.255.255.248 

interface Loopback2 
ip address 172.16.4.65 255.255.255.248 

interface Loopback3 
ip address 172.16.4.97 255.255.255.248 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 

interface Serial1/0 
bandwidth 64 
ip address 172.16.34.4 255.255.255.0 
ip authentication mode eigrp 1 md5 
ip authentication key-chain eigrp 1 cisco 
serial restart-delay 0 

interface Serial1/1 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/2 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/3 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/4 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/5 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/6 
no ip address 
shutdown 
serial restart-delay 0 

interface Serial1/7 
no ip address 
shutdown 
serial restart-delay 0 

router eigrp 1 
network 172.16.0.0 0.0.7.255 
network 172.16.32.0 0.0.7.255 
no auto-summary 


no ip http server 
no ip http secure-server 

!          




control-plane 






gatekeeper 
shutdown 


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 
!          

end 

汇总到r4的lookback口 
R4#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP 
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
      E1 - OSPF external type 1, E2 - OSPF external type 2 
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 
      ia - IS-IS inter area, * - candidate default, U - per-user static route 
      o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

    172.16.0.0/16 is variably subnetted, 12 subnets, 3 masks 
C       172.16.4.32/29 is directly connected, Loopback1 
C       172.16.34.0/24 is directly connected, Serial1/0 
D       172.16.3.32/29 [90/40640000] via 172.16.34.3, 00:02:12, Serial1/0 
D       172.16.23.0/24 [90/41024000] via 172.16.34.3, 00:03:00, Serial1/0 
D       172.16.12.0/24 [90/41536000] via 172.16.34.3, 00:03:17, Serial1/0 
C       172.16.4.0/29 is directly connected, Loopback0 
D       172.16.0.0/16 is a summary, 00:28:30, Null0 
D       172.16.3.0/29 [90/40640000] via 172.16.34.3, 00:02:12, Serial1/0 
C       172.16.4.96/29 is directly connected, Loopback3 
D       172.16.3.96/29 [90/40640000] via 172.16.34.3, 00:02:12, Serial1/0 
C       172.16.4.64/29 is directly connected, Loopback2 
D       172.16.3.64/29 [90/40640000] via 172.16.34.3, 00:02:12, Serial1/0 

用tclsh测试 
R4(tcl)#foreach address { 
+>(tcl)#172.16.12.1 
+>(tcl)#172.16.12.2 
+>(tcl)#172.16.23.2 
+>(tcl)#172.16.23.3 
+>(tcl)#172.16.3.1  
+>(tcl)#172.16.3.33 
+>(tcl)#172.16.3.65 
+>(tcl)#172.16.3.97 
+>(tcl)#172.16.4.1  
+>(tcl)#172.16.4.33 
+>(tcl)#172.16.4.65 
+>(tcl)#172.16.4.97 
+>(tcl)#} { 
+>(tcl)#ping $address 
+>(tcl)#} 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/137/204 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/88/152 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/94/176 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/76/112 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/72/176 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.3.33, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/76 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.3.65, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/69/112 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.3.97, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/52/104 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.33, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.65, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.97, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 m 



R2(config-if)#ip hold-time eigrp 1 3 
R2(config-if)#do show ip eig ne      
IP-EIGRP neighbors for process 1 
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                           (sec)         (ms)       Cnt Num 
1   172.16.23.3             Se1/1              2 00:06:32  108   648  0  10 
0   172.16.12.1             Se1/0             12 00:10:03  121   726  0  5 

R3(config-if)#do show ip eig ne 
IP-EIGRP neighbors for process 1 
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                           (sec)         (ms)       Cnt Num 
1   172.16.34.4             Se1/1             13 00:05:57  102   918  0  5 
0   172.16.23.2             Se1/0              2 00:06:15  110   660  0  14 

R3#show ip eigrp in detail  
IP-EIGRP interfaces for process 1 

                       Xmit Queue   Mean   Pacing Time   Multicast    Pending 
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes 
Lo0                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Lo1                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Lo2                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 

                       Xmit Queue   Mean   Pacing Time   Multicast    Pending 
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Lo4                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Se1/0              1        0/0       117      10/380        840           0 
 Hello interval is 2 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 8/9 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 3 
 Retransmissions sent: 0  Out-of-sequence rcvd: 1 
 Authentication mode is not set 
 Use unicast 
Se1/1              1        0/0       115       0/15         491           0 
 Hello interval is 5 sec 

                       Xmit Queue   Mean   Pacing Time   Multicast    Pending 
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 6/12 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 6 
 Retransmissions sent: 1  Out-of-sequence rcvd: 0 
 Authentication mode is md5,  key-chain is "cisco" 
 Use unicast 

R4#show ip eigrp in detail  
IP-EIGRP interfaces for process 1 

                       Xmit Queue   Mean   Pacing Time   Multicast    Pending 
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes 
Lo0                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Lo1                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Lo2                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 

                       Xmit Queue   Mean   Pacing Time   Multicast    Pending 
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Lo3                0        0/0         0       0/1            0           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0 
 Retransmissions sent: 0  Out-of-sequence rcvd: 0 
 Authentication mode is not set 
 Use multicast 
Se1/0              1        0/0       114      10/380        876           0 
 Hello interval is 5 sec 
 Next xmit serial <none> 
 Un/reliable mcasts: 0/0  Un/reliable ucasts: 5/22 
 Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 6 
 Retransmissions sent: 8  Out-of-sequence rcvd: 1 
 Authentication mode is md5,  key-chain is "cisco" 
 Use unicast 











本文转自zhang25yun51CTO博客,原文链接: http://blog.51cto.com/1585654/1402035,如需转载请自行联系原作者



版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
+ 订阅

云安全开发者的大本营

其他文章
最新文章
相关文章