课程第七天内容《基础交换七》-阿里云开发者社区

开发者社区> 云计算> 正文

课程第七天内容《基础交换七》

简介:

案例一: 子网划分
   需求:
       基于给定的IP地址进行子网划分;
        1、给定IP地址为 - 137.26.19.200 /17
        2、对IP地址所属于的网段进行子网划分:
             #确保有7个网段;
             #每个网段的可用主机数量为 35 ;
             #确保每个网段尽量减少可用IP地址的浪费;
        3、写出每个网段的IP地址空间范围;
    步骤分解:
        1、计算出给定IP地址所在的网段(网络地址)
    ip     1000 1001 . 0001 1010 . 0001 0011 . 1100 1000  
    mask 1111 1111   1111 1111   1000 0000   0000 0000  
          所以,网络地址为:
            1000 1001 . 0001 1010 . 0000 0000 . 0000 0000
            1111 1111   1111 1111   1000 0000   0000 0000
       
              最终计算所得,网络地址为-   137.26.0.0 /17
          
        2、计算新网段的主机位的个数,假设 主机位个数为 n ;
              2的n次方 , 减2 , 大于等于35 ;  
                  n=6
        3、计算出每个新网段的网络位的个数:
                   32-6 = 26 ;
              所以,每个新网段的子网掩码应该为: /26
               
        4、故,最终的每个新网段的IP地址范围为:
                      137.26.0.0 /26
 网段1   1000 1001 . 0001 1010 . 0000 0000 . 0000 0000 /26
            137.26.0.0/26 -137.26.0.63/26
                  
 网段2   1000 1001 . 0001 1010 . 0000 0000 . 0100 0000 /26
            137.26.0.64/26 -  
            
 网段3   1000 1001 . 0001 1010 . 0000 0000 . 1000 0000 /26
 
 网段4   1000 1001 . 0001 1010 . 0000 0000 . 1100 0000 /26
 
 网段5   1000 1001 . 0001 1010 . 0000 0001 . 0000 0000 /26
 
 网段6   1000 1001 . 0001 1010 . 0000 0001 . 0100 0000 /26
 
 网段7   1000 1001 . 0001 1010 . 0000 0001 . 1000 0000 /26      
 
-----------------------------------------------------------
案例二:静态路由配置
实验名称 :静态路由原理
 
实验拓扑 :
 
实验需求 :
    1、依据图中所示,配置终端PC与路由器的 IP地址;
    2、配置路由器的静态路由,确保两个PC可以互相 ping 通;
 
实验步骤 :
    1、配置主机 PC-1 的 IP地址与网关IP地址;
    2、配置路由器 R1 的 互联端口 IP 地址;
    3、配置主机 PC-2 的 IP地址与网关IP地址;  
    4、配置路由器 R2 的 互联端口 IP 地址;  
    5、在 R1 配置去往 192.168.20.0 /24的路由;
R1(config)# ip route 192.168.20.0 255.255.255.0 192.168.12.2
    6、在 R2 配置去往 192.168.10.0 /24的路由;
R2(config)# ip route 192.168.10.0 255.255.255.0 192.168.12.1
    7、验证与 测试 :
        路由条目验证,
           R1#show ip route //查看 R1 的路由表;
           R2#show ip route //查看 R2 的路由表;
        PC-1与PC-2之间进行互相 ping 通测试;
          PC-1> ping 192.168.20.1  
          PC-2> ping 192.168.10.1     
 
实验结果 :
    终端主机互相Ping通;
     
实验总结 :
    认识网关:
        1、是一个接口级别的概念,而不是设备级别的概念;
        2、是以一个 IP 地址的形式体现和配置的;
        3、对于源主机而言,去往“其他网段”时,才使用“网关”;
        4、网关IP地址所在的端口的所属设备,必须具备连接多个
           网段的功能,即必须具备路由功能 - 路由器/多层交换机
 
    认识路由:
        结构组成-  
     类型  网段/掩码 [属性] via 下一跳 ;
      
    认识路由工作原理:
        基于目标IP地址,查看路由表;
      
------------------------------------------------------
案例三:DHCP配置
实验名称:DHCP工作原理
实验拓扑:
 
实验需求:
      1、通过 server 实现 DHCP 服务器配置;
            server 地址为 - 192.168.10.253 /24
      2、为客户端自动分配IP地址 - 192.168.10.0/24
         网关地址 - 192.168.10.254
         DNS server 地址 - 8.8.8.8
      3、通过路由器,连接不同的网段,确保不同网段的主机互通;
实验步骤:
      1、配置 Server 的IP地址 和网关
      2、开启 Server 的 DHCP 服务
      3、配置 Server 的 DHCP 地址池
      4、保存 Server 的 DHCP 地址池  
      5、配置 PC 为 DHCP客户端
      6、验证 PC 是否获得 IP 地址 : ipconfig /all  
      7、配置 路由器 与 交换机的互联端口的IP地址;
GateWay(config)#interface gi0/0   // 10.0/24的网关
GateWay(config-if)# no shutdown
GateWay(config-if)# ip address 192.168.10.254 255.255.255.0  
 
GateWay(config)#interface gi0/0   // 20.0/24的网关
GateWay(config-if)# no shutdown
GateWay(config-if)# ip address 192.168.20.254 255.255.255.0
 
实验结果:
    PC-1 与 PC-2 均可以获得 IP 地址、网关地址、DNS服务器地址
    PC-1 与 PC-2 互相 ping 通;
    
实验总结:
    DHCP 是 客户端/服务器模式;
    DHCP server 自身的 IP 地址,必须与客户端在同一个网段;
 
 
-----------------------------------------------------------
 
案例四:DHCP中继
实验名称 : DHCP 中继配置
实验拓扑:
实验需求:
     1、配置 Server 同时为多个网段自动分配IP地址;
     2、A网段主机IP地址为 - 192.168.10.0/24  
         网关地址 - 192.168.10.254
         DNS-Server - 8.8.8.8
        B网段主机IP地址为- 192.168.20.0/24  
         网关地址 - 192.168.20.254
         DNS-Server - 9.9.9.9
     3、确保两个网段的 PC 可以互相访问;
实验步骤:
    1、配置 PC 为 DHCP 客户端
    2、配置 配置每个网段的“网关IP”
GateWay(config)#interface gi0/0    //A网段的网关端口;
GateWay(config-if)#no shutdown  
GateWay(config-if)#ip address 192.168.10.254 255.255.255.0  
 
GateWay(config)#interface gi0/1    //B网段的网关端口
GateWay(config-if)#no shutdown  
GateWay(config-if)#ip address 192.168.10.254 255.255.255.0  
           
    3、配置 DHCP 服务器,为不同网段创建对应地址池
          #配置 server 使用的IP地址  
               192.168.10.253   
               255.255.255.0  
               192.168.10.254 // A 网段的网关IP地址;
          #为A/B网段创建对应的 DHCP 地址池;
              -确保每个网段的“网关IP”配置正确;
    4、为 B 网段的网关配置“DHCP中继”
         GateWay(config)#service dhcp   //开启 DHCP 功能;
         GateWay(config)#interface gi0/1  
         GateWay(config-if)#ip helper-address 192.168.10.253
    5、验证与测试
         PC-1>ipconfig /all  
         PC-2>ipconfig /all  
          
         PC-1>ping 192.168.20.1  
实验结果:
 
实验总结:
    当DHCP客户端与服务器不在相同网段时,才使用 DHCP 中继;
    DHCP中继命令,需要配置在 DHCP客户端所在网段的网关端口上;
    DHCP客户端的网关端口所在的设备,必须开启 DHCP 服务;
    DHCP 服务器,必须配置正确的网关IP地址;
    DHCP 服务器配置的 DHCP 地址池中的网关IP必须与 DHCP 中继  
       命令所在端口的 IP 地址相同,否则无法准确定位到对应的
       DHCP地址池。
```````````````````````````````````````````````````````````````````````````````````````````````````````
以太网/LAN(local area network )的相关概念:
 
   问题:
       信号传输距离有限;
   解决方案:
        中继器 - 放大电信号,延长信息的传输距离;
        
    中继器带来的问题:
        只有2个端口,连接设备少;
    解决方案:
        集线器 - 多端口的中继器,可以连接多个设备;
    集线器的问题:
        不同终端设备发送的信号,会产生冲突;
    针对信号冲突的缓解方案:
          CSMA/CD ,带有冲突检测的,载波侦听多路访问机制;
          引入新的设备 :  
               网桥(bridge) - 隔离冲突域;
                 问题:    
                     网桥设备端口较少,只能连接2个设备;
                 解决方案:
                      引入新的设备 :
                          交换机 - 多端口的网桥,可以实现
                                   冲突域的隔离;        
-----------------------------------------------------------
           
交换机的工作原理:
    1、首先查看数据包的“目标 MAC 地址”;
    2、将目标 MAC 地址与“MAC地址表”中的条目进行匹配;
        成功,则从对应的端口转发出去;
        失败,则广播(从除入端口以外的其他所有端口发出去);    
        
    1、MAC地址啥样子?
           长度为48bit;
           通过16进制表示;
           结构:
              厂商代码 - 24bit
              自己的编码 - 24bit        
                      (每个生产厂商给自己生产的网卡的编号)
    数据包结构:                   
    源MAC -- 目标MAC
    源IP  -- 目标IP    
                         
    2、MAC地址表啥样子?
          每个条目都是 MAC 地址与 Port的对应关系,
          表示去往该 MAC 地址的数据,从对应的 Port 发送出去;
        MAC表如何形成:
            静态配置;
            动态学习 -  
              1、当交换机在端口上收到数据包以后,首先查看
                源MAC地址,从而形成 源MAC 与 入端口的对应关系
              2、分析数据包的 目标MAC地址,并且查找 MAC地址表
                     -能找到对应的MAC条目,则在对应端口转发;
                     -如果找不到对应的条目,则广播;
    
    3、两者如何匹配?
          1、显示 MAC 地址表  
                SW1# show mac-address-table  
    
    4、MAC表的动态条目存活时间:
                   300秒;
------------------------------------------------------
    
16进制:
    0-9,a,b,c,d,e,f
 
2进制:
    0-1
 
10进制:
    0-9
 
记住:
    一个16进制,等同于 4 个2进制;





      本文转自云计算王森 51CTO博客,原文链接:http://blog.51cto.com/13426941/1981379,如需转载请自行联系原作者



版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

其他文章