linux 下将tomcat注册成服务并开机启动

简介:
#!/bin/bash  
# This is the init script for starting up the  
#  Jakarta Tomcat server  
#  
# chkconfig: 345 91 10  
# description: Starts and stops the Tomcat daemon.  
#  

# Source function library.  
. /etc/rc.d/init.d/functions  

# Get config.  
. /etc/sysconfig/network  

# Check that networking is up.  
[ "${NETWORKING}" = "no" ] && exit 0  

export JAVA_HOME=/usr/local/java/jdk1.7.0_79 ------jdk路径,这里要根据实际路径修改
tomcat_home=/usr/local/java/apache-tomcat-7.0.77-----tomcat路径,也是根据实际路径修改
startup=$tomcat_home/bin/startup.sh  
shutdown=$tomcat_home/bin/shutdown.sh  

start(){  
   echo -n "Starting Tomcat service:"  
   cd $tomcat_home  
   $startup  
   echo "tomcat is succeessfully started up"  
}  

stop(){  
   echo -n "Shutting down tomcat: "  
   cd $tomcat_home  
   $shutdown  
   echo "tomcat is succeessfully shut down."  
}  

status(){  
    numproc=`ps -ef | grep catalina | grep -v "grep catalina" | wc -l`  
    if [ $numproc -gt 0 ]; then  
       echo "Tomcat is running..."  
    else  
       echo "Tomcat is stopped..."  
    fi  
}  

restart(){  
   stop  
   start  
}  

# See how we were called.  
case "$1" in  
start)  
   start  
   ;;  
stop)  
   stop  
   ;;  
status)  
   status  
   ;;  
restart)  
   restart  
   ;;  
*)  
   echo $"Usage: $0 {start|stop|status|restart}"  
   exit 1  
esac

将以上代码复制并拷贝到文件tomcat文件中,vim tomcat复制以上内容
chmod +x tomcat ——添加执行权限
mv tomcat /etc/rc.d/init.d/ ——将tomcat文件拷贝到服务目录下
添加tomcat服务
chkconfig - -add tomcat
chkconfig tomcat on——开机启动tomcat服务
service tomcat start/stop/restart ——启动tomcat命令
注意:如果发现执行启动tomcat命令还是无法启动,请确认jdk bin目录是否有执行权限
linux 下将tomcat注册成服务并开机启动
确定jdk版本使用以下命令
linux 下将tomcat注册成服务并开机启动
如果发现jdk使用的是系统自带的openjdk,可以卸载掉
rpm -qa | grep jdk
rpm -e - - nodeps java-1.7.0-openjdk***
卸载完成后再执行java -version确认jdk版本是否正确。










本文转自 rm_rf_db 51CTO博客,原文链接:http://blog.51cto.com/12185273/2049163,如需转载请自行联系原作者
目录
相关文章
|
11月前
|
Linux 网络安全 Docker
盘古栈云,创建带ssh服务的linux容器
创建带ssh服务的linux容器
520 146
|
12月前
|
缓存 安全 Linux
六、Linux核心服务与包管理
在没有网络的情况下,使用系统安装光盘是获取RPM包的常用方法。场景二:配置本地文件镜像源 (使用系统安装光盘/ISO)(检查RPM包的GPG签名以保证安全) 或。YUM/DNF包管理工具 (yum/dnf)(此处可以放置您为本主题制作的思维导图)处理依赖问题的危险选项 (应极力避免)(覆盖文件、替换已安装包)。(list) 则是列出文件。(query file) 是。(假设系统安装光盘已挂载到。信息 (verbose)。(upgrade) 选项。(all) 已安装的包。(package) 选项
778 11
|
Java 关系型数据库 MySQL
在Linux平台上进行JDK、Tomcat、MySQL的安装并部署后端项目
现在,你可以通过访问http://Your_IP:Tomcat_Port/Your_Project访问你的项目了。如果一切顺利,你将看到那绚烂的胜利之光照耀在你的项目之上!
658 41
|
开发框架 Java 关系型数据库
在Linux系统中安装JDK、Tomcat、MySQL以及部署J2EE后端接口
校验时,浏览器输入:http://[your_server_IP]:8080/myapp。如果你看到你的应用的欢迎页面,恭喜你,一切都已就绪。
909 17
|
Java 关系型数据库 MySQL
在Linux操作系统上设置JDK、Tomcat、MySQL以及J2EE后端接口的部署步骤
让我们总结一下,给你的Linux操作系统装备上最强的军队,需要先后装备好JDK的弓箭,布置好Tomcat的阵地,再把MySQL的物资原料准备好,最后部署好J2EE攻城车,那就准备好进军吧,你的Linux军团,无人可挡!
668 18
|
Linux Shell
在Linux、CentOS7中设置shell脚本开机自启动服务
以上就是在CentOS 7中设置shell脚本开机自启动服务的全部步骤。希望这个指南能帮助你更好地管理你的Linux系统。
2453 25
|
关系型数据库 MySQL Java
安装和配置JDK、Tomcat、MySQL环境,以及如何在Linux下更改后端端口。
遵循这些步骤,你可以顺利完成JDK、Tomcat、MySQL环境的安装和配置,并在Linux下更改后端端口。祝你顺利!
799 11
|
开发框架 关系型数据库 Java
Linux操作系统中JDK、Tomcat、MySQL的完整安装流程以及J2EE后端接口的部署
然后Tomcat会自动将其解压成一个名为ROOT的文件夹。重启Tomcat,让新“植物”适应新环境。访问http://localhost:8080/yourproject看到你的项目页面,说明“植物”种植成功。
426 10
|
Linux iOS开发 MacOS
Gitea Enterprise 23.4.0 (Linux, macOS, Windows) - 本地部署的企业级 Git 服务
Gitea Enterprise 23.4.0 (Linux, macOS, Windows) - 本地部署的企业级 Git 服务
544 0
Gitea Enterprise 23.4.0 (Linux, macOS, Windows) - 本地部署的企业级 Git 服务
|
监控 Linux
Linux systemd 服务启动失败Main process exited, code=exited, status=203/EXEC
通过以上步骤,可以有效解决 systemd 服务启动失败并报错 `Main process exited, code=exited, status=203/EXEC` 的问题。关键在于仔细检查单元文件配置、验证可执行文件的有效性,并通过日志分析具体错误原因。确保可执行文件路径正确、文件具有执行权限,并且可以独立运行,将有助于快速定位和解决问题。
7016 7