开发者社区> 技术小胖子> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

云计算网络基础第四天

简介:
+关注继续查看

设备初始化配置:

      IOS 

     用户模式

 特权模式

     switch > enable 

 switch #  ?/ tab 

                 switch #config  terminal 

         switch(config)#hostname  SW1

         switch(config)#no ip  domainlookup 

         switch(config)# line console 0

         switch(config-line)# exec-timeout 0 0 

         switch(config-line)#exit

         switch(config)# enable password   cisco 

         switch(config)# enable secrect   cisco1


         switch(config)#interface vlan 1 

         switch(config-if)#no shutdown

         switch(config-if)#ip address 192.168.1.1          

                               255.255.255.0


         PC -> 运行--> cmd  ---->telnet  192.168.1.1 

             

            问题:

                默认情况下无法登录成功;

 

            共识:

                网络设备的本地管理接口 - console 0 网络设备远程管理接口 - vty 

                        ---> 默认情况下,开启了认证;


            成功远程访问:

                   @ 配置远程访问密码;

       sw1(config)# line vty  0 4

                       sw1(config-line)# password   

           cisco123    

                   @ 关闭远程访问的认证;

       sw1(config)# line vty  0 4

                       sw1(config-line)# no login 

   


=========================================================


IP地址作用:

    在一定范围内,唯一的表示一个网络设备;


IP地址结构:

    网络位 + 主机位 ,长度 32 bit ;

                   bit - 位 ; 

                   Byte - 字节; 1Byte = 8bit 


    子网掩码 :

        与IP地址中的位一一对应,用于区分IP地址的结构;

            子网掩码中的1对应的位,称之为网络位;

            子网掩码中的0对应的位,称之为主机位;


IP地址和子网掩码的表示方式:

        ip-address :101010101010000101010

mask :       111111111111100000000

点分十进制:

        X.X.X.X (X 为 10 进制)

m.m.m.m   or     /n  (例如:/24 )

二进制与十进制的相互转换:

    0000 0000 -->  0 

1111 1111 -->  255

      210.1.9.8 255.255.255.0 

 

            2的N次方:

    0    7 

 X 除以 2 , 取余数 ; 从下向上写; 


            16进制:

    0 - 9 , a , b , c , d , e ,f 


 网卡地址(MAC地址):

    运行--> CMD ---> ipconfig |  ipconfig /all

  



特殊IP地址:

      每一个网段中都存在 2 个特殊的IP地址:

        网络地址 - IP 地址中的主机位全为0 ; 

广播地址 - IP 地址中的主机位全为1;


========================================================


IP地址空间不足/浪费解决方案:


1、划分公有地址和私有地址:

      私有地址空间 - 

      A  0 -- 127  /8 

     

    10.0.0.0 ---  10.255.255.255  (8)

          

  B  128 -- 191   /16

  

        172.16.0.0  ---  172.31.255.255 (12)

      2 的 20 次方; 

     

  

  C  192 -- 223   /24

  

        192.168.0.0  --- 192.168.255.255  (16) 

  

   网段A : 192.168.1.0/24 --> 256 个 IP 地址;

                                      可用IP - 254 

              

       网段B : 192.168.2.0/24 --> 256 个 IP 地址;

                                      可用IP - 254      

  

  D  224 --  239 (组播地址)

    

    239.0.0.0  ---  239.255.255.255   (8)

  

---------------------------------------------------------

子网划分: (192.168.1.0 /24 , 总共可用地址 254 )


    1、首先确定主机位;

      2 的 N 次方 ,减 2 个特殊IP地址,必须大于等于28

  所以 N 取值 5 ; 

2、确定新的IP网段的网络地址:

      新的网段的网络位 为 27 位 (32-5);

      所以新的网段为:

      192.168.1.0000 0000   /27

                    192.168.1.0 -- 192.168.1.31  /27

  

  192.168.1.0010 0000   /27

  192.168.1.0100 0000   /27

  192.168.1.0110 0000   /27

  192.168.1.1000 0000   /27

  192.168.1.1010 0000   /27

  192.168.1.1100 0000   /27

  192.168.1.1110 0000   /27

  

    

---------------------------------------------------------


前提:

   规划网络之初,甲方给定一个 A  类网络:10.10.1.0/20 ;

   以给定的网段为基础进行IP地址规划;

要求:

   为每栋楼宇分配一个网段(8栋楼)

   每个网段70台主机;

   请写出每个网段的IP地址范围,以及网络地址、广播地址;

   尽量减少每个网段中的IP地址浪费;

   

思路:

    1、首先确定给定IP地址的网络地址;

2、其次确定新的网络地址中的主机位个数;

3、再次确定新的网络地址中的网络位;

3、再次确定新的网络地址中的网络



----------------------------------------------------------


交换:

   相同网段之间互通,称之为 交换; 

   

   

路由:

   不同网段之间互通,称之为  路由 ; 

   

   实现:

       路由设备;

       -  路由器 

   -  多层交换机

  

   本质:

           通过一个“路由表”实现“不同网段之间的路由功能”;    

查看路由表:

   R1# show  ip  route  ; 


   注意:

        某些型号的多层交换机,默认没有开启路由功能;

SW# configuration  terminal

SW(config)#  ip  routing     // 开启路由功能;

       

R1#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M -    

       mobile, B - BGP


   在显示的内容中,如果有“codes”,则说明开启了路由功能;



-------------------------------------------------------------


R1 :

      192.168.12.1 -----> 192.168.23.2

                      192.168.23.3 


原因:

     没有路由条目; 

 

 

静态路由: 

R1(config)# ip route  192.168.23.0 255.255.255.0  gi0/0

      or   

R1(config)# ip route 192.168.23.0 255.255.255.0            

                                          192.168.12.2 



R3(config)# ip route 192.168.12.0 255.255.255.0 192.168.23.2


建议:

    在配置静态路由时,使用第二种配置方式;减少 ARP 报文的发送



关闭3层端口的代理ARP:

     R2(config)#interface gi0/1

 R2(config-if)# no ip proxy-arp 

----------------------------------------------------------


路由器的工作原理:

    1、路由器仅仅关心数据中的 “ 目标IP 地址” ; 

2、路由器提取 目标IP地址,与 路由表中的条目进行匹配:

       如果匹配成功,则转发;

   如果匹配不成功,则丢弃;    

匹配原则:

    最长匹配原则。

匹配过程:

     举例 - R1 的 192.168.12.1 访问目标 192.168.23.3 

 

 1、首先查看 R1 的 路由表  - show  ip  route 

      S 192.168.23.0 /24 [1/0] via 192.168.12.2

  

 2、以上条目中,首先查看其中的子网掩码长度 /24 

           表示该条目仅仅查看目标IP地址中前面24位;

                如果目标IP地址中的前24位,

                与路由条目中前面的24位,完全相同,

                  则表示匹配成功,转发出去;

                如果与路由条目前面的24位,不相同;

                  则表示匹配失败,丢弃数据包;

-------------------------------------------------------------


1、配置每个设备的接口IP地址;


R1


Router(config)#hostname R1   // 更改设备名字;


R1(config)#no ip domain-lookup // 关闭域名查询;


R1(config)#interface GigabitEthernet0/0 // 配置互联接口;

R1(config-if)# no shutdown 

R1(config-if)# ip address 192.168.12.1 255.255.255.0



~~~~~~~~~~~~~~

R1


Router(config)#hostname R2   // 更改设备名字;


R2(config)#no ip domain-lookup // 关闭域名查询;


R2(config)#interface GigabitEthernet0/1 // 配置互联接口 - R1

R2(config-if)# no shutdown 

R2(config-if)# ip address 192.168.12.2 255.255.255.0



R2(config)#interface GigabitEthernet0/0 // 配置互联接口 - R3

R2(config-if)# no shutdown 

R2(config-if)# ip address 192.168.23.2 255.255.255.0



~~~~~~~~~~


Router(config)#hostname R3   // 更改设备名字;


R3(config)#no ip domain-lookup // 关闭域名查询;


R3(config)#interface GigabitEthernet0/1 // 配置互联接口;

R3(config-if)# no shutdown 

R3(config-if)# ip address 192.168.23.3 255.255.255.0



2、在R1上创建 “静态路由条目” ,去往目标地址; 


R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2


 

3、在 R3 上创建去往 R1 的 静态路由条目 ; 

R3(config)#ip route 192.168.12.0 255.255.255.0 192.168.23.2



4、验证与测试

    R1# show  ip   route  

    R1# ping 192.168.23.3

    ping 192.168.23.2 



注意:

    路由条目,下一跳必须可达,才能进入路由表。

      下一跳可以是:

              端口 - 必须为设备本身的端口;

              IP地址 - 必须是对端设备的互联端口的IP地址; 


--------------------------------   


路由属性:


    管理距离(Admin Distance) :

     表示路由条目的稳定性;取值范围 0 -- 255 ;

 值越小表示越稳定; 

 当值达到255时,不会放入路由表; 

 每种类型的路由,都有一个默认的管理距离;

    比如 , 直连路由管理距离 为 0 ; 

        静态路由管理距离 为 1 ;


    度量值(metric):

          表示路由器去往该目标网段的距离;

          越小越好;   

  对于直连和静态路由,metric 都为0  ,且不可以更改

 



注意:   

    当去往同一个网络具有多个条目时,会进行路由属性的比较,

选择一个最优的,放入路由表:

    1、首先比较 AD , 越小越好;

2、如果AD相同,则比较Metric , 越小越好; 

3、如果都相同,则同时放入路由表,形成”负载均衡“;


出口链路备份配置:

    浮动静态路由 - 

         即调整出口静态路由的管理距离为非默认值;

R2(config)# ip route 192.200.1.1  255.255.255.255 

                                   192.178.12.1 // 主链路; 

R2(config)# ip route 192.200.1.1 255.255.255.255 

     192.178.23.3  9  //备份链路的路由 AD 调整为 9 ; 



测试步骤:

   1、配置完成之后,查看 R2 路由表,仅有主链路路由进入;

   2、关闭R2上连接 R1 的端口(模拟主链路故障),此时备份链路

       对应的路由(管理距离为9)进入路由表;

   3、开启R2上连接 R1 的端口(模拟主链路故障修复), 此时备份

      链路所对应的路由”跳出“路由表,主链路路由进入;

IP地址浪费解决方案:

        公有地址/私有地址;

        子网划分

    优点

缺点

        IPv6 - 128bit ;

     

 

    ARP 

  MAC :物理地址,全球范围内,唯一的指定一个物理设备;

  

  确定通信设备/终端, 一定要 IP 地址与 MAC 地址结合;


      即,必须形成IP地址与MAC地址的对应关系,如下:

         IP --- MAC     

      对应关系的形成方式:

             手动 - 

 自动 - ARP 

     分类 -  ARP 

         代理ARP

 ARP病毒

 无故ARP

   

     R1 -----  R2   ----  R3   

 

    R1 : ping 192.168.23.3

                源IP - 192.168.12.1 

                目标IP - 192.168.23.3 

                问题: 不通 ; 

定位:路由;

定义:什么是路由?如何实现?

     不同网段之间的设备互通,称之为路由; 

 通过 具有路由功能的设备来实现:

            路由器

多层交换机

                                    本质:

    路由表;

路由器的工作过程:

      仅仅关注数据包的”目标IP地址“

  然后将其与路由表中的路由条目进行”匹配“

       匹配成功,则转发;

   不成功,则丢弃;


          条目匹配举例:

      数据包 - 192.168.12.1  ----> 192.168.23.3 

  

              查看路由表 --- R1# show ip route 

  

  C 192.168.12.0 /24  is directly   gi0/0 

  

  手动添加去往目标IP地址所需要的路由:

  R1(config)# ip route 192.168.23.0 255.255.255.0

                                   192.168.12.2 

  

  R1# show ip route 

  S 192.168.23.0 /24 [1/0] via , 192.168.12.2 

  C 192.168.12.0 /24  is directly   gi0/0 

  

路由 与 ARP 关系:

        1、首先通过路由,确定数据转发方向;

2、其次获得具体目标IP对应的物理地址;即 ARP ; 


------------------------------------------------------

Router 作为 DHCP 服务器: 


1、配置 Router 地址:

    Router(config)#hostname GateWay

GateWay(config)#interface gi0/0

GateWay(config-if)# no shutdown 

GateWay(config-if)# ip address 192.168.1.1 255.255.255.0


2、启动 DHCP 服务 :

  GateWay(config)# service dhcp 


3、配置 DHCP 地址池:

   GateWay(config)# ip dhcp pool CCIE

   GateWay(dhcp-config)# network 192.168.1.0 255.255.255.0

   GateWay(dhcp-config)# default-router 192.168.1.254

   GateWay(dhcp-config)# dns-server 8.8.8.8 

4、配置 DHCP 客户端 :

     点击 - ”DHCP“ ;


5、验证命令:

       在服务器端的验证命令:

                   GateWay# show ip dhcp binding 

   GateWay# show running-config 

       在客户端的验证:

                    运行--> cmd ---> ipconfig /all    



6、特殊地址处理:

    内网有业务服务器,编址如下:

     web - 192.168.1.20    /24

 email  - 192.168.1.75 /24

 FTP - 192.168.1.88    /24 

  OA - 192.168.1.166   /24 

    DHCP 地址排除:

  GateWay(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10


  注意:

    low 地址与 high 地址不同,则表示一段连续的IP;

如果相同,则表示”排除一个地址“;

---------------------------------------------------------

Switch 作为 DHCP 服务器:


1、配置交换机的IP地址;

  Switch(config)# interface vlan 1 

  Switch(config-if)# no shutdown 

  Switch(config-if)# ip address 192.168.1.250 255.255.255.0

2、启动 DHCP 服务 :

  Switch(config)# service dhcp

3、配置 DHCP 的排除地址:

  Switch(config)# ip dhcp excluded-address 192.168.1.1 

                                           192.168.1.20  

4、配置 DHCP 地址池 :

   Switch(config)# ip dhcp pool CCNP

    Switch(dhcp-config)# network 192.168.1.0 255.255.255.0

Switch(dhcp-config)# default-router 192.168.1.1 

Switch(dhcp-config)# dns-server  8.8.8.8

5、配置 DHCP 客户端 ; 

6、验证:

Switch#show ip interface brief  // 查看交换机接口IP地址配置;

Switch#show running-config     //查看 DHCP 的相关配置命令;

Switch#show ip dhcp binding //查看DHCP服务器分配成功的IP地址

  

    在 PC 上 : 

 ipconfig /all   // 在 PC 的命令行中查看自动获取的IP地址

      ping  x.x.x.x // 在 PC1 上 测试与 PC2 的 连通性;   



---------------------------------------------------------


需求:

   确保医院中的财务部、门诊部、药房 ,属于不同的网段;

   每个部门的主机,自动获取IP地址;

   网段分别为:

       财务部 - 192.168.1.0 / 24  ; 

            192.168.1.254 (网关)

8.8.8.8 (DNS-server)

       门诊部 - 192.168.2.0 / 24  ; 

            192.168.2.254 (网关)

7.7.7.7 (DNS-server)

       药房   - 192.168.3.0 / 24  ; 

            192.168.3.254 (网关)

9.9.9.9 (DNS-server)

    确保部门内部和部门之间的主机都可以互相 Ping 通 ; 


路由器配置命令:

Router(config)#interface gi0/0     // 财务部网关接口;

Router(config-if)# no shutdown 

Router(config-if)# ip address 192.168.1.254   255.255.255.0

Router(config-if)#description GW-CaiWu 


Router(config)#interface gi0/0     // 门诊部网关接口;

Router(config-if)# no shutdown 

Router(config-if)# ip address 192.168.2.254   255.255.255.0

Router(config-if)#description GW-MenZhen 


Router(config)#interface gi0/0     // 药房网关接口;

Router(config-if)# no shutdown 

Router(config-if)# ip address 192.168.3.254   255.255.255.0

Router(config-if)#description GW-YaoFang 



该项目出于成本控制方面的考虑,建议节省3台服务器,将

交换机作为 DHCP server :


SW1(config)#interface vlan 1 

SW1(config-if)#no shutdown

SW1(config-if)#ip address 192.168.1.250  255.255.255.0 


SW1(config)# ip dhcp pool CaiWu 

SW1(dhcp-config)# network 192.168.1.0  255.255.255.0

SW1(dhcp-config)# default-router 192.168.1.254

SW1(dhcp-config)# dns-server  8.8.8.8

SW1(dhcp-config)# exit

SW1(config)# service dhcp 



SW2(config)#interface vlan 1 

SW2(config-if)#no shutdown

SW2(config-if)#ip address 192.168.2.250  255.255.255.0 


SW2(config)# ip dhcp pool MenZhen 

SW2(dhcp-config)# network 192.168.2.0  255.255.255.0

SW2(dhcp-config)# default-router 192.168.2.254

SW2(dhcp-config)# dns-server  7.7.7.7

SW2(dhcp-config)# exit

SW2(config)# service dhcp 



SW3(config)#interface vlan 1 

SW3(config-if)#no shutdown

SW3(config-if)#ip address 192.168.3.250  255.255.255.0


SW3(config)# ip dhcp pool MenZhen 

SW3(dhcp-config)# network 192.168.3.0  255.255.255.0

SW3(dhcp-config)# default-router 192.168.3.254

SW3(dhcp-config)# dns-server  9.9.9.9

SW3(dhcp-config)# exit

SW3(config)# service dhcp  



-------------------------------------------------------

DHCP Relay 配置:(仅在门诊楼与药房的网关端口进行配置)

     将路由器 配置为 DHCP relay , 需要在每个部门的

 网关端口上进行配置 - 

Router(config)# interface gi0/2

Router(config-if)# description GW-YaoFang

Router(config-if)# ip helper-address  192.168.1.250

                      // 此时该网关端口接收到 DHCP  discover

  报文以后,会将广播报文,以单播的方式

  发送到该 DHCP 服务器 - 192.168.1.250 ;

  并且源地址为 192.168.3.254 , 

    目标地址为 192.168.1.250 ,

Router(config)# service dhcp // 作为DHCP中继,必须要开启DHCP;

注意:

    当 DHCP 服务器上具有多个 DHCP 地址池时,

服务器是通过 DHCP 报文 中的源IP地址来进行地址池区分的;

在 DHCP relay 环境中,本质上就是根据每个部门的网关IP地址

来决定的;

-----------------------------------------------------

在 DHCP 服务器 上,配置三个网关的 DHCP 地址池;

同时,在 DHCP 服务器上配置 ”网关IP“地址 :

        确保 DHCP 服务器能够回应其他部门/网段的 

DHCP 客户端发送的 DHCP 报文;


------------------------------------------------------------


浮动静态路由回顾:

    作用 - 

   实现链路备份;

      当主链路活动的时候,针对主链路的路由,进入路由表;

  主链路故障以后,

  备份链路针对的路由(管理距离大于1的),进入路由表;

  主链路修复以后,管理距离为 1 的路由,会再次进入路由

  表,之前针对备份链路的路由,被排挤出路由表。

  因为,在路由表中,针对一个目标网络,只能是存在

  一个最好的,比较原则:

     首先比较 AD ,值越小越好;

 如果AD相同,则比较 Metric,值越小越好;

此处的备份链路的路由,是通过调整 AD 值来实现的;

    

    浮动路由/备份路由 的 配置命令:

Router(config)# ip route 192.168.50.0 255.255.255.0 

                                       192.168.23.3   200

验证命令

     show ip route 

     show  ip  route  192.168.50.0 

         该命令查看的是一个具体的路由条目的详细信息:

例如:

R1#show ip route 192.168.50.0

Routing entry for 192.168.50.0/24

Known via "static", distance 1, metric 0

  Routing Descriptor Blocks:

  * 192.168.12.2

      Route metric is 0, traffic share count is 1



     本文转自hj_1314wgn 51CTO博客,原文链接:http://blog.51cto.com/13513556/2048354,如需转载请自行联系原作者





版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
CloudService计算类技术和网络类技术以及存储类技术的基础学习
CloudService计算类技术和网络类技术以及存储类技术的基础学习
0 0
Linux网络基础编程|学习笔记
快速学习Linux网络基础编程
0 0
数通路由交换之网络基础(一)
硬件方面:通过介质(例如,网线、光纤、无线WIFI)将网络设备和终端连接起来。软件方面:操作系统、应用软件、应用程序相互通讯。网络作用:实现资源共享、信息传递。 Internet组成:Internet由多个ISP(运营商)组成,例如移动、电信、联通等众多运营商组成。 网络通信中的“语言” 汉语和英语当做协议 聊天当做通信 说话内容当做数据决定数据的格式和传输的一组规则语言不通,无法沟通、语言一致,通信自如。协议一致,通信自如。所以想要实现通信,网络设备要用统一
0 0
计算机网络——网络基础_网络命令的使用(配置主机IP、ipconfig、ping、tracert、arp实战)
任务要求 打开Windows 10的命令(控制台)窗口。 实验步骤 有多种方法打开Windows命令(控制台)窗口。其中一种较为快速的方法是: 在键盘上按下“Win+R"组合键,系统将打开“运行"窗口,如图1-1所示。键入cmd.按回车键或单击“确定”按钮,Windows将打开命令(控制台)窗口,显示俞令提示符,如图1-2所示。
0 0
《图解HTTP》读书总结-第一章-了解Web及网络基础
本文为个人总结的《图解HTTP》第一章的读书笔记
0 0
了解Web以及网络基础
了解Web以及网络基础
0 0
ESP32-C3入门教程 网络 篇(三、 MQTT 协议基础介绍及测试)
在前面,我们已经学会了 ESP32-C3 的WiFi 配置以及使用,为我们学习网络协议建立了基础。 这篇文章我们就来学习测试一下ESP32-C3 的 MQTT 驱动。
0 0
Linux网络基础
Linux网络基础
0 0
网络基础 - 默认网关是什么?
网络基础 - 默认网关是什么?
0 0
文章
问答
文章排行榜
最热
最新
相关电子书
更多
边缘云计算技术及标准化白皮书(2018)
立即下载
《云网络概念手册》
立即下载
云上大数据与AI开发范式的演进
立即下载