PIX配置手册二(telnet和ssh)

简介:

PIX配置手册二 telnet and ssh


telnet

打开telnet允许所有:

conf t

telnet 0 0 inside  :允许任何人访问

telnet 0 0 outside


打开telnet指定某个主机:

telnet 1.1.1.2 255.255.255.255 inside


设置进入特权模式密码:

passwd cisco encrypted (+encrypted是加密秘钥,如果不加则是明文)

设置进入全局模式密码:

enable password cisco1 encrypted (如果前者加了encrypted,此次则可以省略encrypted)


查看telnet回话:

who


pixfirewall#   who

       0: 1.1.1.2


查看telnet配置信息:

sh running-config telnet 或者sh running-config



如果有长链接的telnet,清空telnet配置

clear conn protocol tcp all



默认pix认为外部是不安全的,不让telnet;

低版本的将outside改成别的名字

(而不能直接修改outside安全级别,会显示outside是默认预留的),

再将接口安全级别设置为5以及5以上就可以了;然后who

会看到以下类似的:

2.2.2.2 255.255.255.255 out(而不是outside)就可以访问。


完整配置:

hostname pixfirewall

enable password WdJQMntV/mB02tJF encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0

nameif outside

security-level 0

ip address 2.2.2.1 255.255.255.0

!

interface Ethernet1

nameif inside

security-level 100

ip address 1.1.1.1 255.255.255.0



telnet 0.0.0.0 0.0.0.0 outside (可以不配置默认不让外部telnet)

telnet 1.1.1.0 255.255.255.0 inside

telnet timeout 5



删除telnet配置信息:

no telnet 0 0 outside

no telnet 1.1.1.0 255.255.255.0 inside





ssh 加密终端访问协议:


创建加密的公私钥:

 给pix命名字

 hostname

 需要创建一个域名

 domain aaa.com

 产生一个秘钥

 ca gen rsa key 512  一路回车(由于版本不同ca generate rsa key 512或者crypto key generate rsa modulus 1024)


打开ssh

ssh 0 0 inside  :允许任何人访问

ssh 0 0 outside  :允许任何人访问


打开ssh指定某个主机:

ssh 1.1.1.2 255.255.255.255 inside


设置密码

passwd cisco


ssh登陆会提示让输入用户名和密码。pix默认有一个pix的用户名密码就是passwd的密码

ssh -l pix 1.1.1.1


ssh默认是允许outside访问的



 crypto key zeroize rsa 清空秘钥


 sh crypto key mypubkey rsa 查看秘钥


 ca generate rsa key 512或者crypto key generate rsa modulus 1024 设置秘钥


 username cisco password cisco encrypted privilege 15


 enable password cisco 特权密码


 ssh timeout 60  超时时间


 ca save all 保存ca秘钥


 write memory 保存PIX配置


另外提供pix 635.bin 下载  http://down.51cto.com/data/1164311




     本文转自506554897 51CTO博客,原文链接:http://blog.51cto.com/506554897/1406868,如需转载请自行联系原作者


相关文章
|
1月前
|
Linux 网络安全 开发工具
Centos6.5安装并配置Telnet服务
该内容是一个关于如何安装配置Telnet服务的教程。首先,通过yum安装vim、xinetd、telnet和telnet-server。接着,修改/etc/xinetd.d/telnet配置文件,将disable改为no,并设置访问限制(如限定特定网段和时间)。关闭防火墙,重启服务。创建测试用户后,分别使用CentOS和Windows的Telnet客户端进行连接测试,显示成功,实验完成。
65 1
|
11天前
|
Shell 网络安全 开发工具
github多用户ssh配置
在Windows 10环境下,当需使用多个GitHub账号进行开发操作时,可通过生成多个SSH密钥对并配置SSH `config` 文件实现。步骤包括:1) 使用`ssh-keygen`命令为每个账号生成密钥对,保存在`C:\Users\<USERNAME>\.ssh`目录;2) 编辑`config`文件,设定每个Host对应的身份文件和用户信息,如果需要,配置代理;3) 验证通过`git clone`不同仓库来确保配置正确。
22 0
|
17天前
/etc/xinetd.d/telnet 配置信息说明
【5月更文挑战第27天】/etc/xinetd.d/telnet 配置信息说明
16 0
|
22天前
|
安全 Shell 网络安全
GitHub SSH 快速配置
这是一个自动化脚本,用于简化设置 Git SSH 连接的过程。功能包括:设置 Git 用户名和邮箱、生成新的 SSH 密钥、将 SSH 私钥添加到 ssh-agent、可选复制 SSH 公钥到剪贴板、提供 GitHub 配置指引以及测试 SSH 连接。用户需确保安装 Git 和 SSH 工具,然后下载脚本并赋予执行权限,按照提示操作即可。适合 Git 初学者或需要快速配置 SSH 的用户。
|
1月前
|
网络安全
|
1月前
|
数据安全/隐私保护 Windows
配置用户通过Telnet登录设备认证
配置用户通过Telnet登录设备认证
|
1月前
|
安全 网络安全 数据安全/隐私保护
ensp中aaa(3a)实现telnet远程连接认证配置命令
ensp中aaa(3a)实现telnet远程连接认证配置命令
|
1月前
|
网络协议 安全 Shell
配置ssh服务
配置ssh服务
|
网络安全