开发者社区> 科技小能手> 正文

安装PHP5、PHP7

简介:
+关注继续查看

安装 PHP5

PHP(Hypertext Preprocessor)英文超级文本预处理语言。PHP是一种HTML内嵌式的语言,是一种在服务端执行的嵌入HTML文档的脚本语言。官网:www.php.net

  • 下载并解压安装包

    切换目录至/usr/local/src/:
    [root@localhost ~]# cd /usr/local/src/
    下载源码包:
    [root@localhost src]# wget http://cn2.php.net/distributions/php-5.6.30.tar.bz2
    解压包:
    [root@localhost src]#tar jxv -f php-5.6.30.tar.bz2

  • 配置源码包

    [root@localhost src]# cd php-5.6.30/
    [root@localhost php-5.6.30]# ./configure --prefix=/usr/local/php --with-apxs2=/usr/local/apache2.4/bin/apxs --with-config-file-path=/usr/local/php/etc --with-mysql=/usr/local/mysql --with-pdo-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-libxml-dir --with-gd --with-jpeg-dir --with-png-dir --with-freetype-dir --with-iconv-dir --with-zlib-dir --with-bz2 --with-openssl --with-mcrypt --enable-soap --enable-gd-native-ttf --enable-mbstring --enable-sockets --enable-exif

    参数说明:
    --prefix=/usr/local/php #指定安装目录
    --with-apxs2=/usr/local/apache2.4/bin/apxs #该文件是Apache的一个工具,可以将扩展模块添加到Apache的module文件。
    --with-config-file-path=/usr/local/php/etc #指定配置文件所在路径
    --with-mysql=/usr/local/mysql #指定mysql的路径
    --with-pdo-mysql=/usr/local/mysql 
    --with-mysqli=/usr/local/mysql/bin/mysql_config
    #上面两行定义mysql相关函数和驱动

    #下面的这些为php配置常用的模块
    --with-libxml-dir 
    --with-gd 
    --with-jpeg-dir
    --with-png-dir 
    --with-freetype-dir 
    --with-iconv-dir 
    --with-zlib-dir 
    --with-bz2 
    --with-openssl 
    --with-mcrypt 
    --enable-soap 
    --enable-gd-native-ttf 
    --enable-mbstring 
    --enable-sockets 
    --enable-exif

  • 配置过程中一些常见错误

报错1:

configure: error: xml2-config not found. Please check your libxml2 installation.
说明:缺少xml2库。

解决办法,安装 libxm12-devel

查找相关的库安装包:
[root@localhost php-5.6.30]# yum list |grep libxml2

安装库文件:
[root@localhost php-5.6.30]# yum install -y libxml2-devel

报错2:

configure: error: Cannot find OpenSSL's <evp.h>
说明:缺少OpenSSL's。

解决办法,安装openssl-devel

[root@localhost php-5.6.30]# yum install -y openssl-devel

报错3:

configure: error: Please reinstall the BZip2 distribution
说明:重新安装bZip2。

解决办法,安装bzip2-devel

[root@localhost php-5.6.30]# yum install -y bzip2-devel

报错4:

configure: error: jpeglib.h not found.
说明:缺少jpeg库。

解决办法,安装libjpeg-devel

[root@localhost php-5.6.30]# yum install -y libjpeg-devel

报错5:

configure: error: png.h not found.
说明:缺少png库。

解决办法,安装libpng-devel

[root@localhost php-5.6.30]# yum install -y libpng-devel

报错6:

configure: error: freetype-config not found.
说明:缺少freetype库。

解决办法,安装freetype-devel

[root@localhost php-5.6.30]# yum install -y freetype-devel

报错7:

configure: error: mcrypt.h not found. Please reinstall libmcrypt.
说明:缺少mcrypt库。

解决办法,安装libmcrypt-devel。安装libmcrypt-devel时,需先按装epl-release。因为yum源没有libmcrypt-devel包,所以只能借助epel yum扩展安装。

[root@localhost php-5.6.30]# yum install -y libtomcrypt-devel
  • 配置时,如果使用的不是mysql,而是mariadb则需要将其中的路径改成mariadb的路径。(将所有的mysql改成mariadb)

    ./configure --prefix=/usr/local/php --with-apxs2=/usr/local/apache2.4/bin/apxs --with-config-file-path=/usr/local/php/etc --with-mariadb=/usr/local/mariadb --with-pdo-mariadb=/usr/local/mariadb --with-mariadbi=/usr/local/mariadb/bin/mysql_config --with-libxml-dir --with-gd --with-jpeg-dir --with-png-dir --with-freetype-dir --with-iconv-dir --with-zlib-dir --with-bz2 --with-openssl --with-mcrypt --enable-soap --enable-gd-native-ttf --enable-mbstring --enable-sockets --enable-exif

  • 编译和安装

    [root@localhost php-5.6.30]# make
    ...
    Build complete.
    Don't forget to run 'make test'.

编译的时间有点长

[root@localhost php-5.6.30]# make install
  • php和apache结合是通过/usr/local/apache2.4/modules/libphp5.so 这个文件。
  • 查看php加载了哪些模块

    [root@localhost php-5.6.30]# /usr/local/php/bin/php -m

    模块都是静态的

  • 将配置文件放到/usr/local/php/etc/php.ini

    [root@localhost php-5.6.30]# cp php.ini-production /usr/local/php/etc/php.ini

安装PHP7

  • 下载并解压

    [root@localhost src]# wget http://cn2.php.net/distributions/php-7.1.6.tar.bz2
    [root@localhost src]# tar jxv -f php-7.1.6.tar.bz2

  • 环境配置

    [root@localhost src]# cd ./php-7.1.6/
    [root@localhost src]# ./configure --prefix=/usr/local/php7 --with-apxs2=/usr/local/apache2.4/bin/apxs --with-config-file-path=/usr/local/php7/etc --with-pdo-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-libxml-dir --with-gd --with-jpeg-dir --with-png-dir --with-freetype-dir --with-iconv-dir --with-zlib-dir --with-bz2 --with-openssl --with-mcrypt --enable-soap --enable-gd-native-ttf --enable-mbstring --enable-sockets --enable-exif
    注意:php7与php5不通处在于php7没有“--with-mysql”选项

  • 编译安装

    [root@localhost php-7.1.6]# make
    [root@localhost php-7.1.6]# echo $?
    0
    [root@localhost php-7.1.6]# make install
    [root@localhost php-7.1.6]# echo $?
    0

  • 一台机器可以同时安装php5和php7。apache调用的时候需要指定好。

    apache配置文件/usr/local/apache2.4/conf/httpd.conf

    [root@localhost php-7.1.6]# vim /usr/local/apache2.4/conf/httpd.conf
    LoadModule php5_module modules/libphp5.so
    LoadModule php7_module modules/libphp7.so
    (150行/151行)
    不想用哪个就把把哪个注释掉就行了。

本文转自 豆渣锅 51CTO博客,原文链接:http://blog.51cto.com/754599082/2051883

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
PHP:CentOS Linux环境下源码编译安装PHP8.0
PHP:CentOS Linux环境下源码编译安装PHP8.0
54 0
Ubuntu 12.04 安装PHP
Ubuntu 12.04 安装PHP
80 0
Ubuntu18.04下PHP安装gRPC
Ubuntu18.04下PHP安装gRPC
58 0
安装memcached 和 php-memcached 实现PHP访问memcached
安装memcached 和 php-memcached 实现PHP访问memcached
24 0
CentOS7 部署安装FastDFS多机版(三)——安装FastDFS的PHP扩展
CentOS7 部署安装FastDFS多机版(三)——安装FastDFS的PHP扩展
42 0
如何修复“PHP 安装缺少 WordPress 所需的 MySQL 扩展”的错误?
在WordPress建站,WordPress定制开发过程中,开发者容易遇见“您的 PHP 安装似乎缺少 WordPress 所需的 MySQL 扩展”的错误提示,如果出现这样的情况,应该怎么办?北京六翼信息有限公司的开发工程师指出,要修复错误“您的 PHP 安装似乎缺少 WordPress 所需的 MySQL 扩展”,您需要确保您的 PHP 安装已正确安装和配置 MySQL 数据库驱动程序 (mysqlnd) 和 mysqli 扩展。只有这样,您才能恢复 WordPress 和 WordPress 数据库之间的正常连接,并让您的网站重新运行。
95 0
QGS
(openEuler21.03-Centos7-x86)yum安装php+nginx—配置nginx解析php
记(openEuler21.03-Centos7-x86)yum安装php+nginx—配置nginx解析php
264 0
QGS
(openEuler21.03-Centos7-x86)yum安装php+apache
记(openEuler21.03-Centos7-x86)yum安装php+apache
65 0
QGS
(openEuler21.03-x86)yum安装php+apache—shell脚本
记(openEuler21.03-x86)yum安装php+apache—shell脚本
44 0
【技术分享】Win10环境php安装seaslog扩展
【技术分享】Win10环境php安装seaslog扩展
60 0
+关注
科技小能手
文章
问答
视频
文章排行榜
最热
最新
相关电子书
更多
PHP 2017.北京 全球开发者大会——高可用的PHP
立即下载
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
相关实验场景
更多