必须添加对程序集“System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a”的引用-阿里云开发者社区

开发者社区> 云计算> 正文
登录阅读全文

必须添加对程序集“System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a”的引用

简介:

问题描述:

       界面层引用BLL层的时候,突然报这个错误。一开始以为是代码什么地方写错了,后面发现其实是因为业务逻辑层使用的是.Net Framwork 4(如图1),而界面层使用的是.Net Framwork 4 Client Profile。.Net Framwork 4里面有一些类库是.Net Framwork 4 Client Profile所没有的,所以我们只要将界面层的目标框架改为.Net Framwork 4就可以解决这个问题了。

image

图1 BLL层使用的框架

image

图2 界面层使用的框架

错误提示

错误 29 类型“

System.Configuration.ConfigurationElement”在未被引用的程序集中定义。必须添加对程序集“System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a”的引用。 D:\阶段性学习\大三下\2.比赛\4.合泰杯\代码\ZNJJ\UI\Form1.cs 31 13 UI

解决步骤

1、右键点击出错的层,选择属性

image

2、改变目标框架,按“Ctrl+s”保存

image


作者:kissazi2 
出处:http://www.cnblogs.com/kissazi2/ 
本文版权归作者所有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。

转载:http://www.cnblogs.com/kissazi2/archive/2013/04/18/3029432.html

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: