Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
解题思路:
给出一个非负数N,求出各个位置的数字之和,并用one ,two表示出来,直接模拟即可。
#include<cstdio>
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
int main(){
string k;
string a[15]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int sum=0;
cin>>k;
for(int i=0;i<k.length();i++){
sum+=k[i]-'0';
}
vector <int>v;
while(sum){
v.push_back(sum%10);
sum/=10;
}
if(v.size()==0){
cout<<"zero";
}
else {
cout<<a[v[v.size()-1]];
}
for(int i=v.size()-2;i>=0;i--){
cout<<" "<<a[v[i]];
}
return 0;
}