有左右各200间房间,对门的房间之间移动家具,每次移动花费10分钟,移动路径上有交集就不能同时移动,问最少花多少时间能完成
输入格式:第一行一个数字t,表示测试数量,接下来每个样例第一行,一个数字n表示移动次数,接下来n行每行两个数字,表示移动的房间编号
输出格式:一个数字花费时间
输入样例:
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
输出样例:
10
20
30
解题思路:用数组存储每两间相对的房间之间一共有多少次家具的搬运,因为重叠的路径每一只能搬运一件,所以经过次数最多的那个数就是花费时间最少量。又由于其他不相互干扰的搬运都能同时完成,所以最终搬运时间就是经过次数的最大值*每次搬运花费的时间。
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
int n,a[405];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(a,0,sizeof(a));
scanf("%d",&n);
for(int i=0;i<n;i++)
{
int x,y;
scanf("%d%d",&x,&y);
if(x>y)
{
int t=x;
x=y;
y=t;
}
if(x%2==0)
x--;
if(y%2==1)
y++;
for(int i=x;i<=y;i++)
a[i]++;
}
int maxx=0;
for(int i=1;i<=400;i++)
{
maxx=max(maxx,a[i]);
}
printf("%d\n",maxx*10);
}
return 0;
}