链路捆绑---LACP(手动方式)-阿里云开发者社区

开发者社区> 云计算> 正文
登录阅读全文

链路捆绑---LACP(手动方式)

简介:

链路捆绑---LACP(手动方式)

一:实验拓扑

wKioL1VkJEqxu-yQAAEZd5GXgK8810.jpg

二:实验要求

1:实现交换机之间的链路捆绑的同时,实现路线的抢占功能

2:实现二层设备与三层设备的捆绑,

4:实现路由器之间的捆绑

5::使用单臂路由技术,实现全网互通

6:思考线路抢占的优与坏

三:实验原理

1:在交换机下创建eth-trunk 口,再将默认端口加入到trunk口中

2:路由器是三层设备,是不能添加到两层交换机下创建的eth-trunk 口。要将路由器下的三层口转化为两层口。

3:单臂路由是在eth-trunk 口下实现接口分开的。

4:三层设备路由器之间的捆绑也要将其变为两层口,否则无法设置ip地址,即无法实现互通。

5:在交换机下设置抢占功能,

四:实验步骤

第一步-----Pc机ip分配

Pc1:192.168.10.10 24 网关:192.168.10.1

Pc2:192.168.20.20 24 网关:192.168.20.1

Pc3:192.168.10.30 24 网关:192.168.10.1

Pc4:192.168.20.40 24 网关:192.168.20.1

 

第二步-----实现交换机之间的捆绑

Sw1

[Huawei]vlanbat 10 20//新建vlan1020

[Huawei]inte0/0/1//进入接口

[Huawei-Ethernet0/0/1]port hybrid pvid vlan 10//实现vlan10的分装

[Huawei-Ethernet0/0/1]port hybrid untagged vlan 10//vlan10的成员通过需要不带标签

[Huawei]inte0/0/2//进入接口

[Huawei-Ethernet0/0/2]port hybrid pvid vlan 20//进行vlan20的分装

[Huawei-Ethernet0/0/2]port hybrid untagged vlan 20//vlan20成员通过需要脱掉标签

注:这里是使用hybrid技术实现接口的分配,与 port link-type access / port defort

Vlan 20的命令意义是一样的

[Huawei]lacp priority 100//定义SW1lacp优先级为100使其成为lacp协议主设备,默认值为32768

[Huawei]intEth-Trunk 1//创建Eth-Trunk链路聚合端口.且名为1

[Huawei-Eth-Trunk1]mode lacp-static //模式lacp-static

这个时候是不能够先将接口加入trunk 1 口的,如果加入了,下面的命令是无效的。

 [Huawei-Eth-Trunk1]max active-linknumber 3//定义eth-trunk 1组的最大活跃链路数为3,分别是0.1.2

[Huawei-Eth-Trunk1]trunkport e 0/0/5 to 0/0/8//看到了这里包括了4个接口

[Huawei]intEth-Trunk 1//进入到Eth-Trunk链路聚合端口

[Huawei-Eth-Trunk1]porthybrid tagged vlan 10 20//将Eth-Trunk链路聚合端口设为中继口,允许vlan10和20之间的成员通过,并且是带标签的。---在我们使用]port link-type trunk/ port trunk allow-pass vlan 10 200的命令意义是一样的。

 

 

Sw2

[Huawei]vlanbat 10 20

[Huawei]int e0/0/3

[Huawei-Ethernet0/0/3]portlink-type access

[Huawei-Ethernet0/0/3]portdefault vlan 10

[Huawei-Ethernet0/0/3]int e0/0/4

[Huawei-Ethernet0/0/4]portlink-type access

[Huawei-Ethernet0/0/4]portdefault vlan 20

[Huawei-Eth-Trunk1]mode lacp-static

[Huawei-Eth-Trunk1]max active-linknumber 3

[Huawei-Eth-Trunk1]port link-type trunk

[Huawei-Eth-Trunk1]port trunk allow-pass vlan 10 20

 

[Huawei]dis eth-trunk 1

wKiom1VkItyD-q61AAHBhEm7IjA422.jpg

上图中我们看到0/5. 0/6. 0/7的接口状态都是开启的,只有0/8接口是没有被选中,因为前面我们设定了只有三个接口可以同时使用,因此 这边它会按照接口越小越优先的原则进行选择。

:我了实现vlan之间成员的互通.在数据包转发的时候,我们可以知道交换机是要接受两个vlan之间成员发送的数据包,为了保证数据包的正常性转发,因此这里要用中继口。允许vlan1020之间的成员通过,且需要带标签。

 关掉e0/0/5接口再看链路端口1

wKiom1VkIuyDKRbMAAGVf1xV3qM564.jpg

上图中我们可以看到0/5的接口被关掉以后,先前没有选中的0/8接口现在已经是开着的,因此这种方法就是可以保证的带宽不会减下去,保证的数据传输的速率的稳定。

如果0/5接口被修好了,但是它任然会使用0/8接口,并不会启用/接口的。

这个时候如果再将其它一个接口关掉的话,先前被关掉的0/5接口就会再次被使用。

 

 

思考:这种抢占的方法真的好吗?上图中我们可以看出它会造成资源的大量浪费,而且如果直接将备份的0/8接口启用的话,还会带来增加带宽的功能,这样又何乐而不为呢?

 

答:这种抢占的方法在现实中使用的地方是很少用到的,只会在一个特殊的要求环境中才会使用,;例如一些运营商它们有特别的要求,设备不能够同时启用备份的接口,这个时候就只能这样了。当然,也正是因为这样,在现实中我们的,小企业网中是不会使用这种方法的。

 

第二步实现交换机与路由器之间的捆绑.并用单臂路由实现跨vlan通信。

Sw1

[Huawei]intEth-Trunk 2

[Huawei-Eth-Trunk2]trunkport g 0/0/1 0/0/2

 [Huawei]diseth-trunk 2

wKiom1VkI7nyYnrBAAEKhKvSqVM147.jpg

 

[Huawei]int Eth-Trunk 2

[Huawei-Eth-Trunk2]portlink-type trunk

[Huawei-Eth-Trunk2]port trunkallow-pass vlan 10 20 //这里是交换机的上心口,因为要实现全网互通,那么数据包就要经过这个上心口通过进入到交换机只见去,那么在这里vlan1020gyAu你发送数据包就要通过这里,因此需要变为中继口

R1

[Huawei]intEth-Trunk 2

[Huawei]int g0/0/0

[Huawei-GigabitEthernet0/0/0]eth-trunk2

Error: The layer-3 interface can not add intoa layer-2 trunk.done.

//这里产生了错误,因为路由器是三层设备,而交换机是两层设备,两者是不能捆绑在同一个eth-trunk 2链路聚合端口的,因此要将路由器切换才两层。

[Huawei-Eth-Trunk2]undoportswitch//由三层切换到两层

[Huawei-Eth-Trunk2]trunkport g0/0/0 0/0/2

[Huawei]int Eth-Trunk 2.10

[Huawei-Eth-Trunk2.10]dot1q termination vid 10

[Huawei-Eth-Trunk2.10]ip add 192.168.10.1 24

[Huawei-Eth-Trunk2.10]arp broadcast enable

[Huawei]int Eth-Trunk 2.20

[Huawei-Eth-Trunk2.20]dot1q termination vid 20

[Huawei-Eth-Trunk2.20]ip add 192.168.20.1 24  

[Huawei-Eth-Trunk2.20]arp broadcast enable

vlan通信验证

Pc1wKioL1VkJVSSFT5XAAE_qk1GqXc310.jpg

wKioL1VkJV3xrERfAAExtVpQDBg748.jpg

上图实现了跨vlan通信,利用了单臂路由技术。

第四步实现三层路由之间的捆绑,并且实现全网互通。

R1

[Huawei]int Eth-Trunk 3//创建Eth-Trunk链路聚合端口3

[Huawei-Eth-Trunk3]undoportswitch//切换到两层

[Huawei-Eth-Trunk3]ip add 12.0.0.1 24//这只Eth-Trunk链路聚合端口的ip

[Huawei]int g0/0/1

[Huawei-Eth-Trunk3]trunkport g 0/0/1 2/0/0

 [Huawei]diseth-trunk 3

wKioL1VkJWiw2QKwAAEJEIUTzfU323.jpg

上图我们已经看到两个端口进入到Eth-Trunk链路聚合端口

R2

[Huawei]intEth-Trunk 3

[Huawei-Eth-Trunk3]undoportswitch

[Huawei-Eth-Trunk2]trunkport g 0/0/0 0/0/1

[Huawei-Eth-Trunk3]ip add 12.0.0.2 24//设置R2Eth-Trunk链路聚合端口的ip

结果

wKiom1VkI-LxWa7EAAHEG6KwzKU717.jpg

实现互通性

R2

[Huawei]ip route-static192.168.10.0 24 12.0.0.1//

[Huawei]ip route-static 192.168.20.024 12.0.0.1//

注:这两条静态路由是实现全网互通的,在路由器的路由表中是没有pc机的ip路径的,数据包到达路由器的时候发现身上没有它的目标地址,就会把数据包丢掉。

这条路径是让pc机上发送的数据包可以到达路由器上并且数据包可以返回。

实验验证

R1

wKioL1VkJXuyZkz5AAE-HsZdQk4366.jpg

R2

wKioL1VkJYWSfjEbAAEnMLkqGhQ850.jpg

 

实验成功

 

总结:

 

从上面可以看出,链路聚合具有如下一些显著的优点:










本文转自 于学康 51CTO博客,原文链接:http://blog.51cto.com/blxueyuan/1655284,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

其他文章