centos系统python版本2.6升级到2.7-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

centos系统python版本2.6升级到2.7

简介:

Centos 6.x上安装的python版本是2.6,不能满足我运行软件的要求,所以对python进行升级。

Python的最新版本已经是3.3,但是Python3的兼容性可能还有一定的问题,所以还是升级到2.7较为保险。Python

2.7也能够满足绝大多数的软件需求了。


安装之前确认服务器已安装以下软件:

没有则安装

yum install zlib zlib-devel openssl openssl-devel libcurl-devel gcc gcc-c++ -y 

注意:后期安装pip时,如没安装以上软件,会报错,而且安装完上面软件还需要重新编译安装python


据说系统自带的旧版本python被严重依赖,所以不能卸载原Python,这里选择全新安装。

下载地址:https://www.python.org/ftp/python/2.7.3/Python-2.7.3.tgz

tar -xvf Python-2.7.3.tgz

cd Python-2.7.3

./configure --prefix=/usr/local/python2.7

make

make install


安装好后可以运行一下Python看看是否正常了

/usr/local/python2.7/bin/python2.7 -V


接下来需要创建一个链接来使系统默认python变为python2.7

ln -fs /usr/local/python2.7/bin/python2.7 /usr/bin/python


运行python查看版本

python -V


进行更改后,yum无法运行了。需要修改/usr/bin/yum文件,将第一行的

#!/usr/bin/python

中的python改为系统原有的python版本,我的如下:

#!/usr/bin/python2.6

到此完毕。



本文转自 jvrmusic520  51CTO博客,原文链接:http://blog.51cto.com/linuxtech/1731104

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: