思科Cisco交换机、路由器设置命令(附详解)

简介:
交换机口令设置:
switch>enable                                        ;进入特权模式
switch#config terminal                               ;进入全局配置模式
switch(config)#hostname <hostname>                   ;设置交换机的主机名
switch(config)#enable secret xxx                     ;设置特权加密口令为 xxx
switch(config)#enable password xxx                   ;设置特权非密口令为 xxx
switch(config)#line console 0                        ;进控制台口(Rs232)初始化
switch(config-line)#line vty 0 4                     ;进入虚拟终端virtual tty
switch(config-line)#login                            ;允许登录
switch(config-line)#password xx                      ;设置登录口令xx
switch#exit                                          ;返回命令
交换机VLAN设置:
switch#vlan database                                 ;进入VLAN设置
switch(vlan)#vlan 2                                  ;建VLAN 2
switch(vlan)#no vlan 2                               ;删vlan 2
switch(config)#int f0/1                              ;进入端口1
switch(config-if)#switchport access vlan 2           ;当前端口1加入VLAN 2
switch(config-if)#switchport mode trunk              ;设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan
switch(config-if)#switchport trunk encap dot1q       ;设置vlan 中继
switch(config)#vtp domain <name>                     ; 设置发vtp域名
switch(config)#vtp password <word>
switch(config)#vtp mode server
switch(config)#vtp mode client
交换机设置IP地址:
switch(config)#interface vlan 1                      ;进入vlan 1
switch(config-if)#ip address <IP> <mask>             ;添加远程登录IP
switch(config)#ip default-gateway <IP>               ;添加默认网关 
switch#dir flash:                                    ;查看内存
交换机显示命令:
switch#write                                         ;写入保存 
switch#show vtp
switch#show run                                      ;查看当前配置信息
switch#show vlan                                     ;看VLAN
switch#show interface                                ;显示所有端口信息 
switch#show int f0/0                                 ;显示端口0的信息
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
路由器显示命令:
router#show run                                      ;显示接口
router#show interface                                ;显示接口
router#show ip route                                 ;显示路由
router#show cdp nei                                  ;看邻居
router#reload                                        ;重新起动
设置口令:
router>enable                                        ;进入特权模式
router#config terminal                               ;进入全局配置模式
router(config)#hostname <hostname>                   ;设置交换机的主机名
router(config)#enable secret xxx                     ;设置特权加密口令为 xxx
router(config)#enable password xxx                   ;设置特权非密口令为 xxx
router(config)#line console 0                        ;进控制台口(Rs232)初始化
router(config-line)#line vty 0 4                     ;进入虚拟终端virtual tty
router(config-line)#login                            ;允许登录
router(config-line)#password xx                      ;设置登录口令xx
router(config)# (Ctrl+z)                             ; 返回特权模式
router#exit                                          ;返回命令
配置IP地址:
router(config)#int s0/0                              ;进行串Serail接口
router(config-if)#no shutdown                        ;起动接口
router(config-if)#clock rate 64000                   ;设置时钟
router(config-if)#ip address 10.1.1.1 255.255.0.0    ;设置IP地址和子网掩码
router(config-if)#ip add 10.1.1.2 255.255.0.0 second;
router(config-if)#int f0/0.1                         ; 进入子接口
router(config-subif.1)#ip address <ip><netmask>      ;
router(config-subif.1)#encapsulation dot1q <n>         ;
router(config)#config-register 0x2142                ;跳过配置文件
router(config)#config-register 0x2102                ;正常使用配置文件
router#reload                                        ;重新引导
复制操作:
router#copy running-config startup-config            ;存配置
router#copy running-config tftp                      ;上载
router#copy startup-config tftp
router#copy tftp flash:                              ;特权模式下升级IOS
router#copy tftp startup-config               ;下载配置文件到nvram
ROM状态:
Ctrl+Break                                           ;进入ROM监控状态 
rommon>confreg 0x2142                                ;跳过配置,26 36 45xx
rommon>confreg 0x2102                                ;使用配置,恢复工作状态
rommon>reset                                    ;重新引导,等效于重开机
rommon>copy xmodem:<sname> flash:<dname>             ;从console升级IOS
rommon>IP_ADDRESS=10.65.1.2                          ;设置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0                    ;设置路由器掩码
rommon>TFTP_SERVER=10.65.1.1                         ;指定TFTP服务器IP
rommon>TFTP_FILE=c2600.bin                           ;所要下载的文件
rommon>tftpdnld                                      ;ROM监控状态下升级IOS
rommon>dir flash:                                    ;查看闪存中的内容
rommon>boot                                          ;引导IOS
静态路由:
ip route <ip-address> <subnet-mask> <gateway>    例:
router(config)#ip route 10.1.0.0 255.255.0.0 10.2.1.1
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2    
动态路由:
router(config)#ip routing                            ;启动路由
router(config)#router rip                            ;启动RIP路由协议。
router(config-router)#network <netid>                ;配置范围,有的支持all。
router(config-router)#negihbor <ip-address>          ;点对点 帧中继用。
帧中继命令:
router(config)# frame-relay switching                ;使能帧中继交换
router(config-s0)# encapsulation frame-relay         ;使能帧中继
router(config-s0)# frame-relay intf-type DCE         ;DCE端(需要配虚电路)
router(config-s0)# frame-relay local-dlci 20         ;配置虚电路号
基本访问控制列表:
router(config)#access-list <number> permit|deny <source ip> <wild|any>
router(config)#interface <interface>                 ;default: deny any
router(config-if)#ip access-group <number> in|out    ;default: out
例:
RB(config)#access-list 4 permit 10.8.1.1
RB(config)#access-list 4 deny 10.8.1.0 0.0.0.255
RB(config)#access-list 4 permit 10.8.0.0 0.0.255.255
RB(config)#access-list 4 deny 10.0.0.0 0.255.255.255
RB(config)#access-list 4 permit any              
RB(config)#int f0/0
RB(config-if)#ip access-group 4 in

扩展访问控制列表:
access-list <number> permit|deny icmp <SourceIP wild> <destinationIP
wild>[type]
access-list <number> permit|deny tcp <SourceIP wild> <destinationIP
wild>[port]
例1:
router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo
router(config)#access-list 101 permit ip any any  
router(config)#int s0/0
router(config-if)#ip access-group 101 in
例2:
router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80
router(config)#access-list 102 permit ip any any
router(config)#interface s0/1
router(config-if)#ip access-group 102 out
router(config)#no access-list 102
router(config-if)#no ip access-group 101 in
在路由器上设置 SNMP Community Strings
   router(config) # snmp-server community read-community-string ro
   router(config) # snmp-server community write-community-string rw
 
在交换机上设置 SNMP Community Strings
switch(config) # snmp-server community     read-community-string ro
switch(config) # snmp-server community write-community-string rw
 
在路由器上配置日志信息(Syslog Message Logging)
router(config) # logging on
router(config) # logging server-ip-address
router(config) # logging trap severity-level
 
路由器恢复出厂设置
erase start-config
或write erase
或erase NVROM

本文转自shenzhoulong  51CTO博客,原文链接:http://blog.51cto.com/shenzhoulong/285544,如需转载请自行联系原作者
相关文章
|
1月前
|
算法 网络协议
【计网·湖科大·思科】实验三 总线型以太网的特性、集线器和交换机的区别、交换机的自学习算法
【计网·湖科大·思科】实验三 总线型以太网的特性、集线器和交换机的区别、交换机的自学习算法
26 1
|
1月前
|
JavaScript 网络虚拟化 网络架构
路由器只能连接不同网段的设备,隔离广播域,交换机可以连接不同网段,也可以连接相同网段(三层) 二层只能同网段
路由器只能连接不同网段的设备,隔离广播域,交换机可以连接不同网段,也可以连接相同网段(三层)二层只能同网段
23 1
|
1月前
|
分布式计算 资源调度 安全
Hadoop节点检查网络交换机、路由器和网线
【5月更文挑战第1天】您可以对Hadoop节点中的网络交换机、路由器和网线进行全面的检查,确保这些设备正常运行并且网络连接稳定可靠。如果在检查过程中发现任何问题,应及时解决,以避免影响Hadoop集群的稳定性和性能。
35 6
|
1月前
|
网络协议 算法 安全
|
1月前
|
网络协议 网络性能优化 网络虚拟化
【亮剑】介绍了华为三层交换机的配置命令,包括基本配置(系统启动、接口配置、基础设置)、路由协议(OSPF、BGP)配置和高级功能(VLAN、ACL、QoS)配置
【4月更文挑战第30天】本文介绍了华为三层交换机的配置命令,包括基本配置(系统启动、接口配置、基础设置)、路由协议(OSPF、BGP)配置和高级功能(VLAN、ACL、QoS)配置。通过这些命令,网络工程师可以有效地管理设备、优化网络性能并解决网络问题。熟练掌握这些命令对于提升网络运行效率至关重要。
|
1月前
|
负载均衡 安全 网络安全
|
1月前
|
网络协议 安全 网络安全
|
1月前
|
存储 网络架构
|
1月前
|
网络性能优化 网络虚拟化 网络架构
配置接口限速示例(盒式交换机)
接口限速简介 接口限速对通过整个端口的全部报文流量速率进行限制,不对具体流量进行区分,可以实现给某个接口分配固定的带宽,控制方式单一,配置简单。 入方向与出方向的接口限速属于并列关系,用户可以根据需要同时配置,也可以单独配置。
|
1月前
|
网络协议 网络虚拟化 网络架构
交换机入门快速配置
交换机入门快速配置