同一台路由器上面双vpdn-group组的运行

拓扑图如下:
需求:
在同一台路由器上面同时运行两个vpdn-group组。
我的配置如下,请帮我检查检查,看看我那里配置有问题,为什么我的配置同时只有一个vpdn-group起作用。
配置如下:
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#aaa new-model
Router(config)#aaa authentication login default local
Router(config)#aaa authentication login console none
Router(config)#aaa authentication ppp default local
Router(config)#aaa authorization network default local
Router(config)#line con 0
Router(config-line)#login authentication console
Router(config-line)#exit
Router(config)#vpdn enable
Router(config)#vpdn-group 10
Router(config-vpdn)#accept-dialin
Router(config-vpdn-acc-in)#protocol pptp
Router(config-vpdn-acc-in)#virtual-template 10
Router(config-vpdn-acc-in)#exit
Router(config-vpdn)#exi
Router(config)#vpdn-group 20
Router(config-vpdn)# accept-dialin
Router(config-vpdn-acc-in)#  protocol pptp
Router(config-vpdn-acc-in)#  virtual-template 20
Router(config-vpdn-acc-in)#exit
Router(config-vpdn)#exi
Router(config)#interface Loopback0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#interface Loopback1
Router(config-if)# ip address 11.11.11.1 255.255.255.0
Router(config)#interface Virtual-Template10
Router(config-if)# ip unnumbered Loopback0
Router(config-if)# peer default ip address pool GroupCisco
Router(config-if)#ppp authentication chap ms-chap
Router(config-if)#interface Virtual-Template20
Router(config-if)# ip unnumbered Loopback1
Router(config-if)# peer default ip address pool GroupCisco1
Router(config-if)# ppp authentication chap ms-chap
Router(config-if)#exit
Router(config)#ip local pool GroupCisco 10.10.10.2 10.10.10.254
Router(config)#ip local pool GroupCisco1 11.11.11.2 11.11.11.254
Router(config)#username cisco@cisco.com password cisco123
Router(config)#username cisco@cisco.cn password cisco123
配置配好以后,建立一个PPTP VPDN拨号,将服务器IP设置成电信的公网地址。
输入用户名及密码进行拨号
拨号成功以后,分配的的IP地址如下:
现在通过PPTP拨上来以后,通过上面分配的地址我们可以看出,这个地址段是属于VPDN-GROUP10的,去访问我们内网的服务器,截图如下:
我们看见可以正常访问。
那么我们现在再通过联通的IP地址来进行拨号测试一下看看效果。将服务器IP设置成电信的公网地址。
输入我们联通对应的用户名及密码。然后点击“connect”进行连接。
我们拨号成功,查看一下详请,看看获取的IP地址。
而我们这时候还是能正常与我们内网的服务器正常通信。
使用show vpdn sess查看会话
Router#show vpdn session
%No active L2TP tunnels
 
PPTP Session Information Total tunnels 1 sessions 1
 
LocID RemID TunID Intf    Username      State   Last Chg Uniq ID
6     16384 6     Vi2.1   cisco@cisco.c estabd  00:11:38 4     
Router#
使用show ip int bri查看接口信息
Router#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            222.215.24.2    YES manual up                    up     
FastEthernet0/1            119.79.6.2      YES manual up                    up     
FastEthernet1/0            172.16.1.254    YES manual up                    up     
FastEthernet1/1            unassigned      YES unset  administratively down down   
Virtual-Access1            unassigned      YES unset  down                  down   
Virtual-Access2            unassigned      YES unset  up                    up     
Virtual-Access2.1          10.10.10.1      YES TFTP   up                    up     
Virtual-Template10         10.10.10.1      YES TFTP   down                  down   
Virtual-Template20         11.11.11.1      YES TFTP   down                  down   
Loopback0                  10.10.10.1      YES manual up                    up     
Loopback1                  11.11.11.1      YES manual up                    up  
我们通过联通IP地址拨号进来以后,分配到的还是VPDN-GROUP 10里面的IP地址。
但是我们这里要实现的功能是,当电信用户通过电信的IP地址拨进来之后是分配VPDN-GROUP 10对应的IP地址组中的地址,当网通用户通过网通的服务器IP地址拨号进来之后,分配到的是VPDN-GROUP 20对应的IP地址组中的地址。还有就是,需要不同的用户名及密码对应不同的VPDN-GROUP组,cisco@cisco.com账号用于电信的vpdn-group 10里面,cisco@cisco.cn帐号用于联通的vpdn-group 20
而我在这里测试,不管是通过联通还是电信的IP地址以及对应的帐户来进行拨号。始终使用的是vpdn-group 10这个组,而只有当vpdn-group 10下对就的! Default PPTP VPDN group这条注释存在vpdn-group 20下时,我们通过电信的IP地址或者联通的IP地址以及对应的帐户进行拨号,这时分配的IP地址就是vpdn-group 20下面对应的IP地址了。但是不能两个vpdn-group组同时存在。
现在我们的问题就是,如何让两个vpdn-group组同时运行起来。就是如上面所说的,当我使用电信的IP地址与cisco@cisco.com来进行拨号,而调用的是vpdn-group 10里面的IP地址池,而当我使用联通的IP地址与cisco@cisco.cn来进行拨号时,而调用的是vpdn-group 20里面对应的IP地址池。
下面的配置只是在设备上面进行模拟的,还没有正试使用起来,不知道怎么解决这个问题,待这个问题解决上来以后,设备就要正式使用上来了。
Router#show run
Building configuration...
 
Current configuration : 1810 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login console none
aaa authentication ppp default local
aaa authorization network default local
!
!
aaa session-id common
ip cef
!
!
!
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 10
! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 10
!
vpdn-group 20
 accept-dialin
  protocol pptp
  virtual-template 20
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
username cisco@cisco.com password 0 cisco123
username cisco@cisco.cn password 0 cisco123
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.0
!        
interface Loopback1
 ip address 11.11.11.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 222.215.24.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 119.79.6.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.254 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Virtual-Template10
 ip unnumbered Loopback0
 peer default ip address pool GroupCisco
 ppp authentication chap ms-chap
!
interface Virtual-Template20
 ip unnumbered Loopback1
 peer default ip address pool GroupCisco1
 ppp authentication chap ms-chap
!
ip local pool GroupCisco 10.10.10.2 10.10.10.254
ip local pool GroupCisco1 11.11.11.2 11.11.11.254
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!         
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 login authentication console
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end