开发者社区> 余二五> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

CCNA--LAB-4:配置OSPF路由协议

简介:
+关注继续查看
拓扑如上:
 
R1:
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.1.254 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int f0/1
R1(config-if)#ip address 12.1.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#router ospf 1     --进入OSPF配置模式,进程号为1
R1(config-router)#router-id 1.1.1.1     --路由器ID为1.1.1.1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0     --发布直连网络,反掩码,区域号(注:OSPF必需有骨干区域,为区域0)
R1(config-router)#network 12.1.1.0 0.0.0.255 area 0     --发布直连网络,反掩码,区域号
R1(config-router)#end
R1#

查看OSPF邻居表:
R1#show ip ospf neighbor
Neighbor ID     Pri     State           Dead Time   Address         Interface
2.2.2.2           1     FULL/DR         00:00:38    12.1.1.2        FastEthernet0/1
邻居ID号//   优先级//   状态//          死亡时间//  对端地址//      通过F0/1接口建立//
R1#

查看路由表:
R1#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
O    192.168.2.0/24 [110/2] via 12.1.1.2, 00:00:20, FastEthernet0/1
R1#

验证在PC0拼PC1:
PC>ping 192.168.2.1
Pinging 192.168.2.1 with 32 bytes of data:
Reply from 192.168.2.1: bytes=32 time=48ms TTL=126
Reply from 192.168.2.1: bytes=32 time=33ms TTL=126
Reply from 192.168.2.1: bytes=32 time=32ms TTL=126
Reply from 192.168.2.1: bytes=32 time=38ms TTL=126
Ping statistics for 192.168.2.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 32ms, Maximum = 48ms, Average = 37ms
PC>
 
 
 
 
R2:
Router>en
Router#conf t
Router(config)#hostname R2
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.2.254 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int f0/1
R1(config-if)#ip address 12.1.1.2 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#router ospf 1
R1(config-router)#router-id 2.2.2.2
R1(config-router)#network 192.168.2.0 0.0.0.255 area 0
R1(config-router)#network 12.1.1.0 0.0.0.255 area 0
R1(config-router)#end
R1#

查看邻居表:
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:38    12.1.1.1        FastEthernet0/1
R2#
 
查看路由表:
R2#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/1
O    192.168.1.0/24 [110/2] via 12.1.1.1, 00:03:08, FastEthernet0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R2#

验证在PC1拼PC0:
PC>ping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time=48ms TTL=126
Reply from 192.168.1.1: bytes=32 time=30ms TTL=126
Reply from 192.168.1.1: bytes=32 time=37ms TTL=126
Reply from 192.168.1.1: bytes=32 time=40ms TTL=126
Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 30ms, Maximum = 48ms, Average = 38ms
PC>

 
总结:
1、使用区域的概念,有效的减少路由选择协议对cpu和内存的占用。还可以降低路由选择协议的通信量。
2、完全无类别的处理地址问题。
3、支持无类别。vlsm和超网技术。
4、支持无大小限制的、任意的度量值。(cost=默认是108次方[参考带宽]/ BW[接口配置带宽]
5、支持多条路径的高效率的等价负载均衡。(默认4条,最多6条)
6、使用保留的组播地址来减小对不宣告OSPF报文的设备的影响。(DR Others 224.0.0.5 DR:224.0.0.6
7、支持更安全的路由选择认证。(null、明文、md5
8、使用可跟踪外部路由的路由标记。(E1/E2 默认为E2忽略内部的开销值)
 









本文转自 meiyanaa 51CTO博客,原文链接:http://blog.51cto.com/justim/234968,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
三层交换机/路由器OSPF配置详解【华为eNSP实验】
三层交换机/路由器OSPF配置详解【华为eNSP实验】
14 0
OSPF路由协议
1、OSPF的基本概念 2、OSPF邻接关系的建立 3、OSPF的应用环境 4、O应用环SPF的基本配置命令
45 0
CentOS5下安装与配置飞鸽传书(Ipmsg)完美完结篇
一、安装注意:必要的操作步骤均用绿色标记出来了。这篇blog是缩小版,如果想看原版,或者您出现了下文没有的问题,建议您详细看下原版,原版记录了我安装linux飞鸽的困苦经过,因为网上搜不到CentOS下的解决方案,所以当您认为这篇文章有价值时,转载请注明出处:xinyuan365.cublog.cn,五岳之巅奉献。
860 0
大型网络实战之ospf路由协议
OSPF路由协议 楔子 为了加强自己我打算好好玩玩网络。 OSPF的基本概念和工作过程 开放式最短路径优先协议(OSFP)是基于开放标准的链路状态路由选择协议,它完成各路由选择协议算法的两大主要功能:路径选择和路径交换。
1467 0
大型网络实战之ospf路由协议
OSPF路由协议 楔子 为了加强自己我打算好好玩玩网络。 OSPF的基本概念和工作过程 开放式最短路径优先协议(OSFP)是基于开放标准的链路状态路由选择协议,它完成各路由选择协议算法的两大主要功能:路径选择和路径交换。
1154 0
+关注
20377
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载