开发者社区> 余二五> 正文

BSCI—1:配置EIGRP的手动汇总

简介:
+关注继续查看
手动汇总特点:
1.减少路由条目。
2.减少正常数据的延时,
3.占用内存和CPU资源的减少。
4.减少带宽的占用。
 
拓扑如下:
 
 
 
实验:将R1上LoopBack 0,1,2三个接口地址汇总成一条路由
 
 
 
 
步骤一:首先我在R1R2之间做好基本配置并启用EIGRP发布网段
 
R1
 
Router>
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no sh
R1(config)#interface loopback 0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#int lo1
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#int lo2
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#exit
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#network 172.16.1.0 0.0.0.255
R1(config-router)#network 172.16.2.0 0.0.0.255
R1(config-router)#network 172.16.3.0 0.0.0.255
R1(config-router)#end
R1#
 
 
 
 
 
R2
 
Router>
Router>en
Router#conf t
Router(config)#hostname R2
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#router eigrp 1
R2(config-router)#network 192.168.1.0 0.0.0.255
R2(config-router)#end
R2#
 
查看路由表:
 
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/24 is subnetted, 3 subnets
D       172.16.1.0 [90/156160] via 192.168.1.1, 00:00:17, FastEthernet0/0
D       172.16.2.0 [90/156160] via 192.168.1.1, 00:00:17, FastEthernet0/0
D       172.16.3.0 [90/156160] via 192.168.1.1, 00:00:17, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
R2#
 
注:在R2上面我们可以很清楚的看见从R1上面学到的3条明细路由.
 
 
 
 
 
 
步骤二:当我们在R1接口下做手工总汇总之后的变化.
 
 
R1
 
R1(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.252.0
//这个时候我把之前3个不同网段的条目汇总为掩码为:255.255.252.0的网段
R1(config-if)#end
R1#
 
 
注:现在我们来看下R2的变化. 
 
 
 
 
 
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/22 is subnetted, 1 subnets
D       172.16.0.0 [90/156160] via 192.168.1.1, 00:01:52, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
R2#
 
注:以之前相比可以看到现在学过来的是在R1上汇总之后的路由,它的掩码长度为/22,也就是我刚刚手动输入的子网掩码.
 
 
总结:
 
这样做在针对连续在子网,有很大的改善,通过减少路由表的条目来节约我们的硬件资源以及网络带宽.









本文转自 meiyanaa 51CTO博客,原文链接:http://blog.51cto.com/justim/244214,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
Web APi之手动实现JSONP或安装配置Cors跨域(七)
前言 照理来说本节也应该讲Web API原理,目前已经探讨完了比较底层的Web API消息处理管道以及Web Host寄宿管道,接下来应该要触及控制器、Action方法,以及过滤器、模型绑定等等,想想也是心痛不已,水太深了,摸索原理关键是太枯燥和乏味了,但是呢,从情感上还是挺乐意去摸索原理,而情绪上不太乐意去探究原理,于是乎,本文就由此诞生了,借此文缓解下枯燥的心情和压抑的情绪。
1309 0
SciTE 修改配置文件方便使用
### 显示行号 line.margin.visible=1 ### 编辑区代码页:UTF-8=65001, GBK=936, BIG5=950 code.
646 0
阿里云服务器如何登录?阿里云服务器的三种登录方法
购买阿里云ECS云服务器后如何登录?场景不同,阿里云优惠总结大概有三种登录方式: 登录到ECS云服务器控制台 在ECS云服务器控制台用户可以更改密码、更换系.
29187 0
小白新手怎样通过阿里云服务器优惠活动购买云服务器配置指南及活动攻略
服务商都是非常喜欢新用户的,针对新用户上云,一般云服务商都会推出很多优惠活动,可以说以阿里云为代表云服务商针对新用户在第一次购买阿里云服务器的时候,都是不以盈利为目的的,为的是让广大用户能够以优惠的价格实现上云,感受云资源带来的效率和便利。
367 0
阿里云服务器端口号设置
阿里云服务器初级使用者可能面临的问题之一. 使用tomcat或者其他服务器软件设置端口号后,比如 一些不是默认的, mysql的 3306, mssql的1433,有时候打不开网页, 原因是没有在ecs安全组去设置这个端口号. 解决: 点击ecs下网络和安全下的安全组 在弹出的安全组中,如果没有就新建安全组,然后点击配置规则 最后如上图点击添加...或快速创建.   have fun!  将编程看作是一门艺术,而不单单是个技术。
20706 0
阿里云服务器怎么设置密码?怎么停机?怎么重启服务器?
如果在创建实例时没有设置密码,或者密码丢失,您可以在控制台上重新设置实例的登录密码。本文仅描述如何在 ECS 管理控制台上修改实例登录密码。
23582 0
两台CISCO2691测试静态路由汇总,浮动静态路由和负载分担静态路由配置
Dynagen的配置文件内容: #Lab 2-5 autostart = False [localhost] [[2691]] ram = 128 im...
936 0
TypeScript的书写规范(TSLint)配置修改
新版Angular中使用的Typescript书写规范非常恼人,比如默认会启用no-trailing-whitespace这样的选项。官方对此的说明是为了配合GIT的使用规范。
1824 0
+关注
20377
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
JS零基础入门教程(上册)
立即下载
性能优化方法论
立即下载
手把手学习日志服务SLS,云启实验室实战指南
立即下载