CCNA课堂练习:nat的介绍及利用nat来实现地址转换-阿里云开发者社区

开发者社区> 余二五> 正文

CCNA课堂练习:nat的介绍及利用nat来实现地址转换

简介:
+关注继续查看
      浅谈nat的介绍及利用nat来实现地址转换

NAT(network  address  tranrlation)网络地址转换,还有一个PAT(port address tranrlation)端口地址转换
nat的设置分为静态地址转换、动态地址转换、复用动态地址转换
那我们现在为什么要用地址转化呢?
1、随着Internet的飞速发展,网上丰富的资源产生着巨大的吸引力
2、接入Internet成为当今信息业最为迫切的需求
3、但这受到IP地址的许多限制
首先,许多局域网在未联入Internet之前,就已经运行许多年了,局
  域网上有了许多现成的资源和应用程序,但它的IP地址分配不符合
  Internet的国际标准,因而需要重新分4、配局域网的IP地址,这无疑是
  劳神费时的工作
5、其二,随着Internet的膨胀式发展,其可用的IP地址越来越少,要想
 6、 在ISP处申请一个新的IP地址已不是很容易的事了
7、NAT(网络地址翻译)能解决不少令人头疼的问题
8、它解决问题的办法是:在内部网络中使用内部地址,通过NAT把内部地址翻译成合法的IP地址,在Internet上使用
9、其具体的做法是把IP包内的地址池(内部本地)用合法的IP地址段(内部全局)来替换
       NAT 功能:
                  内部网络地址转换
                   复用内部的全局地址
                  TCP 负载均衡
                  解决网络地址重叠

NAT有三种类型:静态NAT(staticNAT)、NAT池(pooledNAT)和端口NAT(PAT)。
其中静态NAT设置起来最为简单,内部网络中的每个主机都被永久映
  射成 外部网络中的某个合法的地址,多用于服务器。
而NAT池则是在外部网络中定义了一系列的合法地址,采用动态分配
  的方法映射到内部网络,多用于网络中的工作站。
PAT则是把内部地址映射到外部网络的一个IP地址的不同端口上。
NAT静态映射实例
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
ip nat inside(指定内部接口)
!
interface Serial0
 ip address 200.1.1.1 255.255.255.0
 ip nat outside (指定外部接口)
!
ip nat inside source static 172.16.1.3 200.1.1.1
(建立两个IP地址之间的静态映射)
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.2
注意
从外网到内网建立静态映射后,外网能PING通内部全局地址(200.1.1.1),如果使用真实地址,则访问失败,这是因为从外网没有到达内网的路由存在!
Ping 172.16.1.3 ……
Ping 200.1.1.5  !!!!!
动态NAT的配置:
ip nat pool dyn-nat 192.16.2.1  192.16.2.254 netmask 255.255.255.0
ip nat inside source list 1 pool dyn-nat
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
 ip nat inside
interface Serial0
ip address 192.16.2.1 255.255.255.0
 ip nat outside 
access-list 1 permit 10.1.1.0 0.0.0.255
今天我们来做两个实验一个是静态,一个是动态。
先来做静态的:
目的:使用静态nat转换内网地
步骤:1、配置ip
             2、设置nat
要求:全网全通
拓扑图如下:
 
配置:
r1:
en
conf  t
host  r1
int  s0/0
ip  addr  192.168.1.2  255.255.255.0
no  shut 
int f1/0
ip  addr  192.168.2.1  255.255.255.0
clock  rate  64000
no shut 
ip  nat  inside  source  static  192.168.1.1 192.168.2.6
ip route 0.0.0.0 0.0.0.0 s0/0
r2:
en
conf t
host r2
int s0/0
ip addr 192.168.2.2 255.255.255.0
no shut 
int f1/0
ip addr 192.168.3.1 255.255.255.0
no shut 
ip nat inside source static 192.168.4.1 192.168.2.6
ip route 0.0.0.0 0.0.0.0 s0/0
在虚拟pc上配上ip指定好网关
pc1:ip 192.168.1.1 192.168.1.2
pc2:ip 192.168.3.2 192.168.3.1
写好文本后开始粘贴
验证一下,全网全通,成功。
接下来我们来做第二个实验动态nat
步骤:1、定义ip
              2、定义动态ip池及池名
              3、指定pc机到指定的ip池中
              4、添加访问控制列表
              5、添加缺省路由
要求:pc1-pc3在2.6-2.9网段中DHCP名为itet
             pc4-pc6在2.11-2.13网段中DHCP名为itat
全网全通就成功
链路连接如下:
Router1 S0/0 <----> Router2 S0/0 
Router1 F1/0 <----> Switch1 F0/0 
Router2 F1/0 <----> Switch2 F0/0 
Switch1 F0/1 <----> VPCS V0/1 
Switch1 F0/2 <----> VPCS V0/2 
Switch1 F0/3 <----> VPCS V0/3 
Switch2 F0/4 <----> VPCS V0/4 
Switch2 F0/5 <----> VPCS V0/5 
Switch2 F0/6 <----> VPCS V0/6
拓扑图如下:
写配置
r1:
en
conf t
host  r1
int f1/0
ip addr 192.168.1.1 255.255.255.0
no shut
ip nat inside
exit
int s0/0
ip addr 192.168.2.1 255.255.255.0
no shut
ip nat outside
clock rate 64000
ip nat pool itet 192.168.2.6 192.168.2.9 netmask 255.255.255.0
access-list 1permit 192.168.1.0 0.0.0.255
ip nat inside source list 0 pool itet
ip route 0.0.0.0 0.0.0.0 s0/0
r2:
en
conf t
host  r2
int f1/0
ip addr 192.168.3.1 255.255.255.0
no shut
ip nat inside
exit
int s0/0
ip addr 192.168.2.2 255.255.255.0
no shut
ip nat outside
ip nat pool itat 192.168.2.11 192.168.2.13 netmask 255.255.255.0
access-list 1permit 192.168.1.0 0.0.0.255
ip nat inside source list 0 pool itat
ip route 0.0.0.0 0.0.0.0 s0/0
在pc机上直接配置ip及网关就可以了
pc1:ip 192.168.1.2 192.168.1.1
pc2:ip 192.168.1.3 192.168.1.1
pc3:ip 192.168.1.4 192.168.1.1
pc4:ip 192.168.3.2 192.168.3.1
pc5:ip 192.168.3.3 192.168.3.1
pc6:ip 192.168.3.4 192.168.3.1
接下来开始粘贴没有错误开始验证。
验证,让pc6ping所有网段都通成功。









本文转自 liuyonglei 51CTO博客,原文链接:http://blog.51cto.com/liuyonglei/132630,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
Kettle之数据抽取、转换、装载
Kettle 官网   ETL利器Kettle实战应用解析系列   利用kettle组件导入excel文件到数据库   kettle中实现动态SQL查询   java中调用kettle转换文件   kettle 7.
2098 0
【译】Databricks使用Spark Streaming和Delta Lake对流式数据进行数据质量监控介绍
本文主要对Databricks如何使用Spark Streaming和Delta Lake对流式数据进行数据质量监控的方法和架构进行了介绍,本文探讨了一种数据管理架构,该架构可以在数据到达时,通过主动监控和分析来检测流式数据中损坏或不良的数据,并且不会造成瓶颈。
1087 0
日志服务CLI ETL - 编排与转换
介绍日志服务命令行工具ETL简单、全面、灵活的日志规则编排与转换方式,编排覆盖分发、分裂、删减等;转换包括:JSON、KV、正则表达式、CSV、Lookup等
2701 0
+关注
12613
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
文娱运维技术
立即下载
《SaaS模式云原生数据仓库应用场景实践》
立即下载
《看见新力量:二》电子书
立即下载