VS2010 + Sql Server Express 2008 R2 如何安装-阿里云开发者社区

开发者社区> 数据库> 正文
登录阅读全文

VS2010 + Sql Server Express 2008 R2 如何安装

简介:

完全相同的项目和环境(VS2010 + Sql Server Express 2008 R2),居然报错说不支持数据库版本,终于解决了。

 

上网一查,谈论的人很多,大致问题是:661是2008R2数据库的版本,而2008则是655。可问题在于:从来没有安装过2008,只安装了2008 R2,为何会出现这个问题呢?

原来,如果先安装VS2010,它发现没有数据库,就自动安装了一个2008的什么版本(在SQL的安装目录中会出现一个10.0版本的目录,而安装2008R2后,又会出现一个10.5版本的目录),而它会执着地把所有R2数据库当作2008来处理,就出现了这个错误。

有个老外推荐了使用Tools/Connect Database来重新定位,我试了很多次,都不行,不过反倒发现了这种方法:

 

1. 卸载VS和R2

2. 先安装R2

3. 再安装VS

 

好了,原来就这么简单。

到SQL目录中,果然没有那个10.0目录了。


本文转自火星人陈勇 51CTO博客,原文链接:http://blog.51cto.com/cheny/1100097

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: