开发者社区> 科技小能手> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

实战HCNA1:华为设备快速记忆生成树的角色及选举规则,实施基本的VLAN间路由和基础的VRRP协议

简介:
+关注继续查看

拓扑图
实战HCNA1:华为设备快速记忆生成树的角色及选举规则,实施基本的VLAN间路由和基础的VRRP协议
2.1.实施生成树
STP中的几个角色举例 
老板 ROOT(有且只有1个)
秘书 DP (每个链路上有且只有1个)
经理 RP (每个非根上有且只有1个)
员工 AP(阻塞的端口)
1.1 选举根设备(如何选举老板)
桥ID:优先级+MAC
先通过优先级进行选举-->MAC地址较小的
32768.4c1f-cc00-4dd0-SW1 (根设备)
32768.4c1f-cc2e-6903-SW2
只能修改优先级,而不能修改背板MAC
园区网的调整:
[SW5]stp root primary 
[SW6]stp root secondary //本质为修改优先级,如下所示
[SW5]dis stp
-------[CIST Global Info][Mode MSTP]-------
CIST Bridge :0 .4c1f-cc4c-0e39
[SW6]dis stp
-------[CIST Global Info][Mode MSTP]-------
CIST Bridge :4096 .4c1f-cc51-015b
什么接口处于转发(业务数据)的状态?秘书和经理
1.2 选举RP选举原则
RP仅仅存在于非根设备上,有且只有一个!
注意,都是小的优先
RPC,root path cost
对端的桥ID 小
对端的端口ID(端口ID由端口优先级+序号组成)小 128.10 经理要看别人脸色
本端的端口ID小
1.3 选举DP(秘书)
在每个链路上有且只有一个DP
选举原则:
RPC小的端口
端口所在交换机的BID小的
端口所在交换机的PID小的

哪种情况下DP和RP会是同一个端口,没有!
生成树中的时间:
Config Times :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
Active Times :Hello 2s MaxAge 20s FwDly 15s MaxHop 20 (message age)
hello间隔(BPDU的发送间隔) 2
FwDly 15s 转发时延(LIS-LRN,LRN-FWD),边缘端口跳过LIS和LRN,直接到转发状态
MaxAge 20s,最大生存时间20s
优化边缘(连接终端或者服务器)的端口:
建议在所有的接入设备上配置
stp edged-port default //全局配置,所有的access接口实施了端口快速特性
[SW3]dis stp int g0/0/10
Port Edged :Config=default / Active=enabled
[SW3-GigabitEthernet0/0/10]stp edged-port enable //接口下实施的
Port Edged :Config=enabled / Active=enabled

2.实施不同VLAN间通信
10.1.10.1<-MAC地址表->10.1.10.2
10.1.10.1《-路由表-》10.1.60.1
2.1 单臂路由
路由器上实施子接口,子接口要封装VLAN ID,能够转发ARP广播
1)AR1:
interface GigabitEthernet0/0/1.10
dot1q termination vid 10
ip address 10.1.10.30 255.255.255.224 
arp broadcast enable
#
interface GigabitEthernet0/0/1.20 
dot1q termination vid 20
ip address 10.1.20.30 255.255.255.224 
arp broadcast enable
2)交换机连接路由器的接口实施trunk
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
单臂路由通过直连完成通信!
借助路由器的子接口来实现的
2.2 VLANIF(多层交换机上的VLAN接口)
工作的条件:1)vlan存在 2)有接口划入了该VLAN (access到vlan30) 或者是 3)trunk、Hybird允

许了VLAN30通过
int vlan xx
ip add xx

3.实施冗余备份VRRP技术
虚拟路由器冗余协议,公有标准,第一跳冗余技术,备份网关
,是一个3层技术(虽然在2层讲解)
[SW5-Vlanif40]dis th
#
interface Vlanif40
ip address 10.1.40.14 255.255.255.240
vrrp vrid 40 virtual-ip 10.1.40.14 //虚拟IP等于真实IP,那么该设备SW5的VRRP的优先级为255(

最优)
interface Vlanif40。MASTER响应PC发起的ARP请求
ip address 10.1.40.13 255.255.255.240
vrrp vrid 40 virtual-ip 10.1.40.14
验证命令:
dis vrrp bri


本文转自EnderJoe 51CTO博客,原文链接:http://blog.51cto.com/enderjoe/2046834


版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
freeswitch使用sip集成网页电话,nginx配置https协议
文章目录 网页集成软电话 配置freeswitch开启wss nginx配置自签名https域名 页面集成软电话开发 网页集成软电话 网页集成软电话需要使用https协议,页面与freeswitch平台建立websocket长连接。使用jssip库进行相关开发
293 0
SAP Spartacus B2B user列表对应的Angular Component
SAP Spartacus B2B user列表对应的Angular Component
58 0
SAP Spartacus B2B user列表对应的Angular Component
SAP Spartacus B2B user列表对应的Angular Component
42 0
How to Install Backdrop CMS on FAMP (FreeBSD 11.1)
In this tutorial, we will be setting up Backdrop CMS on a FAMP stack using an Alibaba Cloud ECS instance (FreeBSD 11.11).
4456 0
TreeMap:是基于红黑树的Map接口的实现
》 TreeMap:是基于红黑树的Map接口的实现。 红黑树:平衡二叉树 取出时,可以有三种方式:前序遍历,中序遍历,后序遍历 》排序: A 自然排序  --TreeMap无参构造 TreeMap map= new TreeMap(); ...
854 0
文章
问答
文章排行榜
最热
最新
相关电子书
更多
互联网协议第六版(IPv6)部署方案及设计
立即下载
思科软件定义访问:实现基于业务意图的园区网络
立即下载
云通信—构筑直连用户之“桥”
立即下载