非等价链路部分设备跑OSPF自动切换SLA测试

简介:

一.概述:
   QQ群里一位网友咨询三个地方通过MSTP专线两两互连,都是思科的设备,但是其中一台不支持OSPF,问如果保证正常情况下,数据走8M线路,但8M链路出现问题时才走4M备份链路,于是用GNS3搭建环境测试了一下,温习一下sla的设置。
二.基本思路:
A.静态路由优先动态OSPF路由,静态路由配置不同的metric值,并且设置SLA
B.备份链路因为能跑动态路由,因此把静态路由重分布到动态路由,这样可以保证三条线路任意一条线路出现故障时都不会影响三个网络的互相访问。
三.测试拓扑:

四.基本配置:
A.R1:

interface Loopback100
ip address 192.168.1.1 255.255.255.0
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
no shut
interface FastEthernet0/1
ip address 13.1.1.1 255.255.255.0
no shut
B.R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Loopback100
ip address 192.168.2.2 255.255.255.0
ip ospf network point-to-point
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
no shut
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
no shut
C.R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Loopback100
ip address 192.168.3.3 255.255.255.0
ip ospf network point-to-point
interface FastEthernet0/0
ip address 13.1.1.3 255.255.255.0
no shut     
interface FastEthernet0/1
ip address 23.1.1.3 255.255.255.0
no shut
五.静态路由配置:
A.R1:

ip route 192.168.2.0 255.255.255.0 12.1.1.2
ip route 192.168.2.0 255.255.255.0 13.1.1.3 10
ip route 192.168.3.0 255.255.255.0 13.1.1.3
ip route 192.168.3.0 255.255.255.0 12.1.1.2 10
----配置两条不同metric的路由,优先选择metric小的条目

----目标网络是相邻设备的直连网络,可以不用配置SLA,当直连线路出现故障时会自动选择metric大的那条路由。
B.R2:
ip route 192.168.1.0 255.255.255.0 12.1.1.1 (静态路由优先动态路由

C.R3:
ip route 192.168.1.0 255.255.255.0 13.1.1.1  静态路由优先动态路由
六.SLA及静态路由
A.R2:
ip sla 1
icmp-echo 13.1.1.1 source-interface FastEthernet0/0
frequency 10
ip sla schedule 1 life forever start-time now
track 1 rtr 1 reachability
ip route 192.168.3.0 255.255.255.0 12.1.1.1 track 1
ip route 13.1.1.1 255.255.255.255 12.1.1.1 tag 10
----配置主机路由是为了进行track,主机路由打tag是为了后面OSPF重分布时方便过滤

----选择的是绕行线路,需要配置监控,监控绕行的非直连链路上面的IP

B.R3:
ip sla 1
icmp-echo 12.1.1.1 source-interface FastEthernet0/0
frequency 10
ip sla schedule 1 life forever start-time now
track 1 rtr 1 reachability
ip route 12.1.1.1 255.255.255.255 13.1.1.1 tag 10
ip route 192.168.2.0 255.255.255.0 13.1.1.1 track 1
----配置主机路由是为了进行track,主机路由打tag是为了后面OSPF重分布时方便过滤

----选择的是绕行线路,需要配置监控,监控绕行的非直连链路上面的IP

七.动态路由OSPF配置:
A.R2:
route-map static deny 10
match tag 10
route-map static permit 20
router ospf 1
router-id 2.2.2.2
redistribute static subnets route-map static
passive-interface default
no passive-interface FastEthernet0/1
network 23.1.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
B.R3:
route-map static deny 10
match tag 10
route-map static permit 20
router ospf 1
router-id 3.3.3.3
redistribute static subnets route-map static
passive-interface default
no passive-interface FastEthernet0/1
network 23.1.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
八.测试:

A.正常情况下测试

----测试结果:所有流量都走两条8M的线路

①R1上traceroute

----R1去R2和R3身后网络,都走直连8M线路

R1#traceroute 192.168.2.2 source 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.2.2

 1 12.1.1.2 100 msec *  68 msec
R1#traceroute 192.168.3.3 source 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.3.3

 1 13.1.1.3 76 msec *  108 msec
②R2上traceroute

----R2去R3身后网络,从R1绕行,选择两跳都为8M的线路
R2#traceroute 192.168.1.1 source 192.168.2.2

Type escape sequence to abort.
Tracing the route to 192.168.1.1

 1 12.1.1.1 108 msec *  60 msec
R2#traceroute 192.168.3.3 source 192.168.2.2

Type escape sequence to abort.
Tracing the route to 192.168.3.3

 1 12.1.1.1 120 msec 92 msec 64 msec
 2 13.1.1.3 108 msec *  96 msec
③R3上traceroute

----R3去R2身后网络,从R1绕行,选择两跳都为8M的线路
R3#traceroute 192.168.1.1 source 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.1.1

 1 13.1.1.1 92 msec *  80 msec
R3#traceroute 192.168.2.2 source 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.2.2

 1 13.1.1.1 76 msec 80 msec 24 msec
 2 12.1.1.2 176 msec *  108 msec

B.R1和R3之间的8M链路出现故障:

----在GNS中必须把相连的两个接口都shutdown,实际情况只要链路出现故障,应该两个设备都能检测的到。

①R1上traceroute

----R1去R3身后网络,自动走R2绕行

R1#traceroute 192.168.2.2 source 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.2.2

 1 12.1.1.2 92 msec *  64 msec
R1#traceroute 192.168.3.3 source 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.3.3

 1 12.1.1.2 100 msec 80 msec 44 msec
 2 23.1.1.3 96 msec *  108 msec
②R2上traceroute

----R2去R1和R3身后网络,都走直连
R2#traceroute 192.168.1.1 source 192.168.2.2

Type escape sequence to abort.
Tracing the route to 192.168.1.1

 1 12.1.1.1 60 msec *  128 msec
R2#traceroute 192.168.3.3 source 192.168.2.2

Type escape sequence to abort.
Tracing the route to 192.168.3.3

 1 23.1.1.3 120 msec *  112 msec
③R3上traceroute

----R3去R1身后网络,自动走R2绕行
R3#traceroute 192.168.1.1 source 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.1.1

 1 23.1.1.2 100 msec 92 msec 68 msec
 2 12.1.1.1 84 msec *  112 msec
R3#traceroute 192.168.2.2 source 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.2.2

 1 23.1.1.2 120 msec *  80 msec
C.R1和R3之间的8M链路恢复,但R1和R2之间的8M链路出现故障:
①R1上traceroute

----R1去R2身后网络,自动走R3

R1#traceroute 192.168.2.2 source 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.2.2

 1 13.1.1.3 52 msec 88 msec 44 msec
 2 23.1.1.2 88 msec *  132 msec
R1#traceroute 192.168.3.3 source 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.3.3

 1 13.1.1.3 132 msec *  92 msec
②R2上traceroute

----R2去R1身后网络,自动走R3
R2#traceroute 192.168.1.1 source 192.168.2.2

Type escape sequence to abort.
Tracing the route to 192.168.1.1

 1 23.1.1.3 68 msec 112 msec 64 msec
 2 13.1.1.1 80 msec *  116 msec
R2#traceroute 192.168.3.3 source 192.168.2.2

Type escape sequence to abort.
Tracing the route to 192.168.3.3

 1 23.1.1.3 112 msec *  140 msec
③R3上traceroute

----R3去R1和R2身后网络,都走直连
R3#traceroute 192.168.1.1 source 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.1.1

 1 13.1.1.1 92 msec *  * 
R3#traceroute 192.168.2.2 source 192.168.3.3  

Type escape sequence to abort.
Tracing the route to 192.168.2.2

 1 23.1.1.2 84 msec *  116 msec




本文转自 碧云天 51CTO博客,原文链接:http://blog.51cto.com/333234/1231044,如需转载请自行联系原作者

相关文章
|
1月前
|
Web App开发 前端开发 安全
前端研发链路之测试
本文由前端徐徐撰写,介绍了前端测试的重要性及其主要类型,包括单元测试、E2E测试、覆盖率测试、安全扫描和自动化测试。文章详细讲解了每种测试的工具和应用场景,并提供了选择合适测试策略的建议,帮助开发者提高代码质量和用户体验。
31 3
前端研发链路之测试
|
18天前
|
Web App开发 定位技术 iOS开发
Playwright 是一个强大的工具,用于在各种浏览器上测试应用,并模拟真实设备如手机和平板。通过配置 `playwright.devices`,可以轻松模拟不同设备的用户代理、屏幕尺寸、视口等特性。此外,Playwright 还支持模拟地理位置、区域设置、时区、权限(如通知)和配色方案,使测试更加全面和真实。例如,可以在配置文件中设置全局的区域设置和时区,然后在特定测试中进行覆盖。同时,还可以动态更改地理位置和媒体类型,以适应不同的测试需求。
Playwright 是一个强大的工具,用于在各种浏览器上测试应用,并模拟真实设备如手机和平板。通过配置 `playwright.devices`,可以轻松模拟不同设备的用户代理、屏幕尺寸、视口等特性。此外,Playwright 还支持模拟地理位置、区域设置、时区、权限(如通知)和配色方案,使测试更加全面和真实。例如,可以在配置文件中设置全局的区域设置和时区,然后在特定测试中进行覆盖。同时,还可以动态更改地理位置和媒体类型,以适应不同的测试需求。
17 1
|
3月前
|
测试技术 Linux Android开发
i2c总线及设备测试工具i2ctools:i2cdetect、i2cdump、i2cget、i2cset
本文介绍了i2ctools工具集的使用,包括i2cdetect、i2cdump、i2cget和i2cset,这些工具有助于I2C设备的开发和调试,通过检测设备、读写寄存器和数据块来提高开发效率。
542 1
|
3月前
|
Java 测试技术
SpringBoot单元测试快速写法问题之区分链路环节是否应该被Mock如何解决
SpringBoot单元测试快速写法问题之区分链路环节是否应该被Mock如何解决
|
3月前
|
Java 测试技术 API
SpringBoot单元测试快速写法问题之确定链路上的Mock点如何解决
SpringBoot单元测试快速写法问题之确定链路上的Mock点如何解决
|
3月前
|
测试技术 索引 CDN
hyengine wasm业务性能测试问题之测试设备如何解决
hyengine wasm业务性能测试问题之测试设备如何解决
|
4月前
|
安全 物联网 物联网安全
物联网设备的安全性评估与测试:技术深度解析
【7月更文挑战第7天】物联网设备的安全性评估与测试是保障物联网系统安全运行的重要环节。通过实施全面的安全性评估与测试,可以发现并修复设备中存在的安全漏洞和风险,提高整体安全防护能力。然而,由于物联网设备的多样性和复杂性以及安全标准与监管的缺失等挑战,测试工作需要不断创新和优化。未来,随着技术的不断进步和实践的深入,物联网设备的安全性评估与测试将更加完善和高效。
|
6月前
|
安全 物联网 测试技术
构建未来:Android与IoT设备的无缝交互深入探索软件自动化测试的未来趋势
【5月更文挑战第30天】在物联网(IoT)技术快速发展的当下,Android系统因其开放性和广泛的用户基础成为了连接智能设备的首选平台。本文将探讨如何通过现代Android开发技术实现智能手机与IoT设备的高效、稳定连接,并分析其中的挑战和解决方案。我们将深入挖掘Android系统的底层通信机制,提出创新的交互模式,并通过实例演示如何在Android应用中集成IoT控制功能,旨在为开发者提供一套可行的指导方案,促进IoT生态系统的进一步发展。
|
6月前
|
数据采集 数据管理 测试技术
LabVIEW开发新型电化学性能测试设备
LabVIEW开发新型电化学性能测试设备
56 6
|
6月前
|
编解码 测试技术 API
模拟手机设备:使用 Playwright 实现移动端自动化测试
本文介绍了使用Python的Playwright库进行移动设备模拟和自动化测试的方法。通过Playwright,开发者能模拟不同设备的硬件和软件特性,如屏幕尺寸、用户代理,以确保网站在移动设备上的表现。示例代码展示了如何模拟iPhone X并访问网站,之后可在此基础上编写测试代码以检验响应式布局和交互功能。Playwright的设备参数注册表支持多种设备,简化了移动端自动化测试的流程。