如何配置三层交换机创建VLAN-阿里云开发者社区

开发者社区> 技术小牛人> 正文

如何配置三层交换机创建VLAN

简介:
+关注继续查看
    曾有博友问,“如何配置三层交换机创建VLAN ”这个问题,我参考了其他书籍和网络上面的一些资料简单的介绍下。
 
  以下的介绍都是基于Cisco交换机的VLANCiscoVLAN实现通常是以端口为中心的,与节点相连的端口将确定它所驻留的VLAN。将端口分配给VLAN的方式有两种,分别是静态的和动态的。
 
  形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP VLAN Trunking ProtocolServer上建立VLAN,然后将每个端口分配给相应的VLAN的过程。这是我们创建VLAN最常用的方法。
 
  动态VLAN形成很简单,由具体的机器决定自己属于哪个VLAN。即我们先建立一个VMPSVLAN Membership Policy ServerVLAN管理策略服务器,里面包含一个文本文件,文件中存有与VLAN映射的MAC地址表。交换机根据这个映射表决定将端口分配给何种VLAN。这种方法有很大的优势,但创建数据库是一项非常艰苦而且非常繁琐的工作。

 
  下面以实例说明如何在一个典型的快速以太局域网中实现VLAN
 
  所谓典型局域网就是指由一台具备三层交换功能的核心交换机接几台分支交换机(不一定具备三层交换能力)。我们假设核心交换机名称为:COM;分支交换机分别为:PAR1PAR2PAR3,分别通过Port 1的光线模块与核心交换机相连;并且假设VLAN名称分别为COUNTERMARKETMANAGING

 
需要做的工作:

 
1、设置VTP DOMAIN(核心、分支交换机上都设置)

2、配置中继(核心、分支交换机上都设置)

3、创建VLAN(在server上设置)

4、将交换机端口划入VLAN

5、配置三层交换

 
1、设置VTP DOMAIN VTP DOMAIN 称为管理域。
 
  交换VTP更新信息的所有交换机必须配置为相同的管理域。如果所有的交换机都以中继线相连,那么只要在核心交换机上设置一个管理域,网络上所有的交换机都加入该域,这样管理域里所有的交换机就能够了解彼此的VLAN列表。
 

COM#vlan database 进入VLAN配置模式

COM(vlan)#vtp domain COM 设置VTP管理域名称 COM

COM(vlan)#vtp server 设置交换机为服务器模式

PAR1#vlan database 进入VLAN配置模式

PAR1(vlan)#vtp domain COM 设置VTP管理域名称COM

PAR1(vlan)#vtp Client 设置交换机为客户端模式

PAR2#vlan database 进入VLAN配置模式

PAR2(vlan)#vtp domain COM 设置VTP管理域名称COM

PAR2(vlan)#vtp Client 设置交换机为客户端模式

PAR3#vlan database 进入VLAN配置模式

PAR3(vlan)#vtp domain COM 设置VTP管理域名称COM

PAR3(vlan)#vtp Client 设置交换机为客户端模式

 
注意:这里设置核心交换机为Server模式是指允许在该交换机上创建、修改、删除VLAN及其他一些对整个VTP域的配置参数,同步本VTP域中其他交换机传递来的最新的VLAN信息;Client模式是指本交换机不能创建、删除、修改VLAN配置,也不能在NVRAM中存储VLAN配置,但可同步由本VTP域中其他交换机传递来的VLAN信息。

 
2、配置中继为了保证管理域能够覆盖所有的分支交换机,必须配置中继。
 
  Cisco交换机能够支持任何介质作为中继线,为了实现中继可使用其特有的ISL标签。ISLInterSwitch Link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个VLAN信息及VLAN数据流的协议,通过在交换机直接相连的端口配置ISL封装,即可跨越交换机进行整个网络的VLAN分配和进行配置。

在核心交换机端配置如下:

 
COM(config)#interface gigabitEthernet 2/1

COM(config-if)#switchport

COM(config-if)#switchport trunk encapsulation isl 配置中继协议

COM(config-if)#switchport mode trunk

COM(config)#interface gigabitEthernet 2/2

COM(config-if)#switchport

COM(config-if)#switchport trunk encapsulation isl 配置中继协议

COM(config-if)#switchport mode trunk

COM(config)#interface gigabitEthernet 2/3

COM(config-if)#switchport

COM(config-if)#switchport trunk encapsulation isl 配置中继协议

COM(config-if)#switchport mode trunk

 
在分支交换机端配置如下:

 
PAR1(config)#interface gigabitEthernet 0/1

PAR1(config-if)#switchport mode trunk

PAR2(config)#interface gigabitEthernet 0/1

PAR2(config-if)#switchport mode trunk

PAR3(config)#interface gigabitEthernet 0/1

PAR3(config-if)#switchport mode trunk

此时,管理域算是设置完毕了。
 

3、创建VLAN一旦建立了管理域,就可以创建VLAN了。

 
COM(vlan)#Vlan 10 name COUNTER 创建了一个编号为10 名字为COUNTER VLAN

COM(vlan)#Vlan 11 name MARKET 创建了一个编号为11 名字为MARKET VLAN

COM(vlan)#Vlan 12 name MANAGING 创建了一个编号为12 名字为MANAGING VLAN

 
注意,这里的VLAN是在核心交换机上建立的,其实,只要是在管理域中的任何一台VTP 属性为Server的交换机上建立VLAN,它就会通过VTP通告整个管理域中的所有的交换机。但如果要将具体的交换机端口划入某个VLAN,就必须在该端口所属的交换机上进行设置。

 
4、将交换机端口划入VLAN

 
例如,要将PAR1PAR2PAR3……分支交换机的端口1划入COUNTER VLAN,端口2划入MARKET VLAN,端口3划入MANAGING VLAN……

PAR1(config)#interface fastEthernet 0/1 配置端口1

PAR1(config-if)#switchport access vlan 10 归属COUNTER VLAN

PAR1(config)#interface fastEthernet 0/2 配置端口2

PAR1(config-if)#switchport access vlan 11 归属MARKET VLAN

PAR1(config)#interface fastEthernet 0/3 配置端口3

PAR1(config-if)#switchport access vlan 12 归属MANAGING VLAN

PAR2(config)#interface fastEthernet 0/1 配置端口1

PAR2(config-if)#switchport access vlan 10 归属COUNTER VLAN

PAR2(config)#interface fastEthernet 0/2 配置端口2

PAR2(config-if)#switchport access vlan 11 归属MARKET VLAN

PAR2(config)#interface fastEthernet 0/3 配置端口3

PAR2(config-if)#switchport access vlan 12 归属MANAGING VLAN

PAR3(config)#interface fastEthernet 0/1 配置端口1

PAR3(config-if)#switchport access vlan 10 归属COUNTER VLAN

PAR3(config)#interface fastEthernet 0/2 配置端口2

PAR3(config-if)#switchport access vlan 11 归属MARKET VLAN

PAR3(config)#interface fastEthernet 0/3 配置端口3

PAR3(config-if)#switchport access vlan 12 归属MANAGING VLAN

 
5、配置三层交换
 
  到这里,VLAN已经基本划分完毕。但是,VLAN间如何实现三层(网络层)交换呢?这时就要给各VLAN分配网络(IP)地址了。给VLAN分配IP地址分两种情况,其一,给VLAN所有的节点分配静态IP地址;其二,给VLAN所有的节点分配动态IP地址。下面就这两种情况分别介绍。

 
  假设给VLAN COUNTER分配的接口Ip地址为172.16.58.1/24,网络地址为:172.16.58.0

VLAN MARKET 分配的接口Ip地址为172.16.59.1/24,网络地址为:172.16.59.0

VLAN MANAGING分配接口Ip地址为172.16.60.1/24 网络地址为172.16.60.0

如果动态分配IP地址,则设网络上的DHCP服务器IP地址为172.16.1.11

 
(1)VLAN所有的节点分配静态IP地址。

 
首先在核心交换机上分别设置各VLAN的接口IP地址。核心交换机将vlan做为一种接口对待,就象路由器上的一样,如下所示:

COM(config)#interface vlan 10

COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP

COM(config)#interface vlan 11

COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP

COM(config)#interface vlan 12

COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP

再在各接入VLAN的计算机上设置与所属VLAN的网络地址一致的IP地址,并且把默认网关设置为该VLAN的接口地址。这样,所有的VLAN也可以互访了。

 

(2)VLAN所有的节点分配动态IP地址。

 
首先在核心交换机上分别设置各VLAN的接口IP地址和同样的DHCP服务器的IP地址,如下所示:

 
COM(config)#interface vlan 10

COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP

COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

COM(config)#interface vlan 11

COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP

COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

COM(config)#interface vlan 12

COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP

COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

 
再在DHCP服务器上设置网络地址分别为172.16.58.0172.16.59.0172.16.60.0
的作用域,并将这些作用域的路由器选项设置为对应VLAN的接口IP地址。这样,可以保证所有的VLAN也可以互访了。

 
最后在各接入VLAN的计算机进行网络设置,将IP地址选项设置为自动获得IP地址即可。

  

本文转自

jiangxuezhi2009 51CTO博客,原文链接:http://blog.51cto.com/jiangxuezhi/338387 ,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
在创建窗口句柄之前,不能在控件上调用 Invoke 或 BeginInvoke。
本文转载:http://blog.csdn.net/playing9c/article/details/7471918              http://blog.csdn.net/beelinkerlidejun/article/details/4772491              http://www.cnblogs.com/fish124423/archive/2012/10/16/2726543.html C#窗体的多线程一直是个难题,总是要出现奇奇怪怪的错误。
1131 0
Notepad++配置Golang开发环境
简述 Notepad++ 不支持 Go 语言的立即使用,可以为其安装 GOnpp 插件。安装之前,需要先配置好 Go 的环境。 简述 安装 Go 开发插件 配置语法高亮 更多参考 安装 Go 开发插件 运行 Notepad++ 软件 打开菜单,选择:插件 -> Plugin Manager -> Show Plugin Manage
1324 0
创建SinaSAE云账号创建和发布基于SVN代码管理的PHP空工程
1、使用Sina微博账号登录,进入【新浪云控制台】 2、选择【云应用SAE】界面,选择【创建新应用】 3、点击【继续创建】,进入应用信息编辑界面     依次编辑“二级域名”“应用程序名”,再点【运行环境】中的【PHP空应用】,再点左下角的【创建应用】完成应用创建。
844 0
在windows平台下使用vscode当golang开发环境的配置
一、使用的平台与软件: 1、window 7 或者10,注意必须是64位,否则不能使用delve debug 2、go1.11.5.windows-amd64.msi 3、Git-2.20.1-64-bit.exe 4、VSCodeUserSetup-x64-1.31.1.exe 二、安装git,golang,vscode git软件全部使用缺省配置即可,安装完成后也不需要做太多配置; golang一般缺省安装在C:\go下 重点是需要设置GOPATH的环境变量。
2810 0
《VMware Virtual SAN权威指南(原书第2版)》一3.8 创建VSAN群集
本节书摘来自华章出版社《VMware Virtual SAN权威指南(原书第2版)》一 书中的第3章,第3.8节,作者:[美] 科马克·霍根,邓肯·埃平,更多章节内容可以访问云栖社区“华章计算机”公众号查看。
1073 0
5723
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载