开发者社区> 白及88> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

not defined in file libmysqlclient.so.18 with link time reference

简介: [root@master conf]<span style="color:#3333ff"># /opt/php/sbin/php-fpm</span><br><p>/opt/php/sbin/php-fpm: relocation error: /opt/php/sbin/php-fpm: symbol mysql_server_init, version libmysqlclient_
+关注继续查看
[root@master conf]# /opt/php/sbin/php-fpm

/opt/php/sbin/php-fpm: relocation error: /opt/php/sbin/php-fpm: symbol mysql_server_init, version libmysqlclient_18

 not defined in file libmysqlclient.so.18 with link time reference


记录一下,没有找到解决办法。

欢迎留言。

1、如下不行:

自己一定要删除干净。


最近编译php的时候在加入mysql编译参数的时候报错,然后我就仔细的研究了下

基本情况
系统:CentOS-6.5
数据库:之前yum安装了mysql后来卸载掉,编译安装了mysql
php:我电脑里装了两个版本的php
一个是yum安装的 php-5.4.28
另一个是编译安装的 php-5.3.28

以下是各种报错

1
2
3
4
5
[root@localhost php-5.3]# php-fpm
[09-Jun-2014 15:37:41] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library'/usr/lib64/php/modules/mysql.so'- /usr/lib64/mysql/libmysqlclient.so.18: version `libmysqlclient_16' not found (required by /usr/lib64/php/modules/mysql.so) in Unknown on line 0
[09-Jun-2014 15:37:41] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library'/usr/lib64/php/modules/mysqli.so'- /usr/lib64/mysql/libmysqlclient.so.18: version `libmysqlclient_16' not found (required by /usr/lib64/php/modules/mysqli.so) in Unknown on line 0
[09-Jun-2014 15:37:41] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library'/usr/lib64/php/modules/pdo_mysql.so'- /usr/lib64/mysql/libmysqlclient.so.18: version `libmysqlclient_16' not found (required by /usr/lib64/php/modules/pdo_mysql.so) in Unknown on line 0
[root@localhost php-5.3]#
1
version libmysqlclient_18 not defined in file libmysqlclient.so.18 with link time reference
1
/usr/lib64/mysql/libmysqlclient.so.18: version `libmysqlclient_16' not found (required by /usr/lib64/php/modules/mysql.so) in Unknown on line 0

错误分析
是64位系统中 libmysqlclient 默认安装到了 /usr/lib64/mysql/ 目录下
如果此目录没有加入到 /etc/ld.so.conf里面,Linux就无法自动加载 /usr/lib64/mysql/ 里面的库文件
php编译时要去 /usr/lib64 和 /etc/ld.so.conf 所指定的目录下查找,却找不到 libmysqlclient 文件

解决方法一

1
ln -s /usr/local/mysql/lib/libmysqlclient.so.18 /usr/lib64/libmysqlclient.so.18(mysql是编译安装的使用此行) ln -s /usr/lib64/mysql/libmysqlclient.so.18 /usr/lib64/libmysqlclient.so.18 (myslq非编译安装的使用此行)

解决方法二: 也可以把mysql库加入/etc/ld.so.conf.d里面

备注:
我两个php用的libmysqlclient版本不一样,我要经常切换
一个用 libmysqlclient.so.18.0.0
另一个 libmysqlclient.so.18.1.0



版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
undefined reference to `swr_init+
undefined reference to `swr_init+
15 0
How to Synchronize RDS Data to a Local User-Defined Database
Here we will discuss how to synchronize RDS data to a local database. We will also explore the critical steps involving the data synchronization from RDS to a local database.
984 0
解决undefined reference to `__poll_chk@GLIBC_2.16' 错误
出现这个错误,是系统的glibc版本太低了,需要更新 到http://ftp.gnu.org/gnu/glibc/下载新版本的glibc,也不用太高,我选择glibc-2.20.tar.gz   解压完毕后 .
989 0
PHP无法编译undefined reference to `libiconv_open
./configure --prefix=/usr/local/php52 make时提示:.....................................................ext/iconv/.
1057 0
libxml2.so: undefined reference to `gzopen64&#39;
从下载 http://pan.baidu.com/s/1sjoDN57 zlib-1.2.3.tar.gz,解压,configure后,vi Makefile ,然后在CFLAGS 后面添加 -fPIC 参数,编译make然后make install
1837 0
+关注
白及88
白及
445
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载