1001.Add More Zero

简介: Problem Description There is a youngster known for amateur propositions concerning several mathematical hard problems.

Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
1
64

Sample Output
Case #1: 0
Case #2: 19

题解如下,水题没啥说的

//202MS 1508K
#include <cstdio>  
#include <cstring>  
#include <algorithm> 
#include <cmath>
using namespace std;
int main()
{
    int cas=1;
    int n;
    while(scanf("%d",&n)!=EOF){
        printf("Case #%d: ",cas);   cas++;
        int w=n*log(2)/log(10);
        printf("%d\n",w);
    }
    return 0;
} 
目录
相关文章
|
5月前
|
Java C++
List.of() Vs Arrays.asList()
在上面的示例中,List.of() 用于创建不可变的颜色列表。任何通过添加或删除元素来修改列表的尝试都将导致抛出异常。 Arrays.asList() 当我们想要由指定数组支持的固定大小(可序列化)集合时,请使用此方法。对返回集合的任何更改也将写入原始数组。 java
28 0
|
安全 Java API
Arrays.asList 解析
快速学习方法的定义 | 学习笔记
78 0
Atomics.add()
Atomics.add()
69 0
Cause: buildOutput.apkData must not be null
Cause: buildOutput.apkData must not be null
Cause: buildOutput.apkData must not be null
|
监控 数据中心