HDOJ-1002 A + B Problem II

简介: Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Problem ...

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

不知道坑了多少人的题目~首先位数1000位long long也存不下,当然java很好做,然而目前没接触过,所以只能用数组存数来计算,然后一个地方要注意:它说每组测试数据 有空行隔开,也就是说最后一组数据后是没有空行的。这个没找出来,一直Presentation Error,看了Discuss后才知道自己错哪了。细节啊!!

//15MS  1676K
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int main(){
    int T,N=1;
    scanf("%d",&T);
    while(T--){
        char a[1005],b[1005];
        int ans[1005];
        scanf("%s %s",a,b);
        int len1,len2,len;
        len1=strlen(a);
        len2=strlen(b);
        len=max(len1,len2);
        for(int i=len-1,j=len2-1,k=len1-1;;i--,j--,k--){
            if(k>=0&&j>=0)
                ans[i]=a[k]-48+b[j]-48;
            else if(k>=0&&j<0)
                ans[i]=a[k]-48;
            else if(k<0&&j>=0)
                ans[i]=b[j]-48;
            else
                break;
        }
        for(int j=len-1;j>0;j--){
            if(ans[j]>9){
                ans[j-1]++;
                ans[j]-=10;
            }
        }
        printf("Case %d:\n%s + %s = ",N++,a,b);
        for(int k=0;k<len;k++)
            printf("%d",ans[k]);
        if(T==0)
            printf("\n");
        else
            printf("\n\n"); //囧~
    }
    return 0;
}

AC后觉得很Interesting~

目录
相关文章
HDOJ 1002 A + B Problem II
HDOJ 1002 A + B Problem II
112 0
HDOJ 2101 A + B Problem Too
HDOJ 2101 A + B Problem Too
98 0
|
Java
HDOJ 1000 A + B Problem
HDOJ 1000 A + B Problem
105 0
HDOJ 1405 The Last Practice
HDOJ 1405 The Last Practice
89 0
HDOJ 2055 An easy problem
HDOJ 2055 An easy problem
103 0
HDOJ 1017 A Mathematical Curiosity
HDOJ 1017 A Mathematical Curiosity
104 0
HDOJ 2058 The sum problem
HDOJ 2058 The sum problem
105 0
|
Java 文件存储
HDOJ(HDU) 2132 An easy problem
HDOJ(HDU) 2132 An easy problem
97 0
|
Java 文件存储
HDOJ(HDU) 2123 An easy problem(简单题...)
HDOJ(HDU) 2123 An easy problem(简单题...)
143 0
HDOJ 1001Sum Problem
HDOJ 1001Sum Problem
104 0