HDOJ-1002 A + B Problem II

简介: Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Problem ...

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

不知道坑了多少人的题目~首先位数1000位long long也存不下,当然java很好做,然而目前没接触过,所以只能用数组存数来计算,然后一个地方要注意:它说每组测试数据 有空行隔开,也就是说最后一组数据后是没有空行的。这个没找出来,一直Presentation Error,看了Discuss后才知道自己错哪了。细节啊!!

//15MS  1676K
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int main(){
    int T,N=1;
    scanf("%d",&T);
    while(T--){
        char a[1005],b[1005];
        int ans[1005];
        scanf("%s %s",a,b);
        int len1,len2,len;
        len1=strlen(a);
        len2=strlen(b);
        len=max(len1,len2);
        for(int i=len-1,j=len2-1,k=len1-1;;i--,j--,k--){
            if(k>=0&&j>=0)
                ans[i]=a[k]-48+b[j]-48;
            else if(k>=0&&j<0)
                ans[i]=a[k]-48;
            else if(k<0&&j>=0)
                ans[i]=b[j]-48;
            else
                break;
        }
        for(int j=len-1;j>0;j--){
            if(ans[j]>9){
                ans[j-1]++;
                ans[j]-=10;
            }
        }
        printf("Case %d:\n%s + %s = ",N++,a,b);
        for(int k=0;k<len;k++)
            printf("%d",ans[k]);
        if(T==0)
            printf("\n");
        else
            printf("\n\n"); //囧~
    }
    return 0;
}

AC后觉得很Interesting~

目录
相关文章
HDOJ 2033 人见人爱A+B
HDOJ 2033 人见人爱A+B
161 0
HDOJ 2013 蟠桃记
HDOJ 2013 蟠桃记
99 0
HDOJ 2050 折线分割平面
Problem Description 我们看到过很多直线分割平面的题目,今天的这个题目稍微有些变化,我们要求的是n条折线分割平面的最大数目。比如,一条折线可以将平面分成两部分,两条折线最多可以将平面分成7部分,具体如下所示。
997 0
|
人工智能 BI
HDOJ 2040 亲和数
Problem Description 古希腊数学家毕达哥拉斯在自然数研究中发现,220的所有真约数(即不是自身的约数)之和为: 1+2+4+5+10+11+20+22+44+55+110=284。
871 0
|
人工智能
HDOJ 2019 数列有序!
Problem Description 有n(n
825 0
|
Java 机器学习/深度学习
HDOJ 2151
Worm Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1727 Accepted Submission(s): 1082 Problem Description 自从见识了平安夜苹果的涨价后,Lele就在他家门口水平种了一排苹果树,共有N棵。
664 0
|
Java
HDOJ 1201
18岁生日 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10076 Accepted Submission(s): 3201 Problem Description Gardon的18岁生日就要到了,他当然很开心,可是他突然想到一个问题,是不是每个人从出生开始,到达18岁生日时所经过的天数都是一样的呢?似乎并不全都是这样,所以他想请你帮忙计算一下他和他的几个朋友从出生到达18岁生日所经过的总天数,让他好来比较一下。
841 0
|
机器学习/深度学习
HDOJ 1028(整数划分)
/* 大概思路是开2个数组,c1[ ]保存当前得到的多项式各项系数,c2[ ]保存每次计算时的临时结果, 当每次计算完毕后,把它赋给c1,然后c2清零。 计算的时候,开3层for循环。最外层,记录它正在与第几个多项式相乘。
778 0

热门文章

最新文章