园区网PAP实现【神州数码设备】-阿里云开发者社区

开发者社区> 安全> 正文
登录阅读全文

园区网PAP实现【神州数码设备】

简介:

 

拓扑图

IP地址分配表

PC1

192.168.20.2/24

PC2

192.168.30.2/24

PC3

192.168.40.2/24

PC4

192.168.50.2/24

SwitchA  VLAN2

192.168.20.1/24

SwitchA  VLAN3

192.168.30.1/24

SwitchB  VLAN4

192.168.40.1/24

SwitchB  VLAN5

192.168.50.1/24

SwitchA  VLAN1

192.168.1.2/24

SwitchB  VLAN1

192.168.7.2/24

RouterA  F0/0

192.168.1.1/24

RouterB  F0/0

192.168.7.1/24

RouterA  Serial0/1

1.1.1.1/24

RouterB  Serial0/1

1.1.1.2/24

网络组建


第一题

制作六条直通线,请按拓扑图正确将各设备互连,其中两个路由器使用V35线缆连接。交换机、路由器按要求化分VLAN、设置路由、telnet管理(用户名digital,密码china路由器需要设置enable密码(digitalchina),交换机不需要设置enable密码)。
第二题
在交换机SwitchA上划分VLAN2和VLAN3。vlan2的ip地址为192.168.20.1/24,vlan3的ip地址为192.168.30.1/24。将1-5端口划分到VLAN2里,将6-10端口划分到VLAN3里。PC1属于 VLAN2, IP地址为192.168.20.2/24,接入SwitchA的2端口。PC2 属于VLAN3 ,IP地址为192.168.30.2/24. 接入SwitchA的6端口。 
将SwitchA的剩余端口划分到VLAN1里,VLAN1的IP地址为192.168.1.2/24.将SwitchA的24口和RouterA的F0/0相连。
第三题
在交换机SwitchB上划分VLAN4和VLAN5。Vlan4的ip地址为192.168.40.1/24,vlan5的ip地址为192.168.50.1/24。将1-5端口划分到VLAN4里,将6-10端口划分到VLAN5里。PC3属于 VLAN4, IP地址为192.168.40.2/24,接入SwitchB的2端口.PC2 属于VLAN5 ,IP地址为192.168.50.2/24,接入SwitchB的6端口。
将SwitchB的剩余端口划分到VLAN1里,VLAN1的IP地址为192.168.7.2/24.将SwitchB的24口和RouterB的F0/0相连。
第四题
设置路由RouterA的F0/0口IP地址为192.168.1.1/24,串口IP地址为1.1.1.1/24.
设置路由RouterB的F0/0口IP地址为192.168.7.1/24,串口IP地址为1.1.1.2/24.
在RouterA、RouterB串口上启用PPP协议,设置PAP验证。DCE端的路由器验证方法列表名为:bisai;DCE端的路由器用户名为:RDCE,密码为:digital;DTE端的路由器用户名为:RDTE,密码为:digital。DCE时钟设置为64000。
第五题
设置静态路由。使任意两台PC能通过网络互相访问。

=====SwitchA的配置====

DCRS-5650-28(config)#hostname SwitchA

SwitchA(config)#telnet-server enable

SwitchA(config)#telnet-user digital password 0 china

SwitchA(config)#interface vlan 1

SwitchA(config- Vlan1)#ip address 192.168.1.2 255.255.255.0

SwitchA(config- Vlan1)#exit

SwitchA(config)#vlan 2

SwitchA(config- Vlan2)#switchport interface ethernet 0/0/1-5

SwitchA(config- Vlan2)#interface vlan 2

SwitchA(config- if-Vlan2)#ip address 192.168.20.1 255.255.255.0

SwitchA(config- if-Vlan2)#exit

SwitchA(config)#vlan 3

SwitchA(config-Vlan3)#switchport interface ethernet 0/0/6-10

SwitchA(config-Vlan3)#interface vlan 3

SwitchA(config- if-Vlan3)#ip address 192.168.30.1 255.255.255.0

SwitchA(config- if-Vlan3)#exit

SwitchA(config)#interface ethernet 0/0/24

SwitchA(config- If-Ethernet0/0/24)#swtichport mode trunk

=====SwitchB的配置======

DCRS-5650-28#config

DCRS-5650-28(config)#hostname SwitchB

SwitchB(config)#telnet-server enable

SwitchB(config)#telnet-user digital password 0 china

SwitchB(config)#vlan 4

SwitchB(config-Vlan4)#name vlan4                                            

SwitchB(config-Vlan4)#switchport interface ethernet 0/0/1-5

SwitchB(config-Vlan4)#exit

SwitchB(config)#vlan 5

SwitchB(config-Vlan5)#name vlan5

SwitchB(config-Vlan5)#switchport interface ethernet 0/0/6-10

SwitchB(config-Vlan5)#interface vlan 1

SwitchB(config-if-Vlan1)#ip address 192.168.7.2 255.255.255.0

SwitchB(config-if-Vlan1)#interface vlan 4

SwitchB(config-if-Vlan4)#ip address 192.168.40.1 255.255.255.0

SwitchB(config-if-Vlan4)#interface vlan 5

SwitchB(config-if-Vlan5)#ip address 192.168.50.1 255.255.255.0

SwitchB(config-if-Vlan5)#interface ethernet 0/0/24

SwitchB(config-if-Ethernet0/0/24)#switchport mode trunk

=====RouterA的配置=====

Router_config#hostname RouterA

RouterA_config#aaa authentication enable default enable

RouterA_config#enable password digitalchina

RouterA_config#aaa authentication ppp bisai local

RouterA_config#username RDCE password digital

RouterA_config#ip route 0.0.0.0 0.0.0.0 serial 0/1

RouterA_config#interface fastethernet 0/0

RouterA_config_f0/0#ip address 192.168.1.1 255.255.255.0

RouterA_config_f0/0#interface fastethernet 0/0.1

RouterA_config_f0/0.1#encapsulation dot1q 2

RouterA_config_f0/0.1#ip address 192.168.20.254 255.255.255.0

RouterA_config_f0/0.1#interface fastethernet 0/0.2

RouterA_config_f0/0.2#encapsulation dot1q 3

RouterA_config_f0/0.2#ip address 192.168.30.254 255.255.255.0

RouterA_config_f0/0.2#interface serial 0/1

RouterA_config_s0/1#ip address 1.1.1.1 255.255.255.0

RouterA_config_s0/1#encapsulation ppp

RouterA_config_s0/1#ppp authentication pap bisai

RouterA_config_s0/1#ppp pap sent-username RDTE password digital

====RouterB的配置=====

Router_config#hostname RouterB

RouterB_config#aaa authentication enable default enable

RouterB_config#enable password digitalchina

RouterB_config#aaa authentication  ppp default local

RouterB_config#username RDTE password digital

RouterB_config#ip route 0.0.0.0 0.0.0.0 serial 0/1

RouterB_config#interface fastethernet 0/0

RouterB_config_f0/0#ip address 192.168.1.2 255.255.255.0

RouterB_config_f0/0#interface fastethernet 0/0.1

RouterB_config_f0/0.1#encapsulation dot1q 4

RouterB_config_f0/0.1#ip address 192.168.40.254 255.255.255.0

RouterB_config_f0/0.1#interface fastethernet 0/0.2

RouterB_config_f0/0.2#encapsulation dot1q 5

RouterB_config_f0/0.2#ip address 192.168.50.254 255.255.255.0

RouterB_config_f0/0.2#interface serial 0/1

RouterA_config_s0/1#physical-layer speed 64000

RouterA_config_s0/1#encapsulation ppp

RouterA_config_s0/1#ip address 1.1.1.2 255.255.255.0

RouterA_config_s0/1#ppp authentication pap

RouterA_config_s0/1#ppp pap sent-username RDCE password digital

 

本文转自tiancong 51CTO博客,原文链接:http://blog.51cto.com/tiancong/656633



版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: