三层交换实现不同VLAN间的通信[神州数码设备]-阿里云开发者社区

开发者社区> 云计算> 正文
登录阅读全文

三层交换实现不同VLAN间的通信[神州数码设备]

简介:

实验线路连接图:

 

实验内容:

三层交换机具有路由功能,在一般三层交换都是需要手动开启其路由功能。只是神州的5526S交换机不用开启,可以直接使用。具体思路就是,在SwitchA上设置VLAN10,且VLAN10IP地址为PC1的网关,另一半同理。

1)测试机配置

测试机PC1连接交换机A 1口,ip 192.168.10.1 网关:192.168.10.10

测试机PC2连接交换机B 10口,ip 192.168.20.1网关:192.168.20.10

2DCRS-5526S配置

SwitchA-Config[完整配置]

switch>enable

switch#config

switch(Config)#hostname SwitchA

SwitchA(Config)#interface ethernet 0/0/23

SwitchA(Config-Ethernet0/0/23)#switchport mode trunk

Set the port Ethernet0/0/23 mode TRUNK successfully

SwitchA(Config-Ethernet0/0/23)#exit

SwitchA(Config)#telnet-server enable

Telnetd already enabled.

SwitchA(Config)#telnet-user shenzhi password 0 123

SwitchA(Config)#ip http server

web server is on

SwitchA(Config)#web-user shenzhi password 0 123

SwitchA(Config)#vlan 10

SwitchA(Config-Vlan10)#switchport interface ethernet 0/0/1-8

Set the port Ethernet0/0/1 access vlan 10 successfully

Set the port Ethernet0/0/2 access vlan 10 successfully

Set the port Ethernet0/0/3 access vlan 10 successfully

Set the port Ethernet0/0/4 access vlan 10 successfully

Set the port Ethernet0/0/5 access vlan 10 successfully

Set the port Ethernet0/0/6 access vlan 10 successfully

Set the port Ethernet0/0/7 access vlan 10 successfully

Set the port Ethernet0/0/8 access vlan 10 successfully

SwitchA(Config-Vlan10)#interface vlan 10

SwitchA(Config-If-Vlan10)#ip address 192.168.10.10 255.255.255.0

SwitchA(Config-If-Vlan10)#vlan 20

SwitchA(Config-Vlan20)#interface vlan 20

SwitchB(Config-If-Vlan20)#ip address 192.168.20.10 255.255.255.0

 

SwitchB-Config[完整配置]

PC1<--->SwitchA(e0/0/1)

PC2<--->SwitchB(e0/0/10)

注意:PC2的网关并不是SwitchBVLAN20IP地址,而是SwitchA上的VLAN20IP地址,并且在SwitchB上的VLAN20并未设置IP地址,因为意义不大。

switch>enable

switch#config

switch(Config)#hostname SwitchB

SwitchB(Config)#telnet-server enable

Telnetd already enabled.

SwitchB(Config)#telnet-user shenzhi password 0 123

SwitchB(Config)#ip http server

web server is on

SwitchB(Config)#web-user shenzhi password 0 123

SwitchB(Config)#interface ethernet 0/0/23

SwitchB(Config-Ethernet0/0/23)#switchport mode trunk

Set the port Ethernet0/0/23 mode TRUNK successfully

SwitchB(Config-Ethernet0/0/23)#vlan 20

SwitchB(Config)#interface ethernet 0/0/23

SwitchB(Config-Ethernet0/0/23)#switchport mode trunk

Set the port Ethernet0/0/23 mode TRUNK successfully

SwitchB(Config-Ethernet0/0/23)#vlan 20

SwitchB(Config-Vlan20)#switchport interface ethernet 0/0/10-15

Set the port Ethernet0/0/10 access vlan 20 successfully

Set the port Ethernet0/0/11 access vlan 20 successfully

Set the port Ethernet0/0/12 access vlan 20 successfully

Set the port Ethernet0/0/13 access vlan 20 successfully

Set the port Ethernet0/0/14 access vlan 20 successfully

Set the port Ethernet0/0/15 access vlan 20 successfully

3)测试机A可以ping通测试机B

实验要求:

   掌握Vlan的定义,同一Vlan中的主机只要IP为同一网段便可以相互通信。



本文转自tiancong 51CTO博客,原文链接:http://blog.51cto.com/tiancong/656920

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: