Unix Study--AIX5.3.8 安装hacmp52 报错
系统环境:
操作系统:AIX5.3
HACMP: Hacmp5.2
故障现象:
通过 smit installp 安装hacmp时,出现以下故障:
Failed running topsvcsctrl to remove subsystems.
Failed running grpsvcsctrl to remove subsystems.
cleanup: Failed while executing the ./cluster.es.server.utils.unpost_i script.
installp: APPLYING software for:
cluster.es.server.utils 5.2.0.0
Failed running emsvcsctrl to add subsystems.
instal: Failed while executing the ./cluster.es.server.utils.post_i script.
0503-464 installp: The installation has FAILED for the "root" part
of the following filesets:
cluster.es.server.utils 5.2.0.0
installp: Cleaning up software for:
cluster.es.server.utils 5.2.0.0
查看安装脚本:
[root@aix195 inst_root]#cat cluster.es.server.utils.post_i
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
|
#!/bin/ksh
# IBM_PROLOG_BEGIN_TAG
# This is an automatically generated prolog.
#
#
#
# Licensed Materials - Property of IBM
#
# (C) COPYRIGHT International Business Machines Corp.
1997
,
2003
# All Rights Reserved
#
# US Government Users Restricted Rights - Use, duplication
or
# disclosure restricted by GSA ADP Schedule Contract
with
IBM Corp.
#
# IBM_PROLOG_END_TAG
#
# @(#)
30
1.8
src/packages/cluster/es/server/utils/root/cluster.es.server.utils.post_i.sh, pkghacmp, 51pkgha_r520, r5200422a
4
/
4
/
02
20
:
35
:
25
#
# COMPONENT_NAME: pkghacmp
#
# FUNCTIONS: if_failed
# onintr
#
# ORIGINS:
27
#
LPPDIR=
"/usr/lpp/cluster.es"
CLUSTDIR=
"/usr/es/sbin/cluster"
PATH=$PATH:/bin:/usr/bin:/usr/sbin
DATTMP=/
var
/tmp/dattmp$$
if_failed()
{
status=$
1
errmsg=$
2
if
[ $status -ne
0
];
then
echo Failed $errmsg
exit
99
fi
}
onintr()
{
exit
5
}
###############################################################################
################################### MAIN ######################################
###############################################################################
trap onintr
1
2
3
################### create subsystems ###############
chservices -a -v topsvcs -n
6178
-p udp > /dev/
null
2
>&
1
if_failed $?
"to add service topsvcs to port 6178"
chservices -c -v
"topsvcs"
-n
6178
-p udp > /dev/
null
2
>&
1
if_failed $?
"to change service topsvcs to port 6178"
chservices -a -v grpsvcs -n
6179
-p udp > /dev/
null
2
>&
1
if_failed $?
"to add service grpsvcs to port 6179"
chservices -c -v
"grpsvcs"
-n
6179
-p udp > /dev/
null
2
>&
1
if_failed $?
"to change service grpsvcs to port 6179"
chservices -a -v emsvcs -n
6180
-p udp > /dev/
null
2
>&
1
if_failed $?
"to add service emsvcs to port 6180"
/usr/sbin/rsct/bin/topsvcsctrl -a > /dev/
null
2
>&
1
if_failed $?
"running topsvcsctrl to add subsystems."
/usr/sbin/rsct/bin/grpsvcsctrl -a > /dev/
null
2
>&
1
if_failed $?
"running grpsvcsctrl to add subsystems."
/usr/sbin/rsct/bin/emsvcsctrl -a > /dev/
null
2
>&
1
if_failed $?
"running emsvcsctrl to add subsystems."
##################### End create subsystems ##########################
exit
0
|
手工执行脚本:
通过检查emsvcsctrl命令存在,脚本也存在手动执行
[root@aix211 ppc]#find / -name 'cluster.es.server.utils.post_i'
# /usr/sbin/rsct/bin/emsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
报错-bash-3.00# /usr/sbin/rsct/bin/emsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i0513-071
The emsvcs Subsystem has been added.0513-071 The emaixos Subsystem has been added.
No such file or directory/usr/sbin/rsct/bin/emsvcsctrl[203]: /var/ha/log/em.mkdir:
cannot createemsvcsctrl: 2521-554 Cannot create the Event Management directory "/var/ha/lck/haem".显示不能创建/var/ha/log和/var/ha/lck/haem目录
手动执行:
/usr/sbin/rsct/bin/emsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
报错:
-bash-3.00# /usr/sbin/rsct/bin/emsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
0513-071 The emsvcs Subsystem has been added.
0513-071 The emaixos Subsystem has been added.
No such file or directory
/usr/sbin/rsct/bin/emsvcsctrl[203]: /var/ha/log/em.mkdir: cannot create
emsvcsctrl: 2521-554 Cannot create the Event Management directory "/var/ha/lck/haem".
显示不能创建/var/ha/log和/var/ha/lck/haem目录
解决方法:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
|
手工创建目录:
-bash
-3.00
# mkdir -p /
var
/ha/soc/haem
-bash
-3.00
# /usr/sbin/rsct/bin/emsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
0513
-071
The emsvcs Subsystem has been added.
0513
-071
The emaixos Subsystem has been added.
[root@aix211 ppc]#/usr/sbin/rsct/bin/topsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
topsvcsctrl:
2523
-636
The topsvcs subsystem must be stopped
before
removing
or
remaking it.
[root@aix211 ppc]#lssrc -a |grep top
topsvcs topsvcs
331850
active
[root@aix211 ppc]#stopsrc -s topsvcs
0513
-044
The topsvcs Subsystem was requested to stop.
[root@aix211 ppc]#lssrc -a |grep top
topsvcs topsvcs inoperative
[root@aix211 ppc]#/usr/sbin/rsct/bin/topsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
0513
-071
The topsvcs Subsystem has been added.
0513
-068
The topsvcs Notify method has been added.
[root@aix211 ppc]#lssrc -a |grep top
topsvcs topsvcs inoperative
重新安装hacmp缺少的文件集(cluster.es.server.utils),OK。
|
错误2:
解决方法:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
|
[root@aix227:/usr/lpp/cluster.es/inst_root]#/usr/sbin/rsct/bin/grpsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.unpost_i
grpsvcsctrl:
2520
-208
The grpsvcs subsystem must be stopped.
[root@aix227:/usr/lpp/cluster.es/inst_root]#lssrc -a |grep grp
grpsvcs grpsvcs
360696
active
grpglsm grpsvcs inoperative
[root@aix227:/usr/lpp/cluster.es/inst_root]#stopsrc -s grpsvcs
0513
-056
Timeout waiting
for
command response. If you specified a foreign host,
see the /etc/inittab file
on
the foreign host to verify that the SRC daemon
(srcmstr) was started
with
the -r flag to accept remote requests.
[root@aix227:/usr/lpp/cluster.es/inst_root]#lssrc -a |grep grp
grpsvcs grpsvcs
360696
stopping
grpglsm grpsvcs inoperative
[root@aix227:/usr/lpp/cluster.es/inst_root]#kill
-9
360696
[root@aix227:/usr/lpp/cluster.es/inst_root]#lssrc -a |grep grp
grpsvcs grpsvcs inoperative
grpglsm grpsvcs inoperative
手工执行脚本:
[root@aix227:/usr/lpp/cluster.es/inst_root]#/usr/sbin/rsct/bin/grpsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.unpost_i
0513
-071
The grpsvcs Subsystem has been added.
0513
-071
The grpglsm Subsystem has been added.
[root@aix227:/usr/lpp/cluster.es/inst_root]#/usr/sbin/rsct/bin/grpsvcsctrl -a /usr/lpp/cluster.es/inst_root/cluster.es.server.utils.post_i
0513
-071
The grpsvcs Subsystem has been added.
0513
-071
The grpglsm Subsystem has been added.
用smit installp重新安装:Cluster.es.server.utils软件包即可!
|
原因:
有可能是在设置PATH 环境变量时,导致root用户无法找到emsvcsctrl 、grpsvcsctl等命令,来执行脚本!