线段树 + 区间更新: HDU 4893 Wow! Such Sequence!

简介: Wow! Such Sequence! Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2234    Accepted Submiss...

Wow! Such Sequence!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2234    Accepted Submission(s): 657


Problem Description
Recently, Doge got a funny birthday present from his new friend, Protein Tiger from St. Beeze College. No, not cactuses. It's a mysterious blackbox.

After some research, Doge found that the box is maintaining a sequence an of n numbers internally, initially all numbers are zero, and there are THREE "operations":

1.Add d to the k-th number of the sequence.
2.Query the sum of ai where l ≤ i ≤ r.
3.Change ai to the nearest Fibonacci number, where l ≤ i ≤ r.
4.Play sound "Chee-rio!", a bit useless.

Let F 0 = 1,F 1 = 1,Fibonacci number Fn is defined as F n = F n - 1 + F n - 2 for n ≥ 2.

Nearest Fibonacci number of number x means the smallest Fn where |F n - x| is also smallest.

Doge doesn't believe the machine could respond each request in less than 10ms. Help Doge figure out the reason.
 

 

Input
Input contains several test cases, please process till EOF.
For each test case, there will be one line containing two integers n, m.
Next m lines, each line indicates a query:

1 k d - "add"
2 l r - "query sum"
3 l r - "change to nearest Fibonacci"

1 ≤ n ≤ 100000, 1 ≤ m ≤ 100000, |d| < 2 31, all queries will be valid.
 

 

Output
For each Type 2 ("query sum") operation, output one line containing an integer represent the answer of this query.
 

 

Sample Input
1 1 2 1 1 5 4 1 1 7 1 3 17 3 2 4 2 1 5
 

 

Sample Output
0 22
 

 

Author
Fudan University
 

 

Source

 

【题目分析】

这题相比于裸的线段树区间更新有了一些难度。
我们在每个结点中设一个fib,表示离sum最近的fibnacci数,每次区间更新时,就将sum的值更新为fib。fib的值只有在单点更新的过程中才会改变,也就是说当sum值改变的时候fib才改变,因为当sum变为fib后,离sum最近的fibnacci数还是fib值。

lazy----记录该点以下的孩子结点是否需要更新。

 

我用long long ,然后用了%lld输入,不知道杭电不支持%lld,debug了半天,TLE了20多次,后来改%lld为%I64d就过了,哭死QAQ...


 

//Memory   Time
//  K      MS
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<iomanip>
#include<string>
#include<climits>
#include<cmath>
#define MAX 100010
#define LL long long
using namespace std;
LL n,m;
LL ans;
LL f[60];

struct Tree
{
    LL l,r;
    LL sum,fib;
    bool lazy;
};
Tree tree[MAX*3];

LL Find(LL x)
{
    if(x<=0)return 1;
    LL ldis,rdis;
    for(int i=0;i<59;++i)
    {
        if(f[i]<=x&&f[i+1]>=x)
        {
            ldis=x-f[i];
            rdis=f[i+1]-x;
            return ldis<=rdis?f[i]:f[i+1];
        }
    }
}

void pushup(LL x)
{
    LL tmp=x<<1;
    tree[x].sum=tree[tmp].sum+tree[tmp+1].sum;
    tree[x].fib=tree[tmp].fib+tree[tmp+1].fib;
}

void pushdown(LL x)
{
    if(!tree[x].lazy)return;
    tree[x].lazy=0;
    if(tree[x].l==tree[x].r)return;
    LL tmp=x<<1;
    tree[tmp].lazy=tree[tmp+1].lazy=1;
    tree[tmp].sum=tree[tmp].fib;
    tree[tmp+1].sum=tree[tmp+1].fib;
}

void build(LL l,LL r,LL x)
{
    tree[x].l=l,tree[x].r=r;
    tree[x].sum=0,tree[x].fib=1,tree[x].lazy=0;
    if(l==r)return;
    LL tmp=x<<1;
    LL mid=(l+r)>>1;
    build(l,mid,tmp);
    build(mid+1,r,tmp+1);
    pushup(x);
}

void add(LL x,LL k,LL num)
{
    if(tree[x].l==tree[x].r)
    {
        tree[x].sum+=num;
        tree[x].fib=Find(tree[x].sum);
        return;
    }
    if(tree[x].lazy)
        pushdown(x);
    LL tmp=x<<1;
    LL mid=(tree[x].l+tree[x].r)>>1;
    if(k<=mid)
        add(tmp,k,num);
    else if(k>mid)
        add(tmp+1,k,num);
    pushup(x);
}

void change(LL l,LL r,LL x)
{
    if(r<tree[x].l||l>tree[x].r)return;
    if(l<=tree[x].l&&r>=tree[x].r)
    {
        tree[x].sum=tree[x].fib;
        tree[x].lazy=1;
        return;
    }
    if(tree[x].lazy)pushdown(x);
    LL tmp=x<<1;
    LL mid=(tree[x].l+tree[x].r)>>1;
    if(r<=mid)
        change(l,r,tmp);
    else if(l>mid)
        change(l,r,tmp+1);
    else
    {
        change(l,mid,tmp);
        change(mid+1,r,tmp+1);
    }
    pushup(x);
}

void query(LL l,LL r,LL x)
{
    if(r<tree[x].l||l>tree[x].r)return;
    if(l<=tree[x].l&&r>=tree[x].r)
    {
        ans+=tree[x].sum;
        return;
    }
    if(tree[x].lazy)
        pushdown(x);
    LL tmp=x<<1;
    LL mid=(tree[x].l+tree[x].r)>>1;
    if(r<=mid)
        query(l,r,tmp);
    else if(l>mid)
        query(l,r,tmp+1);
    else
    {
        query(l,mid,tmp);
        query(mid+1,r,tmp+1);
    }
    pushup(x);
}

int main()
{
//    freopen("cin.txt","r",stdin);
//    freopen("cout.txt","w",stdout);
    f[0]=f[1]=1;
    for(int i=2;i<60;++i) f[i]=f[i-1]+f[i-2];
    while(scanf("%I64d %I64d",&n,&m)!=EOF)
    {
        build(1,n,1);
        LL a,b,c;
        while(m--)
        {
            scanf("%I64d %I64d %I64d",&a,&b,&c);
            if(a==1)
                add(1,b,c);
            else if(a==2)
            {
                ans=0;
                query(b,c,1);
                printf("%I64d\n",ans);
            }
            else
                change(b,c,1);
        }
    }
    return 0;
}

  

 

目录
相关文章
|
7月前
|
机器学习/深度学习 安全 Java
hdu-1596-find the safest road(dijkstra)
hdu-1596-find the safest road(dijkstra)
41 0
hdu 1196 Lowest Bit(水题)
hdu 1196 Lowest Bit(水题)
43 0
|
开发框架 .NET
poj 3468 A Simple Problem with Integers线段树区间修改
题目意思很简单,有N个数,Q个操作, Q l r 表示查询从l到r 的和,C l r v 表示将从l到r 的值加上v,明显的线段树,不知道线段树的人肯定暴力,肯定超时,哈哈!!
34 0
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3494 Largest Submatrix of All 1’s(单调栈)
POJ 3494 Largest Submatrix of All 1’s(单调栈)
|
人工智能
POJ 2299 Ultra-QuickSort(树状数组+离散化+求逆序数)
POJ 2299 Ultra-QuickSort(树状数组+离散化+求逆序数)
HDU7050.Link with Limit(有向图tarjan找环)
HDU7050.Link with Limit(有向图tarjan找环)
147 0
洛谷P3855-[TJOI2008]Binary Land(BFS)
洛谷P3855-[TJOI2008]Binary Land(BFS)