矩阵乘法 --- hdu 4920 : Matrix multiplication

简介: Matrix multiplication Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 820    Accepted Submi...

Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 820    Accepted Submission(s): 328


Problem Description
Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.
 

 

Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).
 

 

Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
 

 

Sample Input
1 0 1 2 0 1 2 3 4 5 6 7
 

 

Sample Output
0 0 1 2 1
 

 

Author
Xiaoxu Guo (ftiasch)
 

 

Source
 
 

 

Mean:

给你两个矩阵,计算两个矩阵的积。

 

nalyse:

很多人认为这题用暴力过不了,时间复杂度为O(n^3),800^3=512000000,差不多要接近于10^9了,可能是hdu的评测速度给力吧,再加上这题是单点评测,每个评测点的时限都有2000ms,所以说暴力过了也实属正常。

 

Time complexity:O(n^3)

 

Source code:

#include<stdio.h>
int a[800][800],b[800][800],c[800][800],n,i,j,k;
int main(){
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<n;++i)
            for(j=0;j<n;++j)
                scanf("%d",&a[i][j]),a[i][j]%=3;
        for(i=0;i<n;++i)
            for(j=0;j<n;++j)
                scanf("%d",&b[i][j]),b[i][j]%=3;
        for(i=0;i<n;++i)
            for(j=0;j<i;++j)
                k=b[i][j],b[i][j]=b[j][i],b[j][i]=k;
        for(i=0;i<n;++i)
            for(j=0;j<n;++j){
                c[i][j]=0;
                for(k=0;k<n;++k)
                    c[i][j]+=a[i][k]*b[j][k];
                c[i][j]%=3;
            }
        for(i=0;i<n;++i)
            for(j=0;j<n;++j)
                printf(j==n-1?"%d\n":"%d ",c[i][j]);
    }
    return 0;
}

  

 

目录
相关文章
|
机器学习/深度学习
下三角矩阵(Lower Triangular Matrix)
下三角矩阵(Lower Triangular Matrix)是一种特殊形式的矩阵,其非零元素仅位于主对角线以下。在数学和工程领域中,下三角矩阵通常用于线性代数和微积分等问题。以下是一些关于下三角矩阵的特点和应用:
1216 1
|
机器学习/深度学习
上三角矩阵(Upper Triangular Matrix
上三角矩阵(Upper Triangular Matrix)是一种特殊形式的矩阵,其非零元素仅位于主对角线以上。在数学和工程领域中,上三角矩阵通常用于线性代数和微积分等问题。以下是一些关于上三角矩阵的特点和应用:
1339 0
uva442 Matrix Chain Multiplication
uva442 Matrix Chain Multiplication
40 0
UVa11549 - Calculator Conundrum (Floyd判圈法)
UVa11549 - Calculator Conundrum (Floyd判圈法)
55 0
UVA442 矩阵链乘 Matrix Chain Multiplication
UVA442 矩阵链乘 Matrix Chain Multiplication
【欧拉计划第 5 题】最小公倍数 Smallest multiple
【欧拉计划第 5 题】最小公倍数 Smallest multiple
156 0
【欧拉计划第 5 题】最小公倍数 Smallest multiple
|
人工智能
Kuroni and Impossible Calculation——容斥原理-鸽笼原理-抽屉原理
题目描述 已知一个数组a[n],请计算式子:∏_{1≤i<j≤n}|ai−aj| 的值,其中1<=i,j<=n;我们可以认为,这一式子等价于 |a1−a2|⋅|a1−a3|⋅ … ⋅|a1−an|⋅|a2−a3|⋅|a2−a4|⋅ … ⋅|a2−an|⋅ … ⋅|an−1−an|
121 0
Kuroni and Impossible Calculation——容斥原理-鸽笼原理-抽屉原理
Leetcode-Easy 867.Transpose Matrix
Leetcode-Easy 867.Transpose Matrix
90 0
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
98 0