Windows Server 2008 与 .NET Framework 的版本之间有什么关系-阿里云开发者社区

开发者社区> 开发与运维> 正文

Windows Server 2008 与 .NET Framework 的版本之间有什么关系

简介:
Windows Server 2008就要上市了,用虚拟机安装了两个版本的,一个Server Core的,也就是类Unix的命令行管理的版本,另一个是企业板。IIS 7值得期待,但是Server Core上的IIS居然不支持Asp.net,甚至没有.NET Framework 。微软推出Server Core不就是为了在加强服务器的安全性吗,难道微软不要.NET 作为服务器,这点就比不上同为.NET Framework的实现的Mono,最新的Mono1.2.6,完全支持Asp.net 2.0, 不也一样好好跑在Linux的命令行下吗,当然图形界面可以方便管理员的管理工作,IIS 7.0已经完全用XML文件配置,像apache一样完全胜任用命令行管理了,期待微软在Server Core上支持.NET Framework. IIS团队的blog上有一篇文章IIS7 on Server Core中有一段说明:
Server Core installations on Windows Server 2008 comes with certain differences than regular Windows Server 2008 OS installations. In a nutshell, .Net framework is not available (hence no ASP.Net) and there is no windows shell so GUI administration tools are not available. As a note, availability and support of .Net framework on Server Core installation option is being discussed so there is no final answer on that as of this date yet.
微软还在讨论,这个还有什么可讨论的啊,微软给出点魄力出来吧。
Windows Server 2008 图形界面版本(以下称Windows Server 2008 )默认安装的版本及应用程序会用到的版本,才能知道是否要再额外加装 .NET Framework 。
1. Windows Server 2008 默认刚安装完成后:.NET Framework 2.0 with Service Pack 1
2. Windows Server 2008 添加安装 Application Server Role:.NET Framework 3.0 with Service Pack 1
3. .NET Framework 3.5 需要另外下载安装,或者通过Windows update 更新
4. Windows Server 2008 "Core" 版本:没有安装且无法安装 .NET Framework,强烈要求微软加入.NET Framework的支持
另外即将发布的Vista SP1里,.NET Framework 3.0 & 2.0的SP1补丁包会随之而来。





本文转自 张善友 51CTO博客,原文链接:http://blog.51cto.com/shanyou/73877,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章