cisco设备上实现单臂路由-阿里云开发者社区

开发者社区> 云计算> 正文
登录阅读全文

cisco设备上实现单臂路由

简介:
    今天有个同学问我一道题,题目如下:
有1台cisco2621路由, 1台cisco2960交换机,一台服务器和若干个PC机器。要求:在交换上划出3个vlan。vlan1连接路由器,vlan2连接服务器,vlan3连接PC机。三个vlan能互相访问,只有vlan2能访问外网,vlan3不能。服务器上做活动目录。
       拿到题目后,我分析了一下,大致设计出如下的拓扑图:
设计出拓扑图之后,我对题目的意思有一点疑问,那就是要在路由器上实现单臂路由,那么交换机上与路由器的连接的那个口必须是trunk模式的,但是如果设了trunk模式的话,该端口将不会属于任何vlan,所以题目中的“vlan1连接路由器”就不能达成了,不知道是题目的问题,还是我同学传达错了。
       如上图所示,要求pc0,pc1,server1分别属于不同的vlan,并且要能通信,交换机的配置如下:
s1(config-if)#interface fa0/3
s1(config-if)#switchport mode access
s1(config-if)#interface fa0/4
s1(config-if)#switchport mode access
s1(config-if)#interface fa0/5
s1(config-if)#switchport mode access
 
s1(config)#interface fa0/3
s1(config-if)#switchport mode access
s1(config-if)#interface fa0/4
s1(config-if)#switchport mode access
s1(config-if)#interface fa0/5
s1(config-if)#switchport mode access
 
s1(config-if)#switchport mode trunk               //一定要把与路由器连接的端口模式设为trunk
 
设置vlan:
s1#vlan database
s1(vlan)#vlan 3
s1(vlan)#vlan 4
s1(vlan)#vlan 5
 
把端口加入对应的vlan:
s1(config)#interface fa0/3
s1(config-if)#switchport access vlan 3
s1(config-if)#interface fa0/4
s1(config-if)#switchport access vlan4
s1(config-if)#interface fa0/5
s1(config-if)#switchport access vlan 5
 
路由器配置如下:
r1(config)#int fa 0/0                //与交换机连接的端口不用再设IP地址
r1(config-if)#no ip add
r1(config-if)#no shut
 
r1(config-if)#int fa0/0.3
(config-subif)#encapsulation dot1q 3              //采用802.1q封装方式
r1(config-subif)#ip address 192.168.3.1 255.255.255.0
r1(config-if)#int fa0/0.4
(config-subif)#encapsulation dot1q 4
r(config-subif)#ip address 192.168.4.1 255.255.255.0
r1(config-if)#int fa0/0.5
(config-subif)#encapsulation dot1q 5
r1(config-subif)#ip address 192.168.5.1 255.255.255.0
 
这样就实现了vlan通过路由器进行通信,至于只有vlan2能通信,则需要在路由器利用ACL实现,具体的实现由于时间关系,今天就来不及写出来了,有时间再写吧。


本文转自 victoryan 51CTO博客,原文链接:http://blog.51cto.com/victoryan/44099

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: