虚拟路由器冗余协议(VRRP)原理与实验

简介:
一、基础知识:
      虚拟路由冗余协议(VRRP)与热备份路由协议(HSRP)都是一种默认网关冗余方法,它们都是让一组路由器构成一台虚拟路由器。和HSRP不同的是,VRRP是开发的协议,而HSRP是思科专属的。
      使用VRRP创建的虚拟路由器被称为VRRP组,它代表一组路由器。
      在VRRP组中是通过优先级来决定主虚拟路由器的。
      优先级范围:1—255。如果优先级设置为0,那么主路由器和任何路由器将不再是VRRP组中的路由器。(通过将优先级设置为0来让主路由器自动辞职。)
二、VRRP的配置与验证:
      配置主要命令:
1.定义VRRP组
Vrrp  group-number  ip  virtual-ip-address
2.配置指定VRRP路由器的优先级:
Vrrp  group-number  priority  priority-value
3.允许主虚拟路由器失效的情况下切换到备用虚拟路由器:
Vrrp  group-number  preempt
      验证命令:
1.查看VRRP详细配置信息:
Show vrrp all
2.查看VRRP简要配置信息:
Show vrrp brief
3.查看VRRP接口配置信息:
Show vrrp interface FastEthernet*/*
三、实验:
      拓扑图:
clip_image002
      实验目的:
在这个实验配置了两个VRRP组——vrrp 1和vrrp 2。在vrrp 1中,路由器R1为主虚拟路由器,R2为备用虚拟路由器;在vrrp 2中,路由器R1为备用虚拟路由器,路由器R1为主虚拟路由器。在两个路由器都正常工作的时候,PC1和PC2通过R1访问远端,PC3通过R2访问远端。
      具体配置:
      路由器R1的具体配置:
R1(config)#int f0/0
R1(config-if)#ip address 10.0.0.253 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int s1/0
R1(config-if)#ip add 200.0.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int f0/0
R1(config-if)#vrrp 1 ip 10.0.0.253
R1(config-if)#vrrp 1 priority 200
R1(config-if)#vrrp 1 preempt
R1(config-if)#vrrp 2 ip 10.0.0.254
R1(config-if)#vrrp 2 priority 100
R1(config-if)#vrrp 2 preempt
R1(config-if)#exit
R1(config)#router rip
R1(config)#ver 2
R1(config)#no auto-summary
R1(config)#network 10.0.0.0
R1(config)#network 200.0.1.0
      路由器R2的配置:
R2#sh run
Building configuration...
Current configuration : 1019 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!  
ip cef
!
no ftp-server write-enable
!
interface FastEthernet0/0
ip address 10.0.0.254 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 10.0.0.253
vrrp 1 priority 150
vrrp 2 ip 10.0.0.254
vrrp 2 priority 200
!
interface Serial1/0
ip address 200.0.2.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 10.0.0.0
network 200.0.2.0
no auto-summary
!
ip http server
ip classless
!
control-plane
!
line con 0
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
!
End
     路由器R3的配置:
R3#sh run
Building configuration...
Current configuration : 965 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
ip cef
!
no ftp-server write-enable
!
interface Serial0/0
ip address 200.0.1.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
ip address 200.0.2.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
ip address 200.0.0.254 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 200.0.0.0
network 200.0.1.0
network 200.0.2.0
no auto-summary
!
ip http server
ip classless
!
control-plane
!
line con 0
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
!
End
      在交换机上要记得将连接路由器、主机的接口用NO SHUTDOWN开启!
验证配置:
在路由器R1上:
clip_image004
clip_image006
      在路由器R2上:
clip_image008
clip_image010
实验做完了,当然,大家也可以通过关闭接口等方法来验证VRRP是否有效果~




本文转自 tiger506 51CTO博客,原文链接:http://blog.51cto.com/tiger506/114949,如需转载请自行联系原作者

目录
相关文章
|
1月前
|
负载均衡 网络协议 数据安全/隐私保护
ensp中vrrp虚拟路由器冗余协议 原理及配置命令
ensp中vrrp虚拟路由器冗余协议 原理及配置命令
124 1
|
1月前
|
负载均衡 网络协议 安全
【计算机网络】虚拟路由冗余(VRRP)协议原理与配置
【计算机网络】虚拟路由冗余(VRRP)协议原理与配置
33 0
|
1月前
|
算法 网络协议 数据建模
【计算机网络】—— IP协议及动态路由算法(下)
【计算机网络】—— IP协议及动态路由算法(下)
25 0
|
1月前
|
算法 网络协议 数据建模
【计算机网络】—— IP协议及动态路由算法(上)
【计算机网络】—— IP协议及动态路由算法(上)
21 0
|
负载均衡 网络协议 算法
ospf路由器连接物理网络的方式 以及ospf与IGRP对比(补充)
ospf路由器连接物理网络的方式 以及ospf与IGRP对比(补充)
133 0
|
缓存 网络协议 网络架构
路由器的原理及配置
1.数据包经过路由器,mac地址需要重新封装 2.路由器通过路由表转发数据包,交换机通过mac地址表转发数据帧 3.静态路由需要双向逐跳配置 4.默认路由可简化末端路由器路由表配置,简洁高效 5.接通路由后ping为什么会丢包两次:
路由器的原理及配置
|
网络协议 网络架构
路由与交换系列之VRRP协议特性与配置小实践
1. 深刻理解VRRP协议原理。 2. 掌握VRRP协议的配置方法
181 1
路由与交换系列之VRRP协议特性与配置小实践
|
网络协议 安全 算法
虚拟路由冗余协议VRRP原理介绍
虚拟路由冗余协议VRRP原理介绍
210 0
虚拟路由冗余协议VRRP原理介绍
|
负载均衡 监控 网络协议
图解网络:什么是虚拟路由器冗余协议 VRRP?
虚拟路由器冗余协议 (VRRP) 为一组路由器提供一个虚拟 IP 地址,VRRP 可以与不同厂商的路由器一起使用,并且 VRRP 支持消息摘要 5 (MD5) 身份验证。
309 0
图解网络:什么是虚拟路由器冗余协议 VRRP?

热门文章

最新文章