开发者社区> 余二五> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

实验:DHCP中继代理

简介:
+关注继续查看
        今天做的试验比较简单,关键的就是一条接口级命令:ip helper-address address。所以说今天的试验除了学会配置DHCP中继代理,更重要的是理解它的工作流程。不知道大家有没有这样的体会,比如说你在家里装上了ADSL,购买的业务是2M的速率,同时支持2台主机上网,有一天你带回来第三台电脑上网,结果上不了,是不是很苦闷?电信局是怎么知道你主机的MAC的呢?今天的试验做完了大家心中的谜团或许会消散些的吧(ADSL的认证是通过PPPOE或PPPOA进行的,今天的实验主要研究如何从远端服务器上获取可用IP)。
        通过一张流程图来说明客户端从远端服务器上获取IP的过程吧。
clip_image002
        下面看看DHCP的报文封装格式:
clip_image003
       看看DHCP报文的具体内容:
image
       大家在上面有没有看到“客户机硬件地址”的字段?这个字段就把你主机的MAC地址告诉给服务器了,一会儿实验的时候咱们看看。
       原理性的东西就说到这吧,细节的东西大家有兴趣继续研究啊。现在开始实验吧。这里还有个事情要说明一下,在Packet Tracer 5.0的接口上随上可以配置ip helper-address的命令,但似乎没有作用。所以还是用DynamipsGUI和VMware虚拟机来搭建网络平台吧。试验中选用的路由器镜像为2600,路由协议选择静态、动态的随意。
       试验拓扑图:
clip_image006
       在这个实验中我们用R2充当远端DHCP服务器。区别于本地DHCP配置,在R0的F0/0接口上使用ip helper-address address命令来只想DHCP服务器R2。
       在实验之前一定要关掉虚拟机网络管理中将自带的DHCP关掉啊。
       具体配置如下:
1路由器R0上的配置:.
R0#sh run
Building configuration...
Current configuration:
!
!
interface FastEthernet0/0
ip address 172.16.1.254 255.255.255.0
ip helper-address 172.16.3.2
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.2.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
2.路由器R1上的配置:
R1#sh run
Building configuration...
Current configuration:
!
hostname R1
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
3.路由器R2上的配置:
R2#sh run
Building configuration...
Current configuration:
!
hostname R2
!
memory-size iomem 15
ip subnet-zero
!
ip dhcp pool tiger506 //配置DHCP地址池
network 172.16.1.0 255.255.255.0
default-router 172.16.1.254
dns-server 200.1.1.1
!
interface FastEthernet0/0
ip address 172.16.3.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
        路由器上已经配置好了,在主机网卡上我们选择“自动获取IP地址”:
clip_image007
       现在在“运行”中敲击cmd,进入后我们用ipconfig/all命令来查看ip配置信息;
用ipconfig/release来释放当前地址,用ipconfig/renew来获取新地址。
clip_image009
        大家看到主机已经获取了IP地址,留意一下它的MAC地址,下面的命令会让我们在远端的DHCP服务器上看到它。
在R2上运行命令 sh ip dhcp binding
clip_image011
        观察下在主机上运行ipconfig/release和ipconfig/renew时R2上的变化:
主机上运行ipconfig/release时,R2的debug ip dhcp event的反映
clip_image013
主机上运行ipconfig/renew时,R2的debug ip dhcp event的反映
clip_image015
        再给大家推荐几个R2上使用的DEBUG命令:
debug ip dhcp server linkage
debug ip dhcp server packet
       在R0上大家可以观察有哪些UDP包过来:
debug ip udp
       总之,多敲些命令对实验的理解就更清晰些,不能只求连接通了就算了。




本文转自 tiger506 51CTO博客,原文链接:http://blog.51cto.com/tiger506/118950,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
华三DHCP及DHCP 中继实验配置
华三DHCP及DHCP 中继实验配置
371 0
自制STP配置实验
本图使用Gns模拟器 实验需求: 1.要求利用vtp实现vlan同步设置 2.要求vtp server实现备份冗余 3.创建vlan 1~10要求MLSW1 是奇数vlan主根 MLSW2 是偶数vlan主根 且两个互为备份 4.
1101 0
ip代理器收集
引用:http://junkay.blog.163.com/blog/static/133390898201092095215900/?fromdm&fromSearch&isFromSearchEngine=yes ccessDiver V4.173 AccessDiver是一个网站安全检测软件,是目前最好的网站破解工具之一,同时它也是检测网站安全漏洞的工具,能通过不同代理服务器多线程检测登录帐号、密码。
1247 0
+关注
文章
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载