VMware虚拟机配置文件与兼容产品、限制列表

简介:

虚拟机配置文件的默认文件扩展名为vmx(以下简称vmx文件)。其中定义了vmx文件的编码类型、(虚拟机)配置版本、虚拟硬件(兼容性)版本、虚拟机所拥有的硬件类型以及硬件配置信息。

其中vmx文件中经常用到的就是“虚拟硬件(兼容性)版本”,配置文件中称为“virtualHW.version”,其值一般是“8”、“10”等,这些值是VMware Workstation或者ESXi的版本代名词。例如ESXi5.1兼容VMware Workstation 8但不兼容VMware Workstation10,那么如果此文件的virtualHW.version的值是10的话就不能将此虚拟机直接导入到ESXi中,但是如果将此值改为8就能导入了。

可以更改此处以更改硬件兼容性(虚拟机硬件兼容性)就可以调整虚拟机的兼容性,例如典型的例子如下。

1.将他人提供的ova、ovf文件格式的虚拟机导入VMware ESXi或VMwave Workstation

2.将VMware Workstation导出的高版本虚拟机导入到低版本的VMware ESXi

3.将VMware ESXi导出的高版本虚拟机导入到低版本的VMware ESXi

如果遇到以上情况就可以更改此字段修改虚拟机的兼容性。

值得肯定的是从VMware ESxi导出的虚拟机模板或者虚拟机配置文件直接可以在VMware Workstation中使用。

下面举一个VMware Workstation 10的vmx文件的例子和一个VMware ESXi 5.1的vmx文件的例子。

VMware Workstation 10的vmx文件的例子:

.encoding = "GBK"    
config.version = "8"     
virtualHW.version = "10"     
numvcpus = "2"     
cpuid.coresPerSocket = "2"     
vcpu.hotadd = "TRUE"     
scsi0.present = "TRUE"     
scsi0.virtualDev = "lsilogic"     
memsize = "512"     
mem.hotadd = "TRUE"

……

VMware ESXi 5.1的vmx文件的例子:

.encoding = "UTF-8"    
config.version = "8"     
virtualHW.version = "8"     
pciBridge0.present = "TRUE"     
pciBridge4.present = "TRUE"     
pciBridge4.virtualDev = "pcieRootPort"     
pciBridge4.functions = "8"     
pciBridge5.present = "TRUE"     
pciBridge5.virtualDev = "pcieRootPort"     
pciBridge5.functions = "8"

如上面的代码所示,virtualHW.version通常就在第3行。

Workstation 5.x的虚拟机硬件支持以下列表:

分别为“兼容产品”和“限制”。

ACE 2.0    
ACE 2.5-2.7     
ESXi 4.x     
ESXi 5.0     
ESXi 5.1     
Fusion 1.1     
Fusion 2.x     
Fusion 3.x     
Fusion 4.0     
Fusion 5.0     
Fusion 6.0     
Server 1.x     
Server 2.x     
Workstation 10.0     
Workstation 5.x     
Workstation 6.0     
Workstation 6.5     
Workstation 7.x     
Workstation 8.0     
Workstation 9.0

3.5 GB 内存   
2 个处理器    
4 个网络适配器    
950 GB 磁盘大小    
无 SATA 设备    
无 HD 音频    
不支持 USB 2.0    
不支持多监视器显示    
无电池状态    
不支持 CPU 热插拔    
不支持设备热插拔    
不支持内存热插拔    
不支持 LSI Logic SAS SCSI 控制器    
无 VMCI 支持    
无打印机支持

Workstation 6.x的虚拟机硬件支持以下列表:

ACE 2.0   
ACE 2.5-2.7    
ESXi 4.x    
ESXi 5.0    
ESXi 5.1    
Fusion 1.1    
Fusion 2.x    
Fusion 3.x    
Fusion 4.0    
Fusion 5.0    
Fusion 6.0    
Server 2.x    
Workstation 10.0    
Workstation 6.0    
Workstation 6.5    
Workstation 7.x    
Workstation 8.0    
Workstation 9.0

8 GB 内存   
2 个处理器    
10 个网络适配器    
950 GB 磁盘大小    
无 SATA 设备    
无 HD 音频    
不支持 CPU 热插拔    
不支持设备热插拔    
不支持内存热插拔    
不支持 LSI Logic SAS SCSI 控制器    
无打印机支持

Workstation 6.5-7.x的虚拟机硬件支持以下列表:

ACE 2.5-2.7   
ESXi 4.x    
ESXi 5.0    
ESXi 5.1    
Fusion 2.x    
Fusion 3.x    
Fusion 4.0    
Fusion 5.0    
Fusion 6.0    
Server 2.x    
Workstation 10.0    
Workstation 6.5    
Workstation 7.x    
Workstation 8.0    
Workstation 9.0

32 GB 内存   
8 个处理器    
10 个网络适配器    
2 TB 磁盘大小    
无 SATA 设备    
无 HD 音频

Workstation 8.x的虚拟机硬件支持以下列表:

ESXi 5.0   
ESXi 5.1    
Fusion 4.0    
Fusion 5.0    
Fusion 6.0    
Workstation 10.0    
Workstation 8.0    
Workstation 9.0

64 GB 内存   
8 个处理器    
10 个网络适配器    
2 TB 磁盘大小    
无 SATA 设备

Workstation 9.x的虚拟机硬件支持以下列表:

ESXi 5.1   
Fusion 5.0    
Fusion 6.0    
Workstation 10.0    
Workstation 9.0

64 GB 内存   
8 个处理器    
10 个网络适配器    
2 TB 磁盘大小    
无 SATA 设备

Workstation 10.x的虚拟机硬件支持以下列表:

Fusion 6.0   
Workstation 10.0

64 GB 内存   
16 个处理器    
10 个网络适配器    
8 TB 磁盘大小

附:虚拟机硬件版本

虚拟机的硬件版本反映虚拟机支持的虚拟硬件功能。这些功能对应于在其上创建虚拟机的 ESXi 主机上可用的物理硬件。虚拟硬件功能包括 BIOS 和 EFI、可用的虚拟 PCI 插槽、CPU 最大数量、最大内存配置以及其他典型硬件特性。

创建虚拟机时,可以接受默认硬件版本(对应于创建虚拟机的主机版本)或较早版本。在以下情况下可以使用较早的硬件版本:

■ 要标准化虚拟环境中的测试和部署。

■ 如果不需要具备更新版本的功能。

■ 要保持与旧版主机的兼容性。

硬件版本早于版本 8 的虚拟机可以在 ESXi 5.0 主机上运行,但不会具有硬件版本 8 中可用的所有功能。例如,无法在硬件版本早于版本 8 的虚拟机中使用 32 虚拟处理器或 1000 GB 的内存。

通过 vSphere Web Client 或 vSphere Client,可以将虚拟机只升级到最新的硬件版本。如果虚拟机不必与旧版 ESX/ESXi 主机保持兼容,则可以在 ESXi 5.0 主机上升级虚拟机。在这种情况下,虚拟机会升级到版本 8。

■ 要保持与 ESX/ESXi 3.5 主机的虚拟机兼容性,请在 ESX/ESXi 3.5 主机上升级虚拟机,这会使虚拟机升级到版本 4。

■ 要保持与 ESX/ESXi 4.x 主机的虚拟机兼容性,请在 ESX/ESXi 4.x 主机上升级虚拟机,这会使虚拟机升级到版本 7。

在下列情况中,虚拟机的硬件版本可以低于它运行所在的主机版本:

■ 将在 ESX/ESXi 4.x 或更早版本的主机上创建的虚拟机迁移到 ESXi 5.0 主机。

■ 通过使用在 ESX/ESXi 4.x 或更早版本的主机上创建的现有虚拟磁盘,在 ESXi 5.0 主机上创建虚拟机。

■ 将在 ESX/ESXi 4.x 或更早版本的主机上创建的虚拟磁盘添加到在 ESXi 5.0 主机上创建的虚拟机中。

可在主机上创建、编辑和运行不同的虚拟机版本(如果主机支持相应版本的话)。有时,主机上的虚拟机操作是受限制的,或者虚拟机无法访问主机。


表 ESXi 主机和兼容的虚拟机硬件版本


版本 8

版本 7

版本 4

与 vCenter Server 版本的兼容性

ESXi 5.0

创建、编辑、运行

创建、编辑、运行

编辑、运行

vCenter Server 5.0

ESX/ESXi 4.x

不支持

创建、编辑、运行

创建、编辑、运行

vCenter Server 4.x

ESX Server 3.x

不支持

不支持

创建、编辑、运行

VirtualCenter Server 2.x 和更高版本

ESXi 5.0 主机上不支持版本 3 虚拟机。要充分使用这些虚拟机,请升级虚拟硬件。

注意在早期版本的 ESX/ESXi 文档中,虚拟机硬件版本4可能列为VM3。




本文转自 urey_pp 51CTO博客,原文链接:http://blog.51cto.com/dgd2010/1587543,如需转载请自行联系原作者


相关文章
|
5天前
|
虚拟化
vmware克隆虚拟机后没有ip地址的问题
解决vmware克隆虚拟机后没有内网ip的问题
|
2月前
|
SQL 存储 数据挖掘
【虚拟机数据恢复】VMware虚拟机文件被误删除的数据恢复案例
虚拟机数据恢复环境: 某品牌R710服务器+MD3200存储,上层是ESXI虚拟机和虚拟机文件,虚拟机中存放有SQL Server数据库。 虚拟机故障: 机房非正常断电导致虚拟机无法启动。服务器管理员检查后发现虚拟机配置文件丢失,所幸xxx-flat.vmdk磁盘文件和xxx-000001-delta.vmdk快照文件还在。服务器管理员在尝试恢复虚拟机的过程中,将原虚拟机内的xxx-flat.vmdk删除后新建了一个虚拟机,并分配了精简模式的虚拟机磁盘和快照数据盘,但原虚拟机内的数据并没有恢复。
【虚拟机数据恢复】VMware虚拟机文件被误删除的数据恢复案例
|
Linux 虚拟化 数据安全/隐私保护
VMware使用 - 虚拟机克隆
如果已经安装了一台Linux操作系统,没有必要重新安装,只需要克隆就可以了,有两种方式。
17 0
|
2月前
|
Linux 虚拟化 数据安全/隐私保护
【Linux】VMware安装虚拟机- Windows + Linux
【1月更文挑战第20天】【Linux】VMware安装虚拟机- Windows + Linux
|
4天前
|
网络协议 Linux 开发工具
使用Xshell连接VMware上的Linux虚拟机
使用Xshell连接VMware上的Linux虚拟机
21 0
使用Xshell连接VMware上的Linux虚拟机
|
2月前
|
虚拟化
VMware使用 - 虚拟机快照
VMware使用 - 虚拟机快照
23 0
|
2月前
|
虚拟化
VMware使用 - 虚拟机迁移或删除
VMware使用 - 虚拟机迁移或删除
18 0
|
3月前
|
存储 网络协议 虚拟化
如何操作VMware ESXi虚拟机的迁移?
如何操作VMware ESXi虚拟机的迁移?
97 1
|
3月前
|
存储 虚拟化 数据中心
如何操作VMware ESXi虚拟机的克隆?
如何操作VMware ESXi虚拟机的克隆?
56 1
|
5月前
|
网络协议 虚拟化
76Linux - VMware虚拟机三种联网方法( NAT网络地址转换: 默认使用VMnet8 )
76Linux - VMware虚拟机三种联网方法( NAT网络地址转换: 默认使用VMnet8 )
47 0