怎样识别SQL Server 2000是否为SP4版本(附上驱动包下载)-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

怎样识别SQL Server 2000是否为SP4版本(附上驱动包下载)

简介:
   这几天,几个同学都找我解决使用JDBC连接SQL Server 2000发生错误的问题,发现大部分只要安装了SQL Server 2000的SP4补丁就没事了,但是怎样识别当前的SQL Server 2000是否为SP4版本,却有点麻烦,而我只是把识别方法保存在自己的电脑里,现在记录在博客上,方便查找!
  • select   @@version
    打开SQL Server 2000的查询分析器,输入上面的命令,按F5运行,就会看到下面的输出结果(SP4的输出结果)
    Microsoft SQL Server  2000 - 8.00.2039 (Intel X86)   May  3 2005 23:18:38   Copyright (c) 1988-2003 Microsoft Corporation  Personal Edition on Windows NT 5.1 (Build 2600: Service Pack 2) 
            当显示结果的上面红色部分的和这里的不相同,说明当前SQL Server 2000不是SP4版本,可以到官方网站[url]http://www.microsoft.com/downloads/details.aspx?FamilyId=8E2DFC8D-C20E-4446-99A9-B7F0213F8BC5&displaylang=zh-cn[/url]下载
 
 
           下载后,双击那个EXE后,首先看到是让你选择解压里面文件的位置(一般都修改到其他盘),记住这是解压文件而已,不是安装!
           执行后,到达刚才选择解压的目录,看到setup.bat这个文件,打开这个文件就开始安装SP4补丁,需要一段时间!
           记得安装后,SQL 服务器是停止了,需要重新启动!
             另外附上SQL Server 2000的驱动Jar包SP3和相应的支持文档下载,这里的SP3是JDBC驱动包的版本,和SQL Server 2000的SP4不同,不要混淆!

本文转自 Icansoft 51CTO博客,原文链接: 
http://blog.51cto.com/android/56569

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: