开发者社区> 技术小阿哥> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

jetty问题记录

简介:
+关注继续查看

1、eclipse中使用jetty容器,使用jetty版本6.1.26运行良好;在命令行启动:mvn jetty:run,却报出异常:不能注入


  1. 2011-12-27 14:44:55,602 [ERROR] org.springframework.web.servlet.DispatcherServlet:290 - Context initialization failed 
  2. org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'hummockAppController': Autowiring of fields failed; 
  3. nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: public com.alibaba.hummock.console.se 
  4. rvice.HummockAppService com.alibaba.hummock.console.controller.HummockAppController.hummockAppService; nested exception is org.springframewo 
  5. rk.beans.factory.BeanCreationException: Error creating bean with name 'hummockAppServiceImpl': Autowiring of fields failed; nested exception 
  6.  is ......

仔细检查了代码,@Autowired使用都正确。为什么???

仔细思考后,发现pom里面使用的jetty插件为:6.1.22版本,难道是这个原因?

解决方案:将pom中jetty的版本改为6.1.26后,在命令行正确启动了。

 

 

 本文转自 zhouhaipeng 51CTO博客,原文链接:http://blog.51cto.com/tianya23/752152,如需转载请自行联系原作者


版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
jetty 基础
1.依赖 <dependency> <groupId>org.eclipse.jetty</groupId> <artifactId>jetty-webapp</artifactId> <version>${jetty.vers
1005 0
剖析Jetty的运行原理
之前写过一篇简单使用Jetty的文章,Jetty对于做JAVA Web方面开发的人来说并不陌生,他是一个servlet容器,不过相对Tomcat来说设计的比较简单,而且使用起来也比较简单灵活,我是在学习和使用openfire时接触的Jetty,openfire使用Jetty开发其强大的管理后台。
805 0
jetty 9使用
jetty 9 使用 下载jdk 7   http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.
1392 0
文章
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载