zeromq学习笔记1——centos下安装 zeromq-4.1.2-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

zeromq学习笔记1——centos下安装 zeromq-4.1.2

简介:

1、前言

  MQ(message queue)是消息队列的简称,可在多个线程、内核和主机盒之间弹性伸缩。ZMQ的明确目标是“成为标准网络协议栈的一部分,之后进入Linux内核”。现在还未看到它们的成功。但是,它无疑是极具前景的、并且是人们更加需要的“传统”BSD套接字之上的一 层封装。ZMQ让编写高性能网络应用程序极为简单和有趣。

2、安装过程

(1)下载最新的ZeroMQ:http://download.zeromq.org/

(2)解压:tar -xvf zeromq-4.1.2.tar.gz  

(3)编译

./configure 提示

checking for sodium... no
configure: error: Package requirements (libsodium) were not met

错误提示如下图:

特意百度了一下libsodium这个库,ibsodium 是一个流行、易于使用的软件库。主要用于加密、解密、签名和生成密码哈希等等。这是一个可移植的、跨编译器支持、可安装的,基于 NaCl 开发,提供一个兼容 API。它的目标是为所有构建更高级别的加密工具提供所需要的核心操作。

我下载了一个安装上,configure还是提示这个错误,不知道是什么原因,为了体验一下zeromq的功能,暂时先屏蔽掉这个库

./configure --prefix=/home/libdev/zmq --without-libsodium  

make

make install

安装成功。


版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章
最新文章
相关文章