[usaco]超级素数 superprime

简介: <p>偶也,纪念一次成功,首先发测试结果</p><p>USER: Ma yunlei [yunleis2]<br>TASK: sprime<br>LANG: C++</p><p>Compiling...<br>Compile: OK</p><p>Executing...<br>   Test 1: TEST OK [0.000 secs, 3028 KB]<br>   Test 2: T

偶也,纪念一次成功,首先发测试结果

USER: Ma yunlei [yunleis2]
TASK: sprime
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 3028 KB]
   Test 2: TEST OK [0.000 secs, 3028 KB]
   Test 3: TEST OK [0.000 secs, 3028 KB]
   Test 4: TEST OK [0.000 secs, 3028 KB]
   Test 5: TEST OK [0.000 secs, 3028 KB]

All tests OK.
YOUR PROGRAM ('sprime') WORKED FIRST TIME!  That's fantastic
-- and a rare thing.  Please accept these special automated
congratulations.

Here are the test data inputs:

------- test 1 ----
4
------- test 2 ----
5
------- test 3 ----
6
------- test 4 ----
7
------- test 5 ----
8

Keep up the good work!


Thanks for your submission!

问题:
Superprime Rib
Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:

     7  3  3  1

The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.

Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.

The number 1 (by itself) is not a prime number.

PROGRAM NAME: sprime
INPUT FORMAT
A single line with the number N.
SAMPLE INPUT (file sprime.in)
4

OUTPUT FORMAT
The superprime ribs of length N, printed in ascending order one per line.
SAMPLE OUTPUT (file sprime.out)
2333
2339
2393
2399
2939
3119
3137
3733
3739
3793
3797
5939
7193
7331
7333
7393


我的程序:
/*
ID: yunleis2
PROG: sprime
LANG: C++
*/
#include<iostream>
#include<fstream>
#include<vector>
using namespace std;

int single[]={
 1,3,5,7,9
};
vector<int > v;
void check(int depth,int num);
bool isprime(int num);
void quicksort(int * a,int p,int r);
int main()
{
 fstream fin("sprime.in",ios::in);
 int N;
 fin>>N;
 int num;
 check(N,0);
 int *result=new int[v.size()];
 for(int i=0;i<v.size();i++)
 {
  result[i]=v.at(i);
 }
 quicksort(result,0,v.size()-1);
 fstream fout("sprime.out",ios::out);
 for(int i=0;i<v.size();i++)
  fout<<result[i]<<endl;
 

}
bool isprime(int num)
{
 if(num==1)
  return false;
 if(num==2)
  return true;
 for(int i=2;i*i<=num;i++)
 {
  if(num%i==0)
   return false;
 }
 return true;
}
void check(int depth,int num)
{
  if(depth==0)
 {
  v.push_back(num);
  return;
 }
 for(int i=0;i<(sizeof(single)/sizeof(int));i++)
 {
  int newnum=num*10+single[i];
  if(isprime(newnum))
   check(depth-1,newnum);
 }
 if(num==0)
  check(depth-1,2);
}


void swap(int * x,int * y)
{
 int t=*x;
 *x=*y;
 *y=t;
}
int partition(int* a,int p,int r)
{
 int i=p-1;
 int x=a[r];
 for(int j=p;j<r;j++)
 {
  if(a[j]<=x)
  {
   i++;
   swap(a+j,a+i);
  }
 }
 swap(a+i+1,a+r);return i+1;
}
void quicksort(int * a,int p,int r)
{
 if(p<r)
 {
  int q=partition(a,p,r);
  quicksort(a,p,q-1);
  quicksort(a,q+1,r);
 }
}


usaco的解法:
We use a recursive search to build superprimes of length n from superprimes of length n-1 by adding a 1, 3, 7, or 9. (Numbers ending in any other digit are divisible by 2 or 5.) Since there are so few numbers being tested, a simple primality test suffices.

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>

FILE *fout;

int
isprime(int n)
{
 int i;

 if(n == 2)
  return 1;

 if(n%2 == 0)
  return 0;

 for(i=3; i*i <= n; i+=2)
  if(n%i == 0)
   return 0;

 return 1;
}

/* print all sprimes possible by adding ndigit digits to the number n */
void
sprime(int n, int ndigit)
{
 if(ndigit == 0) {
  fprintf(fout, "%d\n", n);
  return;
 }

 n *= 10;
 if(isprime(n+1))
  sprime(n+1, ndigit-1);
 if(isprime(n+3))
  sprime(n+3, ndigit-1);
 if(isprime(n+7))
  sprime(n+7, ndigit-1);
 if(isprime(n+9))
  sprime(n+9, ndigit-1);
}

void
main(void)
{
 int n;
 FILE *fin;

 fin = fopen("sprime.in", "r");
 assert(fin != NULL);
 fout = fopen("sprime.out", "w");
 assert(fout != NULL);

 fscanf(fin, "%d", &n);

 sprime(2, n-1);
 sprime(3, n-1);
 sprime(5, n-1);
 sprime(7, n-1);
 exit (0);
}

 

 

 

目录
相关文章
|
2月前
|
C++
【PTA】L1-046 整除光棍(C++)
【PTA】L1-046 整除光棍(C++)
19 1
|
3月前
|
算法
HJ108 求最小公倍数
HJ108 求最小公倍数
30 0
|
3月前
PTA-求指定范围内的素数
求指定范围内的素数
51 0
|
3月前
PTA-求100以内的素数
求100以内的素数
35 0
|
10月前
|
算法
华为机试HJ108:求最小公倍数
华为机试HJ108:求最小公倍数
|
9月前
|
Java
hdu 1262 寻找素数对
hdu 1262 寻找素数对
29 0
|
9月前
hdu1406 完数 (水题)
hdu1406 完数 (水题)
37 0
PTA 7-4 素数等差数列 (20 分)
2004 年,陶哲轩(Terence Tao)和本·格林(Ben Green)证明了:对于任意大的 n,均存在 n 项全由素数组成的等差数列。
93 0
P5705 【深基2.例7】数字反转
P5705 【深基2.例7】数字反转
113 0