开发者社区> 橘子红了呐> 正文

CentOS 7 安装Mono 和 MonoDevelop

简介:
+关注继续查看

【原文来自:http://www.linuxidc.com/Linux/2015-01/112350.htm】

好几年前安装过mono,后来一直没有再用过。最近购买了新服务器,想再安装一个试试,先安装了最新的CentOS 7.2 ,然后按照搜索到的文章来做,很不幸,几乎都不成功,有些源的包依赖关系解析中断,后来终于找到了上面的文章,现在列出所有的步骤:

本次所有操作在root模式下

1.执行  rpm --import "http://keyserver.Ubuntu.com/pks/lookup?op=get&search=0x3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF"

2.执行  yum-config-manager --add-repo http://download.mono-project.com/repo/centos/

1-2 添加mono安装使用的资源环境

3.执行 yum install mono  按照提示安装所以安装包

4.安装libgdiplus

  a. mkdir /var/local/src                                 创建文件夹

  b. cd /var/local/src                                   进入创建文件

  c. wget http://download.mono-project.com/sources/libgdiplus/libgdiplus-3.12.tar.gz     下载文件

  d. tar -zxvf libgdiplus-3.12.tar.gz                              解压下载文件

  e. cd libgdiplus-3.12                                       进入解压文件夹

  f. ./configure                                         对安装程序进行配置

  g. make && make install                                    编译并安装

5.安装gtk-sharp

   a. cd /var/local/src                                              进入创建文件

  b. wget http://download.mono-project.com/sources/gtk-sharp212/gtk-sharp-2.12.26.tar.gz     下载文件

  c. tar -zxvf gtk-sharp-2.12.26.tar.gz                                       解压下载文件

  d. cd gtk-sharp-2.12.26                                             进入解压文件夹

  e. ./configure                                                   对安装程序进行配置

  f. make && make install                                              编译并安装

6.安装monodevelop yum install monodevelop

【安装第6步没有成功,源码依赖关系解析失败】

7,测试mono环境:

复制代码
[root@CentOS Test]# mono -V
Mono JIT compiler version 4.2.1 (Stable 4.2.1.102/6dd2d0d Thu Nov 12 04:43:41 EST 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen
复制代码

 

8,运行一个.net测试程序:

复制代码
[root@CentOS Test]# mono dotNetTest.exe
OS 版本:Unix 3.10.0.327
.NET 版本:4.0.30319.17020

Hello,测试程序
复制代码

终于解决困扰了近一天的问题。

 9,升级Jexus

请教 Jexus作者后,他说可以支持在线升级的,下面贴出他给的方法:

简单的办法就是在线更新到5.8.1,然后在windows上下载5.8.1,解压后,把data文件夹中的exe和dll上传到服务器jexus的文件夹,覆盖文件,然后:
sudo ./jws stop
sudo killall -9 mono
sudo ./jws regsvr
sudo ./jws start
 
在线升级的命令是:
sudo curl jexus.org/5.8.x/upgrade|sh
注:这个命令只能用于jexus被安装在/usr/jexus 文件夹这个路径,另外,这样升级的版本是5.8.0
 
 

 

    本文转自深蓝医生博客园博客,原文链接:http://www.cnblogs.com/bluedoctor/p/5056719.html,如需转载请自行联系原作者



版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
CentOS 6.5安装二进制版本的MongoDB 2.6
CentOS 6.5安装二进制版本的MongoDB 2.6 MongoDB的国外镜像访问非常慢,以至于选择MongoDB官网的在线安装很不靠谱。那么,我们可以选择安装MongoDB 2.6的二进制发布包。
802 0
Windows下安装weblogic dev版本
在开发过程中,有一种情况是比较尴尬的:需要用到某个软件,但是只需要用到这个软件中的一小部分功能,这样既浪费的磁盘空间,又浪费了CPU空间。比如Weblogic,完整版包括很多功能,但是开发过程中,只是需要创建数据源、部署项目,然后进行测试即可。所以开发过程中,需要一款简化的Weblogic(Weblogic开发版)是挺有必要的(如果电脑配置比较壕,也可以任性的使用完整版)。
66 0
PostgreSQL和Slony-I的安装和配置
PostgreSQL和Slony-I的安装和配置 Published by wesley.he May 12th, 2008 in icyriver and technique. 浏览次数: 12277 Tags: icyriver, internet, postgresql, programming, technique. 随着Mysql被Sun收购,不少web开发者和架构师开始关注PostgreSQL。
781 0
Centos7 安装 nodejs
https://nodejs.org/en/download/package-manager/ 设置node v4的源 curl --silent --location https://rpm.nodesource.
615 0
安装PageAdmin Cms时候“System.ServiceModel.Activation.HttpModule”错误的解决办法
未能从程序集“System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”中加载类型“System.ServiceModel.Activation.HttpModule”。
1122 0
3402
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
OceanBase 入门到实战教程
立即下载
阿里云图数据库GDB,加速开启“图智”未来.ppt
立即下载
实时数仓Hologres技术实战一本通2.0版(下)
立即下载