DFS PKU 1562

简介:

简单地DFS

Oil Deposits
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12801   Accepted: 6998

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
//#include <map>
using namespace std;
#define MAXN 100 + 10
char map[MAXN][MAXN];
int vis[MAXN][MAXN];
int m,n;
//int count;
int xx[8] = {-1,-1,0,1,1,1,0,-1};
int yy[8] = {0,1,1,1,0,-1,-1,-1};

void DFS(int x,int y){
    int i;
    for(i=0;i<8;i++){
        int dx = x+xx[i];
        int dy = y+yy[i];
        if(dx>=0 && dx<m && dy>=0 && dy<n){
            if(map[dx][dy]=='@' && vis[dx][dy]==0){
                vis[dx][dy] = 1;
                DFS(dx,dy);
                //vis[dx][dy] = 0;
            }
        }
    }

    return ;
}

int main(){
    int i,j;
    int ans;

    while(~scanf("%d%d",&m,&n)){
        if(m==0 && n==0){
            break;
        }
        for(i=0;i<m;i++){
            scanf("%s",map[i]);
        }
        ans = 0;
        memset(vis,0,sizeof(vis));
        for(i=0;i<m;i++){
            for(j=0;j<n;j++){
                if(map[i][j]=='@' && vis[i][j]==0){
                    vis[i][j] = 1;
                    ans++;
                    DFS(i,j);
                    //vis[i][j] = 0;
                }
            }
        }
        printf("%d\n",ans);
    }
}


版权声明:本文博客原创文章。博客,未经同意,不得转载。








本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4629750.html,如需转载请自行联系原作者


相关文章
|
2月前
|
算法
DFS算法的实现
DFS算法的实现
38 3
|
4月前
|
C++
|
4月前
|
算法
DFS算法及应用(一)
DFS(深度优先搜索)是一种图遍历算法,常用于解决穷举问题,如全排列、迷宫问题、图的连通性等。它沿着树的深度分支进行探索,直至达到叶子节点,若无法继续则回溯。例如,将数字6拆分为3个正整数的递增序列问题可以通过DFS实现,类似地,分糖果问题和买瓜问题同样可以用DFS求解。DFS通常涉及递归或栈结构,通过标记已访问节点避免重复。在编程中,会定义递归函数,设定结束条件,然后枚举可能的情况,并处理下一层节点。
|
4月前
|
算法 索引
DFS算法及应用(二)
回溯:回溯就是DFS的一种,在搜索探索过程中寻找问题的解,当发现不满足求解条件时,就回溯返回,尝试其他路径。
|
机器学习/深度学习 人工智能 定位技术
|
算法
DFS and BFS
DFS and BFS
46 0
|
定位技术
DFS:踏青
DFS:踏青