CentOS升级MySQL到5.5-阿里云开发者社区

开发者社区> 数据库> 正文

CentOS升级MySQL到5.5

简介:

centOS的yum安装的MySQL是5.1版本,可通过官方的rpm包安装5.5版本

复制代码
# 查看安装的相关项
rpm -qa|grep -i mysql
# 停止服务
service mysqld stop
# 卸载
yum remove mysql-*
or
rpm -e xxx
# 下载MySQL5.5
wget -c http://cdn.mysql.com/Downloads/MySQL-5.5/MySQL-5.5.40-1.el6.x86_64.rpm-bundle.tar
# 解压
tar -xvf xxx.tar
# 安装
rpm -ivh MySQL-server-5.5.40-1.el6.x86_64.rpm MySQL-devel-5.5.40-1.el6.x86_64.rpm MySQL-client-5.5.40-1.el6.x86_64.rpm
# 升级
service mysql start
mysql_upgrade -u root -p
复制代码

yum安装的mysql服务名为mysqld,通过rpm安装的服务名mysql

ps: 通过rpm安装的MySQL 5.6,发现通过C#(MySql.Data.dll)写入中文时总提示"invalid value",安装MySQL-Python时也总是提示各种错误和兼容性问题,安装5.5版本后解决。

MySQL 5.5版本开始才支持Limit可带变量,旧版本只能通过PREPARE 实现。

 

-- 2015.5.19 更新

# 安装是有冲突,先移除旧版本的库
yum -y remove mysql-libs-5.1.73*

# 新的下载地址
http://dev.mysql.com/downloads/mysql/5.5.html?os=31
本文转自chy710博客园博客,原文链接:http://www.cnblogs.com/chy710/p/4022390.html,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
数据库
使用钉钉扫一扫加入圈子
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

其他文章