开发者社区> goodboy_heyang> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

CocoaPods的安装(图文并茂)OS X 10.11 系统

简介:
+关注继续查看

先给一个挺不错的关于CocoaPods的安装和使用的简书博客(点击图片就能跳转网页):

这篇博文在CocoaPods的安装使用方面还是很全面的,不过还是有是有欠缺的地方,这个欠缺的地方主要原因就是苹果系统的更新,更新到EI Capitan,相关的目录换了

这里主要的就是旧版本的系统的/usr/bin安装目录,现在变成了/usr/local/bin。而默认通过终端的install目录是下载相关文件到/usr/bin。所以

《CocoaPods的安装使用和常见问题》中有一个步骤需要注意,这个注意也是我通过Google搜索来的:

所以那么就安装的步骤就按着我下面的步骤来吧,不过关于更多的问题解决请参考《CocoaPods的安装使用和常见问题》,因为本人还没有遇到那么多的问题,我就偷懒不整那么多啦,不好意西啊:

这里正式开始安装:

打开终端,怎么打开终端随你们自己,我个人习惯输入快捷键:control + 空格键 ,然后在弹出的搜索框里输入英文的 ter ,然后立马按回车就OK了。

1.先升级Gem
 sudo gem update --system
2.切换cocoapods的数据源
 【先删除,再添加,查看】
 gem sources --remove https://rubygems.org/
 gem sources -a https://ruby.taobao.org/
 gem sources -l
3.安装cocoapods
 sudo gem install cocoapods
 或者(如10.11系统)sudo gem install -n /usr/local/bin cocoapods
下面的第四步直接跳过,现在不需要了(更新时间:2016年1月19日)
因为下面的两个连接现在已经失效了

4.将Podspec文件托管地址从github切换到国内的oschina
 【先删除,再添加,再更新】
 pod repo remove master
 pod repo add master http://git.oschina.net/akuandev/Specs.git
 pod repo add master https://gitcafe.com/akuandev/Specs.git
 pod repo update

5.设置pod仓库 pod setup
6.测试 【如果有版本号,则说明已经安装成功】 pod --version
7.利用cocoapods来安装第三方框架 01 进入要安装框架的项目的.xcodeproj同级文件夹 02 在该文件夹中新建一个文件podfile 03 在文件中告诉cocoapods需要安装的框架信息 a.该框架支持的平台 b.适用的iOS版本 c.框架的名称 d.框架的版本
关于使用cocoapods安装第三方框架可以直接看我的下一篇图文并茂的博文使用详解《CocoaPods的使用 OS X 10.11系统
8.安装 pod install --no-repo-update pod update --no-repo-update 9.说明 platform :ios, '8.0' 用来设置所有第三方库所支持的iOS最低版本 pod 'SDWebImage','~>2.6' 设置框架的名称和版本号 版本号的规则: '>1.0' 可以安装任何高于1.0的版本 '>=1.0' 可以安装任何高于或等于1.0的版本 '<1.0' 任何低于1.0的版本 '<=1.0' 任何低于或等于1.0的版本 '~>0.1' 任何高于或等于0.1的版本,但是不包含高于1.0的版本 '~>0' 任何版本,相当于不指定版本,默认采用最新版本号 10.使用pod install命令安装框架后的大致过程: 01 分析依赖:该步骤会分析Podfile,查看不同类库之间的依赖情况。如果有多个类库依赖于同一个类库,但是依赖于不同的版本,那么cocoaPods会自动设置一个兼容的版本。 02 下载依赖:根据分析依赖的结果,下载指定版本的类库到本地项目中。 03 生成Pods项目:创建一个Pods项目专门用来编译和管理第三方框架,CocoaPods会将所需的框架,库等内容添加到项目中,并且进行相应的配置。 04 整合Pods项目:将Pods和项目整合到一个工作空间中,并且设置文件链接。

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
ECS安装Fedora CoreOS操作系统版本34
ECS安装Fedora CoreOS操作系统版本34
82 0
MacOs安装Kafka
一、安装kafka brew install kafka
149 0
Mac安装vue.js开发环境
本来以为在Mac上搭建vue.js的环境挺简单的,谁知遇到各种问题(可能是RP问题),网上解决的方法也寥寥无几,这里就记录下遇到的坑。
283 0
[cocos2dx]mac xcode安装cocos2dx开发环境
下载好cocos2d-x-2.1.4,然后在./install-templates-xcode.sh -u -f 会发现就安装好了cocos2dx的模板
714 0
243
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载