POJ 1222 EXTENDED LIGHTS OUT

简介:

XOR高斯消元:

开启和关闭围绕每个灯5一个格子的影响,选择一些光线,使所有的灯关闭.

能够构建一个每一个灯对周围影响的30×30矩阵。矩阵的值等于原来的状态。

再用高斯消元求解每一个灯的状态。


EXTENDED LIGHTS OUT
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6442   Accepted: 4228

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source

[Submit]   [Go Back]   [Status]   [Discuss]




#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int a[40][40],ans[40];

void Gauss()
{
    for(int k=0;k<30;k++)
    {
        int mx=k;
        for(int i=k+1;i<30;i++)
            if(a[i][k]>a[mx][k])
                mx=i;
        if(mx)
        {
            for(int i=0;i<=30;i++)
                swap(a[mx][i],a[k][i]);
        }
        for(int i=0;i<30;i++)
        {
            if(i==k) continue;
            if(a[i][k])
            {
                for(int j=k;j<=30;j++)
                {
                    a[i][j]^=a[k][j];
                }
            }
        }
    }
    for(int i=0;i<30;i++) ans[i]=a[i][30];
}

int main()
{
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        memset(a,0,sizeof(a));
        memset(ans,0,sizeof(ans));
        for(int i=0;i<5;i++)
        {
            for(int j=0;j<6;j++)
            {
                scanf("%d",&a[j+i*6][30]);
                a[j+i*6][j+i*6]=1;
                if(i-1>=0)
                    a[j+i*6][j+6*(i-1)]=1;
                if(i+1<5)
                    a[j+i*6][j+6*(i+1)]=1;
                if(j-1>=0)
                    a[j+i*6][j-1+i*6]=1;
                if(j+1<6)
                    a[j+i*6][j+1+i*6]=1;
            }
        }
        Gauss();
        printf("PUZZLE #%d\n",cas++);
        for(int i=0;i<30;i++)
        {
            if(i%6) putchar(32);
            printf("%d",ans[i]);
            if((i+1)%6==0) putchar(10);
        }
    }
    return 0;
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。







本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4719158.html,如需转载请自行联系原作者


相关文章
|
算法
poj 3625 Building Roads
点击打开链接poj 3625 思路:最小生成树+prim分析:         1 由于点有1000,如果要用kruskal的话最少有1000000条边,所以我么选择用prim算法         2 题目中的点的坐标最大值为10^6,那么如果在平方一下的话会超过int,所以在求两个点之间的距离的时候用在前面乘上一个1.0这样就表示的double从而不会超过int了。
820 0
poj 1787 Charlie's Change
思路: 多重背包 分析: 1 题目给定的数据明显就是多重背包,但是题目有个难点就是输出路径,0/1背包里面有输出路经的方法,做法做法是通过记录前面的状态 2 这一题还要求输出每种硬币的个数,那么这边利用mark数组,mark[i][0] ...
993 0
|
C++
Brute Force & STL --- UVA 146 ID Codes
 ID Codes    Problem's Link:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=3&problem=82&mosmsg=Submission+received+with+ID+14418598  Mean:   求出可重排列的下一个排列。
890 0

热门文章

最新文章